-   Linux - Networking (
-   -   windows7 host, virtual box linux guest, trying to do samba (

glorsplitz 12-26-2009 10:41 PM

windows7 host, virtual box linux guest, trying to do samba
hi, windows 7 host, virtualbox 3.0.12, slackware 12.2 guest

i have virtualbox/slackware guest using dhcp and has a 10.0.... ip address

rc.firewall on gateway has for local_net

how can i get the 192.... range to play samba with 10.... range?

i know i can get at host files using shared folders, i'd like to
get at network folders from the slackware guest

is it possible to static a guest 192.... ip address and not use dhcp? or some other config, like spoof the dhcp ip to 192....

i can provide additional info as needed

thank you

glorsplitz 12-27-2009 02:25 PM

i look into different ways of setting up nic within virtualbox to facilitate host/guest networking and dont feel like messing with it, i'm just going to use virtualbox shared folders

scheidel21 12-28-2009 09:12 AM

Well you could do host only networking and put a proxy on the host to proxy requests from the guest. You could also use bridged networking placing the guest on the same subnet and network as the host. Additionally with NAT networking you can go out but not come back. i.e. if guest network is 10.10.10.x and host network is 192.168.100.x I can access 192.168.100.x from the guest network but cannot access the guest network from the host network. So with this in mind, if you had a DNS server on the host network for instance typing a host DNS name into the guest browser would connect you to the host on the VM host network.

glorsplitz 12-28-2009 04:43 PM

hi scheidel21, thanks for your suggestions

i just wanted to try samba with the virtualbox/slackware setup if it didnt take too much trouble as i'm not that network experienced, i may follow up on what you said as i have time

scheidel21 12-29-2009 08:33 AM

The easiest thing is to bridge your virtual adapter then they will be able to see each other only takes like 5 minutes to shut down VM change setting start-up again.

glorsplitz 12-29-2009 08:52 PM

hi again scheidel21, got it working! thanks for your follow up

changed nic to bridge in vbox settings, changed dhcp to static in nic conf, started samba, i can now access all my shares

didnt think it would be so simple


All times are GMT -5. The time now is 03:30 PM.