LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-18-2004, 03:35 AM   #1
emailssent
Member
 
Registered: Sep 2004
Posts: 312

Rep: Reputation: 30
windows share automatically mount on linux box


i have samba server configured on mandrake 9.2 and client is window98 ,

i want the windows share automatically mount on linux box on its boot.

so, what entry should i have to put in /etc/fstab file to automatically mount windows share on linux box


-jack
 
Old 09-18-2004, 07:38 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Take a look at this wiki article:
http://wiki.linuxquestions.org/wiki/...cally_at_boot?
 
Old 09-18-2004, 09:29 AM   #3
emailssent
Member
 
Registered: Sep 2004
Posts: 312

Original Poster
Rep: Reputation: 30
I read that and i have added this line /etc/fstab
but it doesn't worked

//192.168.1.1/C /home/emailssent/mnt/C5M9X2/C smbfs rw 0 0
 
Old 09-18-2004, 09:31 AM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
What happens if you run:
mount -t smbfs //192.168.1.1/C /home/emailssent/mnt/C5M9X2/C

Does it mount straight away or ask for a password etc?
 
Old 09-18-2004, 01:05 PM   #5
emailssent
Member
 
Registered: Sep 2004
Posts: 312

Original Poster
Rep: Reputation: 30
when mount with the ip

it says,


# mount -t smbfs //192.168.1.1/C /home/emailssent/mnt/C5M9X2/C

4465: session request to 192.168.1.1 failed (Called name not present)
4465: session request to 192 failed (Called name not present)
4465: session request to *SMBSERVER failed (Called name not present)
SMB connection failed

but when i access it through machine name

# mount -t smbfs //C5M9X2/C /home/akshat/mnt/C5M9X2/C
passwd:

why it is not mount with ip, even this ip is mapped with its name in /etc/hosts file

what should write in /etc/fstab entry for fullfiling its password requirement

#/etc/fstab
//C5M9X2/C /home/emailssent/mnt/C5M9X2/C smbfs rw 0 0
 
Old 09-18-2004, 02:27 PM   #6
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
Quote:
what should write in /etc/fstab entry for fullfiling its password requirement

#/etc/fstab
//C5M9X2/C /home/emailssent/mnt/C5M9X2/C smbfs rw 0 0
Try This....

//C5M9X2/C /home/emailssent/mnt/C5M9X2/C smbfs rw,username=abc,password=test 0 0

where 'abc' is your user on the windows machine and 'test' is that user's password....


--amit
 
Old 09-19-2004, 10:11 PM   #7
emailssent
Member
 
Registered: Sep 2004
Posts: 312

Original Poster
Rep: Reputation: 30
it doesn't worked, share is not automatically mounted on linux box,

any other idea ?
 
Old 09-20-2004, 06:22 AM   #8
vald
LQ Newbie
 
Registered: Sep 2004
Location: Bulgaria
Distribution: Fedora
Posts: 14

Rep: Reputation: 0
I think in you must add "_netdev" in mount options to force mounting of this device after network:

Code:
//C5M9X2/C /home/emailssent/mnt/C5M9X2/C smbfs rw,_netdev,username=abc,password=test  0 0
 
Old 09-21-2004, 09:26 PM   #9
emailssent
Member
 
Registered: Sep 2004
Posts: 312

Original Poster
Rep: Reputation: 30
dump,

_netdev doesn't worked


any more ideas,
 
Old 10-21-2004, 02:52 AM   #10
Kabuto
Member
 
Registered: May 2004
Location: Istanbul, Turkey
Distribution: Gentoo as host OS and Redhat as guest OS
Posts: 34

Rep: Reputation: 15
Question

//campus01/mtozses /home/mtozses/T smbfs rw,user,username=abd,password=****** 0 0

timed out but still worked for me, but it is mounted as root. is there a way to mount it as mtozses so that I don't have to su - root everytime? also is there a way to make the server not timeout?
 
Old 10-21-2004, 03:07 AM   #11
BillJennings
Member
 
Registered: Oct 2004
Location: Big River, California, USA
Distribution: Debian
Posts: 48

Rep: Reputation: 15
You could try adding ",ip=192.168.1.1" to the options list if you're sure this is the IP address of the windoze box.

To make the mounted filesystem owned by a user other than root, add ",uid=xxx,gid=yyy" (remember, no spaces in the options list) to the list of options (where xxx is the uid of the desired owner and yyy is the gid of the desired group).

Hope this helps.

Bill Jennings
 
Old 11-01-2004, 04:02 AM   #12
Kabuto
Member
 
Registered: May 2004
Location: Istanbul, Turkey
Distribution: Gentoo as host OS and Redhat as guest OS
Posts: 34

Rep: Reputation: 15
uid=xxx,gid=yyy worked man. Thanks a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Share Windows modem connection with Linux box? Toronto Linux - Networking 3 09-18-2005 02:13 AM
acces windows share from my linux box jb_jauvin Slackware 6 03-30-2005 09:00 PM
Can't mount pc share on Red Hat 6.1 box kraid Linux - Networking 2 11-16-2004 10:15 AM
Can't see Windows-share automatically (SuSE 9.0) Sika Linux - Networking 2 09-05-2004 03:16 PM
(Windows) Only one Linux box can mount a smb share Artimus General 1 07-21-2004 01:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration