LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-29-2004, 12:11 AM   #1
Nexgen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Rep: Reputation: 0
Windows machines cannot locate server by hostname


Hi, I am a Linux

I have a Fedora box on a Windows network. It's IP is assigned dynamically through DHCP. It is able to connect to the internet. The hostname is set to 'Datamaster' and the domain name is left blank. I have samba services up and running.

The problem I am facing is that from any other Windows box, I cannot 'ping Datamaster'. I can ping it by IP, but not by the hostname. What's more confusing is that it shows up on the Network Neighbourhood (as Datamaster), but I can't access any shared folders on it, nor can I do a "net use".

I suspect this might be because I changed the hostname from 'localhost.localdomain' to 'Datamaster'. I have changed the files /etc/sysconfig/network-scripts/ifcfg-eth0, as well as /etc/sysconfig/network

My /etc/hosts looks like:

127.0.0.1 localhost


I have also tried putting in Datamaster as an alias in that file, but it did not do anything.

Would anybody be able to shed some light on what went wrong?
 
Old 04-29-2004, 01:22 AM   #2
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Rep: Reputation: 30
Hi.

If you run 'neat' as superuser and click 'Edit' on your eth0 device. Have you got anything in the Hostname (optional) value? If not this is where the DHCP server grabs your hostname from. From what I understand the DHCP server doesn't grab the hostname from your localhost hostname. (Please correct me if I'm wrong anyone).

If it is blank put Datamaster in there and do a service network restart.

The reason you are seeing it in Network Neighbourhood is because you have the samba up and running and it is getting the samba name from the 'server string = Datamaster'
in your smb.conf file.

Let me know how you get on.

>Craig

PS. Give it 10 or so minutes as the DHCP will have to update your DNS server.
 
Old 04-29-2004, 01:59 AM   #3
Nexgen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Thank you Craig,

I ran neat and true enough, the Hostname field was blank. So I filled it in and saved. Restarted the network service, waited, rebooted the whole machine, waited..... unfortunately it still refused to work for me.

Any other ideas?
 
Old 04-29-2004, 02:07 AM   #4
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Rep: Reputation: 30
Thats strange. I used to have the problem until I did that.

Have you access to the DNS server at your place? If you do you might want to see if it has added the entry to the records. Also check to see if you can find out how often your DNS updates its records. I know our server has been set up to update itself every 30 minutes.

You could always just manually add the record. However you shouldn't need to.

I've got no other ideas sorry. I had the identical problem few months back, but this got it working.

There are alot of people on here that know alot more than I do, they might have some ideas for you to try.

Sorry again.

>Craig
 
Old 04-29-2004, 02:14 AM   #5
Nexgen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Unfortunately, I don't have access to the DHCP server, so I can't tweak or check it that way. I'll check it again in a few hours just to be sure.

Last edited by Nexgen; 04-29-2004 at 02:16 AM.
 
Old 04-29-2004, 02:32 AM   #6
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Rep: Reputation: 30
Cool. let me know how you go anyway : )
 
Old 04-29-2004, 06:27 AM   #7
toniwong
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Rep: Reputation: 0
Hi, I also have this problem.

I can see the samba server in network neighbourhood.
But I can't access it.

So, I want to know can it set in Webmin ?!

Thanks~
 
Old 04-29-2004, 08:53 AM   #8
gauge73
Member
 
Registered: Jan 2003
Location: Dallas, TX
Distribution: Fedora Core 4
Posts: 420

Rep: Reputation: 30
I had this issue at home a year or so ago. The only way I was able to solve it was to make the Linux machine a PDC. After that everything worked just fine. I didn't make any of the other machines on the network members of the domain, just had them logon to it.
 
Old 04-29-2004, 09:24 PM   #9
Nexgen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Currently re-installing Fedora (since I can because it's new) and trying this again.

Last edited by Nexgen; 04-29-2004 at 09:27 PM.
 
Old 04-30-2004, 03:55 AM   #10
metalick
Member
 
Registered: Apr 2004
Location: Zagreb, Croatia
Distribution: SuSE 9.0
Posts: 44

Rep: Reputation: 15
Try static IP address.
Also, try to install the newest version of Samba. And configure it with swap (http://localhost:901).
Through this configuration utility you can do almost anything.
 
Old 04-30-2004, 10:52 AM   #11
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
About half the time, Samba problems are due to firewall issues. Stop the iptables service on the linux box, stop the window’s firewall and retest the connection.

Any time you are trying to troubleshoot a network problem, the first thing you should do is to shut down the firewalls and see if they are causing the problem.
 
Old 05-03-2004, 04:48 AM   #12
Nexgen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Found the solution! All I did was configure and enable lisa. Not sure why it worked, but it did!
Thanks for your inputs!
 
Old 08-03-2004, 09:44 PM   #13
mosteal
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Rep: Reputation: 0
how do you configure 'lisa'

"Found the solution! All I did was configure and enable lisa. Not sure why it worked, but it did!
Thanks for your inputs!"

You recently wrote this while fixing your samba setup--being a newbie--how exactly do you configure and enable 'lisa'? Having the same errors setting up samba--don't know what to do. I get it in the Network neighborhood to setup right--but i get the dreaded error of network not found.

Mosteal
 
Old 08-03-2004, 09:45 PM   #14
mosteal
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Rep: Reputation: 0
Same

Also--how do you turn off firewalls? it is possibe using a router?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I see my Linux server from Windows client machines? easwaran Linux - Networking 5 10-13-2004 04:03 PM
Linux machines cant ping server..Windows can. NetAX Linux - Networking 1 05-21-2004 09:55 AM
problem seeing Samba server from Windows machines kenviro Linux - Networking 11 08-18-2003 12:04 AM
Can't ping windows machines by hostname explorer Linux - Networking 10 03-06-2003 12:44 PM
Can I use Mandrake 8.1 to act as a server for two windows machines? GWS Linux - Networking 8 01-20-2002 11:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration