-   Linux - Networking (
-   -   Windows don't like ProFTPD? :/ (

Barca 01-11-2005 01:39 PM

Windows don't like ProFTPD? :/
I have newest proftpd installed. When I log in on my ftp from others linux machines, everything works great. Problem is, when on the client side is installed Microsoft Windows :/
I tried to login by IE, ftp command, Total Commaned and FlashFXP and there is always the same problem. I can log in, but listing of files always fails. All of those programs "think" and "think" and nothing happens. After 120 seconds, proftpd disconnect them.
Why can't I see any files? It happens on all accounts. For example (ftp command):

Microsoft Windows 2000 [Wersja 5.00.2195]
(C) Copyright 1985-1999 Microsoft Corp.

ftp> open **.**.**.** 5021
Połączony z **.**.**.**.
220 ::: Campnou FTP :::
Użytkownik (**.**.**.**:(none)): ****
331 Password required for go
230 User gosc logged in.
ftp> ls
200 PORT command successful
450 No files found
ftp> ls
200 PORT command successful
>>> here he waits 120 seconds and I'm getting mad ;) <<<
421 no Transfer Timeout (120 seconds): closing control connection

Thx for your help :)

PS I thought about one thing... I run my ftp on port 5021 because I haven't public IP, but I have ports 5000-6000 forwarded. Maybe it's the cause? When I connect by FlashFXP, he says sth about two ports which are beyond that range... Have I to forward any other ports? I'll try to log in to my ftp from windows in the same lan to see if my hypothese is true...

BinaryBob 01-11-2005 03:11 PM

Going by your last paragraph - Have you tried setting the cleints to only use ports in the 5000-6000 range? Some of them allow for that. Also, have you tried, passive, and active modes?

Good Luck!

Barca 01-11-2005 03:33 PM

I was right. When I log to my ftp from machine with Windows, which is located in the same LAN, everything goes fine. But, I sniffed with Ethereal, and Windows machine use only 5021 port to connect... So what's going on?
Idea with passive and active modes looks good for me, I'll try. Thanks for advice, BinaryBob :)

Anyone else, please? :)


Yeah, the problem was in range of ports used to passive connection. I had to add to my proftpd.conf:

PassivePorts 5000 6000
MasqueradeAddress # my public IP

And now it works :) Thank you.

All times are GMT -5. The time now is 06:57 PM.