-   Linux - Networking (
-   -   windows does not resolve linux hostname (

abrb220 05-17-2004 08:59 AM

windows does not resolve linux hostname
I have 3 linux boxes on a mostly windows machines lan.
We run dhcp. I have not got access to the dhcp machine.

From my linux boxes i can resolve all the windows machines by name.

However if i try to ping the linux boxes by name it does not resolve and
comes back with unknown host.

We get our dns info from the dhcp server.
How do I configure my linux boxes to tell the dhcp server to update the dns
server with their names?


onnyloh 05-17-2004 10:08 AM

are your using samba?

abrb220 05-17-2004 10:17 AM

I do not want to share drives, so I do not think i need it.Could be wrong though.


carlmarshall 05-17-2004 10:48 AM

If your trying a line such as:


then you'll need a DNS A record in the zone file for this host, otherwise it can't resolve the host name.

Windows uses an lmhosts file or a wins server or a broadcast to resolve a name to an IP address. To do this with Linux you need to install samba and configure this to act in the same manner.


abrb220 05-18-2004 03:18 AM

I am going to install and configure Samba on one of the boxes.

Will update later.

muse 05-18-2004 03:45 AM

modify /etc/sysconfig/network-scripts/ifcfg-eth0:

and restart the network service, let the dhcp server take a while to update dns record.

abrb220 05-18-2004 05:11 AM

Tried it, but it does not seem to work.
Also tried putting the following in /etc/dhclient-eth0.conf

send fqdn.fqdn ""
send fqdn.encoded off /on
send fqdn.server-update on / off

According to the man page for dhclient.conf this should let the dhcp know to update the dns. The interface comes up but the problem still persists.

in /var/log/messages I see :

nazgul dhclient: if IN A rrset doesn't exist add 3600 IN A add 3600 IN TXT "00b58c3399805572d04df4e41b326777bc": ran out of space

So it looks like its trying to update but something is going wrong.

All times are GMT -5. The time now is 03:43 PM.