Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 10-02-2003, 05:13 PM   #1
LQ Newbie
Registered: Sep 2003
Location: Ogun state, Nigeria.
Posts: 16

Rep: Reputation: 0
windows clients unable to Browse

good day again

my windows (XP, 2000, 98, Me) clients unable to browse thru linux box. whereas the linux box which is the gateway can browse easily.

could the problem be ip masq or squid proxy!

pls reply ASAP

Old 10-04-2003, 06:01 AM   #2
Registered: Sep 2003
Location: Northants, UK
Distribution: RedHat 8, Damn Small
Posts: 39

Rep: Reputation: 15
Check net masks first to ensure they are all the same on every machine. Better still, set up DHCP somewhere and let PCs and workstations use that, leaving only static IP on gateway and dhcp server (which could be same machine.)

If you are using static IP address you must also set the default gateway address. If using DHCP, this info is dragged down from the DHCP server when the address is requested (and this is one of the reasons that even on a small network, DHCP starts to make sense quite quickly.)

Old 10-04-2003, 06:34 AM   #3
Senior Member
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 47
When you say 'browse' do you mean browse the web or browse for other machines using say Network Neighbourhood? If its browsing the local network for other machines then AshkeyK's comments are a good place to start, then check that you can ping the other boxes, then move onto your Samba config.

However if its that you can't browse the internet then you'll need to tell us a little more about how you have things configured. You mentioned both NAT and Squid - do you currently have a Squid proxy in place on your gateway machine? Are your other PCs set to use the proxy? If you are using NAT (IP Masquerading) to forward your other machines out onto the web then what IPTables rules are you using? How is your gateway machine connected out to the web?

Sorry to ask so many questions but we'll need to narrow down the problem before we can help!


Old 10-06-2003, 05:54 AM   #4
LQ Newbie
Registered: Sep 2003
Location: Ogun state, Nigeria.
Posts: 16

Original Poster
Rep: Reputation: 0
thanks jamie

I am using NAT not squid
iptable rules---

iptables --table nat --append POSTROUTING --out - interface eth0 -j MASQUERADE

iptables --append FORWARD --in - interface eth1 -j ACCEPT

echo 1 > /proc/sys/net/ipv4/ip_forward

my gateway settings are:
eth0 - ipaddr= ISP assigned
gateway $ dns name server = ISP assigned

eth1 - -


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to browse ALL webpages jr88 Slackware 6 10-27-2005 12:06 PM
Unable to browse the internet daliernest Linux - Newbie 2 08-12-2004 04:50 PM
Unable to browse internet windoze killa Linux - Networking 17 02-10-2004 03:53 AM
unable to browse samba share from windows 2003 kfloda Linux - Software 1 08-16-2003 07:14 AM
How to make clients browse the internet Gorchi Linux - Networking 0 03-13-2003 06:12 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration