LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-22-2016, 12:23 AM   #1
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 17.3
Posts: 86

Rep: Reputation: 15
Windows 10 dual boot turns off wifi switch on laptop for Linux Mint 17.2


I am having an odd problem with my Dual boot windows 10/Linux mint 17.2 installation on an old Lenovo C3000 N100 laptop. I use the Windows 10 bootloader to boot both OS's and have noticed recently that when booting and selecting which OS to boot, the laptop wifi led is lit. If I boot on into Windows 10 it stays active and wifi works normally. However, if I choose Linux Mint, the wifi led is immediately switched off (while still in Windows bootloader screen),and the system reboots via BIOS screen into Linux Mint. But when booting mint the wifi led stays off and will not come on again even if I toggle the hardware switch several times. Rebooting into windows and the wifi LED lights up normally and wifi works.

I am assuming the Windows bootloader is not playing nice, but don't know if that's the cause and certainly don't know how to resolve the issue.

Can anyone suggest a solution I could try? Configuring the wifi connection manually in Mint did not work as it simply did not "see" the wifi hardware and I could not toggle the wifi hardware switch at all until rebooting into Windows. Have tried resetting BIOS defaults - no change.
 
Old 01-22-2016, 12:27 AM   #2
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,675

Rep: Reputation: Disabled
Run rfkill from Linux.
 
Old 01-22-2016, 01:13 AM   #3
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 17.3
Posts: 86

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Emerson View Post
Run rfkill from Linux.
I did run rfkill:
Code:
rfkill list
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: phy1: Wireless LAN
	Soft blocked: no
	Hard blocked: no
 
Old 01-22-2016, 09:02 AM   #4
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,675

Rep: Reputation: Disabled
I have seen reports Windows drivers turning off wireless cards, the only solution provided was to remove Windows.
 
Old 01-22-2016, 09:27 AM   #5
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: Slackware Debian, Fedora, others
Posts: 7,470

Rep: Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619
Quote:
Configuring the wifi connection manually in Mint did not work as it simply did not "see" the wifi hardware
sounds like a driver or missing firmware issue. What is the specs on the wifi device?
 
Old 01-22-2016, 12:32 PM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053
i have a similar problem on one laptop, running linux only.
i did not find a solution.
i think it depends on the wifi hardware.
please post output of
Code:
lspci -k | grep -iE 'net|wifi'
 
Old 01-22-2016, 06:50 PM   #7
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 17.3
Posts: 86

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ondoho View Post
i have a similar problem on one laptop, running linux only.
i did not find a solution.
i think it depends on the wifi hardware.
please post output of
Code:
lspci -k | grep -iE 'net|wifi'
Code:
lspci -k |grep -iE 'net|wifi'
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)
I have managed to connect to the network using wicd-curses interface and static IP. The wifi hardware switch LED is lit when connection is up. So why doesn't network manager set this up at boot time properly? Is there a way of making it do this?

Last edited by gchandler; 01-22-2016 at 07:48 PM. Reason: Additional information
 
Old 01-23-2016, 04:01 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053
please don't mess around with wicd - it doesn't play well with networkmanager.
and why a static ip? i can't see how that would help.

actually my last request was wrong, it should have been:
Code:
lspci -k |grep -iEA5 'net|wifi'
because i'd like to see what driver you're using.

anyhow, searching your model i found this page, and it says:
Quote:
Fix hardware/software RF kill switch problem during module loading time
which seems to describe your problem pretty well.

however, the project is moved/superseded, and after a few clicks i get to this page which states very clearly that you need the iwlegacy driver.
 
Old 01-23-2016, 06:33 AM   #9
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 17.3
Posts: 86

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ondoho View Post
please don't mess around with wicd - it doesn't play well with networkmanager.
and why a static ip? I can't see how that would help.
Thanks for the input. Initially, I couldn't figure out how to get a dynamic IP with wicd, hence static, but I changed that to dynamic afterwards. Perhaps it doesn't play well with network-manager, but network-manager isn't playing at all at this stage. If I can get network-manager to load wifi on boot, then I can easily disable/uninstall wicd-curses, wicd.

Quote:
Originally Posted by ondoho View Post
actually my last request was wrong, it should have been:
Code:
lspci -k |grep -iEA5 'net|wifi'
because i'd like to see what driver you're using.

anyhow, searching your model i found this page, and it says:

which seems to describe your problem pretty well.

however, the project is moved/superseded, and after a few clicks I get to this page which states very clearly that you need the iwlegacy driver.
Code:
lspci -k |grep -iEA5 'net|wifi'
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
	Subsystem: Intel Corporation Device 1010
	Kernel driver in use: iwl3945
And that kernel driver obviously gets the wifi card to work as I am writing this on the laptop. It even survives suspending/sleep just fine. I also tried using a usb boot of Mint 17.1 and that used wifi even with the laptop LED off (but the hardware switch always on.) So at this stage it looks like something in the Linux Mint install or network-manager, but I don't know how to troubleshoot this.
 
Old 01-23-2016, 07:58 AM   #10
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053
so what did you do since your initial post to get it fixed?

i don't see how wicd would pull in a wifi driver.
 
Old 01-23-2016, 06:58 PM   #11
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 17.3
Posts: 86

Original Poster
Rep: Reputation: 15
Solved

I don't really know what worked either, but I resolved the situation by editing /etc/network/interfaces and removing all wifi configuration options (backed up file first!), leaving only:
auto lo
iface lo inet loopback

Saved file and then rebooted. The boot took about 10 secs instead of 3 minutes and immediately connected to the wifi network through network-manager. Next step is to uninstall the wicd components, but that hasn't conflicted at all with network-manager so far.

The source of my solution was this link: http://askubuntu.com/questions/21361...ration-problem

Thank you for your help and any explanation for why this solution would work would be greatly appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Windows fonts from a PC (Windows 7) to another PC (Linux Mint (17.2)) - not dual boot ArtKautz Linux - Newbie 9 09-30-2015 08:42 AM
how do I dual boot linux mint and windows 8? stewart858 Linux - Newbie 3 05-26-2014 02:00 AM
Dual boot linux Mint - Windows 8 vixa Linux - Newbie 4 09-14-2013 05:42 AM
[SOLVED] Dual Boot Windows 7 and Linux Mint 13, Windows failed jasperbuckens Linux - Software 6 12-21-2012 01:37 PM
I'm installing Linux Mint on an HP Laptop with Windows 7 for a dual boot 2cen Linux - Newbie 10 03-12-2010 06:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration