LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-19-2004, 10:54 AM   #1
ganja_man9999
LQ Newbie
 
Registered: Oct 2004
Posts: 11

Rep: Reputation: 0
win2k and redhat 9 networking


i have a machine running win2k and a machine running linux redhat 9 i cnat get each machine to other and access the net. the setup is a s follows

win2k has ethernet modem attached with internet connection sharing enabled and the win2k machine then goes to a switch, the linux machine then connects to this switch and is unable to to see the internet connection.

mozilla says it is online but unable to find any web pages

the windows machine picks up its internet setting automatically, and the network card attached to the switch has a static ip for ics,

i have also tried connecting the ethernet modem directly to the linux machine and it does not work either,

need to know what settings to use to configure the network card in linux,

the windows ones for the network card to switch are

ip address 192.168.0.1
subnet mask 255.255.255.0

dns settings are picked up automatically
 
Old 10-19-2004, 01:06 PM   #2
n3tw0rk
Member
 
Registered: Sep 2003
Location: Rawalpindi, Pakistan
Distribution: Slackware
Posts: 86

Rep: Reputation: 15
When you attached the ethernet modem to Linux, are you sure that Linux detects your device? If yes then did you specify the default gateway i.e the router you are connected to, if not then you can do so in Linux by using the following command, you must be root to do the following

route add default gateway 123.123.123.123

where 123.123.123.123 is the IP address of the router. Ofcourse you have to replace the address with your router's address.

This should make things work. To enable the windows machine to use the Internet you can setup IP masquerading on your Linux machine. Check the IP Masquerading howto at http://en.tldp.org/HOWTO/IP-Masquerade-HOWTO/

If you setup Windows Internet connection sharing, then you have to configure Linux to get the IP address using DHCP. Check this link for setting up DHCP client http://www.redhat.com/docs/manuals/l...ng-client.html You might also have to specify the default gateway as we did above but in this case the gateway will be your windows machine.
 
Old 10-19-2004, 01:42 PM   #3
ganja_man9999
LQ Newbie
 
Registered: Oct 2004
Posts: 11

Original Poster
Rep: Reputation: 0
I dont have a router its only a switch which doesnt have an ip address as far as i am aware so im not certain whether it would use a default gateway
 
Old 10-19-2004, 01:49 PM   #4
mardanian
Member
 
Registered: Mar 2004
Distribution: Fedora
Posts: 254

Rep: Reputation: 30
well things could be easy if you wana connect your net from win2k and want to access it from linux box.
first assign a static ip to llinux box hmm "netconfig" is good for this during this setup you will also define your default gateway give the ip of your win2k machine which i could assume will be 192.168.0.1
during this it will also ask you for your primary dns server hmm give agian the ip of your win2k box.
or you could change it in /etc/resolv.conf

regards
 
Old 10-19-2004, 01:57 PM   #5
ganja_man9999
LQ Newbie
 
Registered: Oct 2004
Posts: 11

Original Poster
Rep: Reputation: 0
the net is attached to win2k via ethernet, the win2k machine then connects to a switch via a second ethernet card, the linux box then connects to this switch as well which appears to be where the problems are arrising, i am using the gui bon linux as i have just come to using linux and the text interface baffles, i appeciate the help given so far and hope it resolves the problem
 
Old 10-19-2004, 02:04 PM   #6
ganja_man9999
LQ Newbie
 
Registered: Oct 2004
Posts: 11

Original Poster
Rep: Reputation: 0
where would i assign a static ip in linux using the gui
 
Old 10-19-2004, 08:17 PM   #7
this213
Member
 
Registered: Dec 2001
Location: ./
Distribution: Fedora, CentOS, RHEL, Gentoo
Posts: 167

Rep: Reputation: 34
In RHL 9 click Menu>System Settings>Network

Unless you're changing the ip address on the Linux box (I'm assuming that if you have a gateway 192.168.0.1, then your Linux system has something like 192.168.0.xxx) you won't be able to see the outside world. 192.168.xxx.xxx is reserved for private address space and cannot traverse the internet. If your win2k system gets its IP automatically, you can do the same for linux by checking the "Automatically obtain IP address from DHCP" box in the network control panel (after you double-click a device)

Personally, I think you're going about things backwards. It's far easier to route through Linux than Windows and doesn't require any configuring on the client(s) - but that's just my view.
 
Old 10-20-2004, 01:35 AM   #8
mardanian
Member
 
Registered: Mar 2004
Distribution: Fedora
Posts: 254

Rep: Reputation: 30
i'm not useto with gui tools sorry
 
Old 10-20-2004, 02:13 AM   #9
ganja_man9999
LQ Newbie
 
Registered: Oct 2004
Posts: 11

Original Poster
Rep: Reputation: 0
ive managed to get linux to see the net and the windows machine but how would you go about setting windows to see the linux machine
 
Old 10-20-2004, 09:02 AM   #10
this213
Member
 
Registered: Dec 2001
Location: ./
Distribution: Fedora, CentOS, RHEL, Gentoo
Posts: 167

Rep: Reputation: 34
Quote:
Originally posted by ganja_man9999
ive managed to get linux to see the net and the windows machine but how would you go about setting windows to see the linux machine
Do you mean to share drives and resources from the Linux machine? If so, this would require you to set up a samba server on the linux machine. I would recommend NOT using Redhat 9's GUI for this as it does not recognize all of the available options for smb.conf and if it does come across an option that it does not understand, the GUI will exit with absolutely no error message printed to the screen (unless you run it from a terminal with: # redhat-config-samba )

The file you'll need to edit for this is /etc/samba/smb.conf
once you're done editing, run the command
testparm
to make sure the format (at least) of the config file is ok, then you can do
/etc/rc.d/init.d/smb start

To make samba start when you reboot your system, edit /etc/rc.d/init.d/smb and replace the line
# chkconfig: - 81 35
with
# chkconfig: 2345 81 35

The 2345 here specifies which runlevels to start smb in
After you've save the file, do the following
/sbin/chkconfig smb reset
This will set smb to start when you boot

/sbin/chkconfig smb --list
This will print a list of what runlevels smb will start in - do this to make sure you've done it right.

All of this needs to be done as root (or su)

There is a veritable plethora of online documentation for getting samba configured properly. After google, if you still have problems, post again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC3 networking to Win2K almost there... need help! vinoloco Linux - Newbie 1 02-26-2005 01:53 PM
Networking problems between Fedora Core 1, WinXP, and Win2k neon_knight Linux - Newbie 1 08-01-2004 01:50 PM
networking with win2k ramzi Linux - Software 2 09-30-2003 04:03 PM
networking win2k server and mandrake 8.2 ramlivs Linux - Networking 2 05-26-2003 11:25 PM
Networking with Win2k thetruevoice Linux - Networking 2 03-19-2002 02:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration