LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Win2k Advanced Server 2 Fedora Core 1 (https://www.linuxquestions.org/questions/linux-networking-3/win2k-advanced-server-2-fedora-core-1-a-195262/)

lil_ak 06-19-2004 05:00 AM

Win2k Advanced Server 2 Fedora Core 1
 
ok people i need some quick advice. how would i go about setting up my own web server on fedora ? is fedora as simple as setting up iis for windows? and what ip you can choose from? any links to articles or something would be nice ... thnx.. :P

dtournas 06-19-2004 06:10 AM

To setup a webserver on fedora just type:

service httpd start :D :D :D

It is really a piece of cake! Try the official site : www.apache.org for some documentation.

lil_ak 06-19-2004 10:14 PM

---if i am correct that doesnt really sound like a command do i need to type that in , in the terminal or the run line? please help im still stuck.....

dtournas 06-20-2004 02:09 AM

Apache, the most common web server all around the world, is propably installed with your linux distro. So, the only thing you have to do is just start the daemon (like the windows' service). To do that just run from a terminal window (command prompt) the following.

service httpd start

That will start the deamon (service) and you will be able to see your home page. How? If your linux box is in a LAN, just type the IP address from another PC. Let's just say that it is 192.168.0.10. So open a browser window in a pc connected to tha e LAN and in the address bar, just type:

http://192.168.0.10

Let me know how it goes!

lil_ak 06-20-2004 04:33 PM

ok this is what i got i keep getting this message when i do it....

[admin@localhost admin]$ su root
Password:
[root@localhost admin]# service httpd start
bash: service: command not found
[root@localhost admin]# httpd start
bash: httpd: command not found
[root@localhost admin]# service httpd start
bash: service: command not found
[root@localhost admin]#service httpd start
bash: httpd: command not found

Crito 06-20-2004 09:57 PM

You could use "chkconfig --list" to see if httpd is installed. If it is then use "chkconfig --level" to enable it on bootup for runlevel 3 and 5.

ppuru 06-20-2004 10:07 PM

It is assumed RedHat installed apache rpms by default.

you can check the existence of apache on your system with

#rpm -q apache

If apache is missing, you can install it from your CDs ... better still download the latest rpm
from RedHat.


#su - root
#rpm -ivh apache<full filename>

Modify /etc/httpd/conf/httpd.conf and start apache with

#service httpd start


All times are GMT -5. The time now is 11:12 AM.