-   Linux - Networking (
-   -   Win XP client on LAN can't find Linux server (

mournblade 06-24-2003 12:44 PM

Win XP client on LAN can't find Linux server
I'm a complete newbie with regard to Linux, and am trying to learn how to set up a rudimentary Linux web server.

I installed Linux 9 on my laptop, which went great. By running Mozilla and typing in, I can successfully see a sample web page I created. The laptop is connected to a Win XP desktop. The desktop has two NICs, one connected to DSL and one connected through a hub to the laptop.

The linux laptop has an address of on my network, the desktop has an address of I can ping from the Win XP client. But when I type into the URL line of IE on the Win XP client, I get a "Cannot Find Server" message.

I'd like to be able to see the web pages on my Linux server through my Win XP client. Does anyone have any ideas on how I can do this, or what the problem could be?

I checked the error and access logs on the Linux server/laptop. Neither, strangely, showed any trace of an attempt to connect from the client, as far as I could tell.

Thank you for your help!

tangle 06-24-2003 12:52 PM

did you try ?

mournblade 06-24-2003 01:08 PM

More details of problem
Yes, in the IE URL line I've tried:

Neither seem to work.

By the way, I should add that my Win XP desktop has two NICs -- one is connected to a Linksys Router, and the other is connected to the Linux server laptop. I run Winroute Pro on the Win XP desktop, which allows me to share an Internet connection with the Linux server laptop (and that works fine, I can browse the Web with Mozilla.)

I've also changed the ServerName in the httpd.conf file to, but that didn't improve anything either.

Please help!

tangle 06-24-2003 01:14 PM

I had a brain fart, do you have a firewall running on the laptop like and iptables script?

mournblade 06-24-2003 02:48 PM

There are no firewalls running on the laptop that I am aware of -- does Linux have one up by default when it is installed? And what is the iptables script? I am unaware of what that is.

tangle 06-24-2003 02:54 PM

You said that you have Linux 9. Do you mean Red Hat 9 or Slackware 9?

crokett 06-24-2003 03:02 PM

iptables is a firewall. the iptables script is the script you create to create a ruleset and tell the firewall what traffic to filter. a quick check to see if you have a firewall running is to type 'iptables -L' at the command line to list any rules that might be loaded. you can also run 'iptables -F' to flush the ruleset and open the filters up to all traffic. during the RedHat install, did you get a prompt about whether you wanted to install a firewall? I haven't used RH9, but earlier versions ask this and the default is yes.

an excellent site:
Firewall site

Robert0380 06-24-2003 03:37 PM

that firewall site thing sucks, iptables is not an option the list. And on top of the that, the site was modified last in 2001.

mournblade 06-24-2003 03:42 PM

Even if I run an iptables -F to open up the filters, I still can't have the Linux server's web pages appear in the Win XP client.

iptables -L does, however, seem to reveal some kind of firewall at work -- it's hard for me to say since I can't understand the list. However, if it runs through the rules sequentially, then among the first few lines -- all of which are ACCEPTs -- is a line saying "ACCEPT ALL anywhere anywere." Perhaps this would break down the firewall?

Sorry for the confusion, too. I am using Red Hat Linux 9.

Thank you again. Please bring on the advice! I could really use it.

tangle 06-24-2003 09:01 PM

If you get a long list from your iptables -L, then you have a firewall running. I have not used Red Hat since ver 7.3. But they had a control center type app. In it there is a service icon that will let you start|stop|restart iptables. That is the easy way to stop and start it. Once you find it and stop it, see if you can connect.

edal11 06-26-2003 04:54 PM

Let's say mournblade wants to type in http://mournblade_server/ instead of typing

What would I have to do to configure linux to do that?
(Assume same config, same ip's, .... just as mournblade)



All times are GMT -5. The time now is 04:05 AM.