LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-08-2003, 07:09 AM   #1
paknip
LQ Newbie
 
Registered: Apr 2003
Posts: 1

Rep: Reputation: 0
win xp & samba


I'm really a newbie here... I just setup a samba server with a network of several pcs running windows.. win98 & win xp pro.

On win98, everything works fine, I can see the workgroup, browse the directories and files but NOT with machines running win xp pro...

I did managed to get the workgroup appears in the network neighborhood (i think they call it with different name..) but I can't access the directories. It keep on asking for password.

Can anybody help/assist me on this? Tq...
 
Old 04-08-2003, 11:06 AM   #2
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
Read some of the manual pages for smb.conf, smbpasswd, smbusers, etc. to try to help the password problem. Not sure why the machines arent' showing up for the XP clients, that's a little strange. I guess we'd all need more information regarding the specifics of your configuration to speculate about what's wrong.
 
Old 04-08-2003, 12:34 PM   #3
koy
Member
 
Registered: Apr 2003
Distribution: SuSe 10
Posts: 55

Rep: Reputation: 15
Quote:
It keep on asking for password.
insert the username and password that u configured in samba.
 
Old 04-08-2003, 08:39 PM   #4
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
Check and make sure that you don't have the default firewall turned on in Windows XP. Also, make sure you have NETBIOS enabled on you XP boxes. It's always enabled on 98. If you fix your problem, be sure to post what fixed it because there's quite a few problems w/ Samba on this forum.
 
Old 04-09-2003, 09:33 AM   #5
jamrock
Member
 
Registered: Jan 2003
Location: Kingston, Jamaica
Posts: 444

Rep: Reputation: 41
XP needs some additional steps.

The tutorial below has a section on configuring clients.

http://www-1.ibm.com/servers/esdd/tu...mba/index.html
 
Old 04-09-2003, 09:44 AM   #6
exalik
Member
 
Registered: Mar 2003
Location: PARIS / FRANCE
Distribution: Mandrake 9.2rc2
Posts: 49

Rep: Reputation: 15
Hello,

You must install NETBEUI protocol that is not installed per default.

So, open your network properties and choose to install a new protocol. Then, insert your XP pro cd-rom ; click on the button to access your cd-rom and find the netbeui.inf file. Select it to install the protocol. Reboot then you should access to your samba share.

;-)

Exalik
 
Old 04-09-2003, 11:51 AM   #7
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
This is not true. You do not need the NetBEUI protocol installed at all. Linux is strictly a TCPIP-based operating system. All Samba communication needs to be done over TCPIP.
 
Old 04-09-2003, 12:13 PM   #8
lgomez
LQ Newbie
 
Registered: Apr 2003
Location: Argentina
Distribution: Red Hat
Posts: 3

Rep: Reputation: 0
It's very important that you use in your smb.conf
encrypt passwords = yes

W98 machines use plain text for passwords, against WXP & W2000 or even NT4 who uses encrypted passwords.

Maybe, after do that w98 clients stops to work, you have to put an entrie in the registry to use encripted passwords in your W98 machines. I can't remember what and where, but you can find it.

and you don't need NetBEUI
 
Old 04-09-2003, 02:23 PM   #9
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
He doesn't need to install NETBEUI. You don't need NETBEUI at all for XP machines networking w/ Samba. I have a 4 XP machines at home that work just fine w/out NETBEUI. However, enabling NETBIOS would be a good idea on your XP machines. That;s enabled on my XP boxes and Samba works great on my home network.
 
Old 04-16-2003, 09:21 AM   #10
exalik
Member
 
Registered: Mar 2003
Location: PARIS / FRANCE
Distribution: Mandrake 9.2rc2
Posts: 49

Rep: Reputation: 15
It's what i had to do to access my samba share since my win xp pro computer !

;-)

Exalik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Fedora Core 3, Samba, gnome & win 2000/XP edesmarais Linux - Networking 21 12-15-2005 02:36 PM
slackware 10 samba 3.04 & Win XP firejdl Linux - Networking 4 03-27-2005 01:27 PM
Networking Win Xp & Samba arsenic420 Linux - Networking 1 01-21-2004 02:26 PM
Win Xp & Win 2000 & Mandrake 9.1 (ntoskrnl missing for xp) mcbaboon Linux - Newbie 8 10-14-2003 10:34 AM
Samba & WIN XP Home pid79 Linux - Networking 1 03-18-2003 01:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration