LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-13-2014, 11:26 AM   #1
hilltownboy
Member
 
Registered: Jan 2008
Location: Ashfield, MA
Distribution: Debian 11 "Bullseye", Arch
Posts: 123

Rep: Reputation: 15
wifi no longer connecting on boot


After wifi connection for a year and a half automatically on boot, it now only connects manually after boot. Will a kind soul take a look at my wireless data to see if there is a fix?
Code:
	======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

debian 3.2.0-4-686-pae i686,  Debian GNU/Linux 7.6 (wheezy), wheezy

CPU    : Intel(R) Core(TM)2 Duo CPU     T7300  @ 2.00GHz
Memory : 2025 MB
Uptime : 11:28:13 up 38 min,  1 user,  load average: 0.14, 0.33, 0.42


lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)
	Subsystem: Hewlett-Packard Company Compaq 6910p [103c:30c1]
	Kernel driver in use: e1000e
--
10:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)
	Subsystem: Intel Corporation Device [8086:1000]
	Kernel driver in use: iwl4965


lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 03f0:171d Hewlett-Packard Bluetooth 2.0 Interface [Broadcom BCM2045]


PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~



iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~



rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~




lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

iwl4965                73721  0 
iwl_legacy             47073  1 iwl4965
mac80211              171389  2 iwl_legacy,iwl4965
cfg80211              113445  3 mac80211,iwl_legacy,iwl4965
hp_wmi                 13121  0 
sparse_keymap          12680  1 hp_wmi
rfkill                 18516  4 bluetooth,hp_wmi,cfg80211
wmi                    13051  1 hp_wmi


module parameters ~~~~~~~~~~~~~~~~~~

cfg80211      (2): cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
iwl4965       (5): 11n_disable=0 | amsdu_size_8K=1 | fw_restart=1 | queues_num=0 | swcrypto=0
iwl_legacy    (2): bt_coex_active=Y | led_mode=0
mac80211      (4): ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500
rfkill        (1): default_state=1
wmi           (2): debug_dump_wdg=N | debug_event=N


nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

State: connected (global)
================o=============o=========o=============o=========o===========o==============o===========
 Interface & ID | Type        | Driver  | State       | Default | Speed     | Support      | HW Addr   
================o=============o=========o=============o=========o===========o==============o===========
 wlan0          | 802.11 WiFi | iwl4965 | unmanaged   | no      |           | WEP/WPA/WPA2 | <MAC wlan0>
----------------+-------------+---------+-------------+---------+-----------+--------------+-----------
 eth0           | Wired       | e1000e  | unavailable | no      |           |              | <MAC eth0>
----------------+-------------+---------+-------------+---------+-----------+--------------+-----------


NetworkManager.state ~~~~~~~~~~~~~~~
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true


NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false


NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~
 


interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
#NetworkManager#iface eth0 inet dhcp

#wifi
# allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
# wpa-ssid "Matviak"
# wpa-psk <WPA key removed>
 wireless-essid WIRELESS
 wireless-mode MANAGED
# wireless-essid guest
# wireless-mode Master

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

nameserver 192.168.0.1


Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~



--- 192.168.0.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 1.216/1.276/1.336/0.060 ms


iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "en_US.UTF-8")


iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

           - 


iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~

Aquiring of root rights failed.


blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~


modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[iwl4965]

[iwl_legacy]

[mac80211]

[cfg80211]

[hp_wmi]

[rfkill]

[wmi]


udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:19.0 (e1000e)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:1c.1/0000:10:00.0 (iwl4965)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"


Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Not Default
/etc/rc.local       : Default
/etc/modprobe.d     : Not Default
/etc/pm/(cnf|pw|sl) : Default

[/etc/modules]
loop

[/etc/modprobe.d]
radeon-kms.conf   : options radeon modeset=1


Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-686-pae root=UUID=81bf64b8-edd1-424f-9eaa-014b8a8afe56 ro quiet


dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    0.004200] Initializing cgroup subsys net_cls
[    0.646043] audit: initializing netlink socket (disabled)
[    1.049258] Initializing network drop monitor service
[    6.844239] wmi: Mapper loaded
[    8.996773] iwl4965: Intel(R) Wireless WiFi 4965 driver for Linux, in-tree:
[    8.996776] iwl4965: Copyright(c) 2003-2011 Intel Corporation
[    8.996851] iwl4965 0000:10:00.0: setting latency timer to 64
[    8.996878] iwl4965 0000:10:00.0: Detected Intel(R) Wireless WiFi Link 4965AGN, REV=0x4
[    9.035514] iwl4965 0000:10:00.0: device EEPROM VER=0x36, CALIB=0x5
[    9.035541] iwl4965 0000:10:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
[    9.035625] iwl4965 0000:10:00.0: irq 46 for MSI/MSI-X
[    9.400846] platform radeon_cp.0: firmware: agent aborted loading radeon/R520_cp.bin (not found?)
[    9.401008] [drm:r100_cp_init] *ERROR* Failed to load firmware!
[    9.636221] iwl4965 0000:10:00.0: firmware: agent loaded iwlwifi-4965-2.ucode into memory
[    9.636226] iwl4965 0000:10:00.0: loaded firmware version 228.61.2.24
[    9.776665] ieee80211 phy0: Selected rate control algorithm 'iwl-4965-rs'
[   16.215900] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   17.882703] wlan0: authenticate with <MAC ID removed> (try 1)
[   17.884977] wlan0: authenticated
[   17.885063] wlan0: associate with <MAC ID removed> (try 1)
[   17.890394] wlan0: RX AssocResp from <MAC ID removed> (capab=0x421 status=0 aid=2)
[   17.890401] wlan0: associated
[   17.890409] wlan0: No basic rates in AssocResp. Using min supported rate instead.
[   17.929579] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   28.267008] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   28.792043] wlan0: no IPv6 routers present
[   31.406241] iwl4965 0000:10:00.0: RF_KILL bit toggled to disable radio.
[   31.461752] iwl4965 0000:10:00.0: RF_KILL bit toggled to enable radio.
[   31.461756] iwl4965 0000:10:00.0: On demand firmware reload
[   31.469931] iwl4965 0000:10:00.0: Failing on timeout while stopping DMA channel 1 [0xa5a5a5a2]
[   31.473247] iwl4965 0000:10:00.0: Failing on timeout while stopping DMA channel 3 [0xa5a5a5a2]
[   31.473247] iwl4965 0000:10:00.0: Failing on timeout while stopping DMA channel 4 [0xa5a5a5a2]
[   31.473247] iwl4965 0000:10:00.0: Failing on timeout while stopping DMA channel 6 [0xa5a5a5a2]
[   32.364060] iwl4965 0000:10:00.0: Error sending REPLY_ADD_STA: time out after 500ms.
[   32.364153] wlan0: deauthenticating from <MAC ID removed> by local choice (reason=3)
[   32.364311] WARNING: at /build/linux-oDe0QO/linux-3.2.60/drivers/net/wireless/iwlegacy/iwl-core.c:1436 iwl_legacy_mac_remove_interface+0x2f/0x5c [iwl_legacy]()
[   32.364316] Modules linked in: ppdev lp rfcomm bnep uinput nfsd nfs nfs_acl auth_rpcgss fscache lockd sunrpc loop lm63 arc4 pata_pcmcia snd_hda_codec_analog snd_hda_intel snd_hda_codec iwl4965 tpm_infineon radeon iwl_legacy snd_hwdep mac80211 snd_pcm snd_page_alloc cfg80211 hp_wmi joydev btusb pcmcia acpi_cpufreq mperf snd_seq snd_seq_device snd_timer snd ttm bluetooth drm_kms_helper yenta_socket pcmcia_rsrc pcmcia_core parport_pc parport hp_accel sparse_keymap irda rfkill drm i2c_algo_bit i2c_core soundcore crc_ccitt lis3lv02d psmouse input_polldev tpm_tis tpm evdev crc16 iTCO_wdt pcspkr serio_raw iTCO_vendor_support video battery processor button container coretemp ac tpm_bios wmi power_supply ext3 mbcache jbd sg sd_mod crc_t10dif fan thermal thermal_sys uhci_hcd ahci libahci libata firewire_ohci sdhci_pci sdhci mmc_core firewire_core crc_itu_t scsi_mod ehci_hcd e1000e usbcore usb_common [last unloaded: scsi_wait_scan]
[   32.364416]  [<f8579f03>] ? iwl_legacy_mac_remove_interface+0x2f/0x5c [iwl_legacy]
[   32.364425]  [<f8579f03>] ? iwl_legacy_mac_remove_interface+0x2f/0x5c [iwl_legacy]
[  232.634103] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  234.301173] wlan0: authenticate with <MAC ID removed> (try 1)
[  234.303535] wlan0: authenticated
[  234.303629] wlan0: associate with <MAC ID removed> (try 1)
[  234.307519] wlan0: RX AssocResp from <MAC ID removed> (capab=0x421 status=0 aid=2)
[  234.307526] wlan0: associated
[  234.307534] wlan0: No basic rates in AssocResp. Using min supported rate instead.
[  234.347242] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  245.184075] wlan0: no IPv6 routers present
[  251.394633] iwl4965 0000:10:00.0: iwl4965_tx_agg_start on ra = <MAC ID removed> tid = 0

	======== Done ========
Thanks for reading the above. I've been using linux for years and googled a lot on this, but I'm still a newbie on complex situations.
 
Old 08-15-2014, 01:13 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,841

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Have you checked in "Network Connections>>Edit>>General"?
Is the "Connect to this network when available" box checked?
 
Old 08-15-2014, 01:53 PM   #3
hilltownboy
Member
 
Registered: Jan 2008
Location: Ashfield, MA
Distribution: Debian 11 "Bullseye", Arch
Posts: 123

Original Poster
Rep: Reputation: 15
EDDY1:"Network Connections>>Edit" does not seem to be available to me. Is it part of Network Manager or Gnome or KDE? I have Openbox, whiich is minimal, and wifi started by init.d/networking.
I believe my trouble is with the failure of "on demand firmware reload" because it comes on the screen at the end of each boot.

Last edited by hilltownboy; 08-15-2014 at 01:58 PM.
 
Old 08-15-2014, 07:01 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,841

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Does your system have a menu? Under menu it may be under "System>>Preferences".
 
Old 08-16-2014, 10:51 AM   #5
hilltownboy
Member
 
Registered: Jan 2008
Location: Ashfield, MA
Distribution: Debian 11 "Bullseye", Arch
Posts: 123

Original Poster
Rep: Reputation: 15
My menus do not include "System>>Preferences", only what came with Openbox and Debian "wheezy" plus what I have added.
 
Old 08-16-2014, 05:21 PM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,841

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
In wheezy then it would be under Activities
 
Old 08-18-2014, 09:40 AM   #7
hilltownboy
Member
 
Registered: Jan 2008
Location: Ashfield, MA
Distribution: Debian 11 "Bullseye", Arch
Posts: 123

Original Poster
Rep: Reputation: 15
Thanks, EDDY1. I believe that "Activities" is part of the Gnome3 window manager, which I do not use. Instead I have Openbox which is useful for older computers of limited capacity because it omits the decorative aspects of managers such as Gnome. I need to find the actual commands controlling the disfunctioning of my wifi "failing on timeout".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WiFi interface will no longer pick up an IP address from access point. DiBosco Linux - Wireless Networking 4 12-22-2007 06:42 PM
broadcom wifi no longer detected after upgrade neo_cool_XIIK Fedora 2 12-17-2007 01:49 PM
Connecting to wifi birddseedd Linux - Wireless Networking 2 02-13-2007 10:45 AM
wifi connecting Nostur Linux - Wireless Networking 3 09-08-2006 01:12 PM
xchat no longer connecting to any servers jrdioko Linux - Software 4 01-20-2006 10:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration