-   Linux - Networking (
-   -   Wierd Samba Problem with Network Speed (using SK98lin driver) (

g8keepR 02-08-2005 10:32 AM

Wierd Samba Problem with Network Speed (using SK98lin driver)
It seems that when I try to copy a file from a Windows Share to Linux I get really crappy speeds (~100KB/s if I'm LUCKY). However, I noticed that if I start a second transfer my speeds are normal (6MB/s each or so on a gigabit lan).

I have a linksys gigabit ethernet card on this machine (using skyline's driver module)

below is from my dmesg when I active my network card:
speed: 1000
autonegotiation: yes
duplex mode: full
flowctrl: symmetric
role: slave
irq moderation: disabled
scatter-gather: enabled

my settings on my windows box are:
full autonegotiation and flow contrl on.

I also do NOT have IPv6 enabled

and just incase I put these in my /etc/modprobe.conf:

alias net-pf-10 off
alias ipv6 off

Of course, if I'm on my windows box and copy files to Linux my speeds are normal

Any ideas what could be causing this?


g8keepR 02-09-2005 06:16 AM

*follow up*

Yesterday I also tried setting up an FTP server on my XP machine and downloading to my linux machine. The speed was normal (13MB/s+) So this seems to be a SAMBA only problem.

Any ideas?


g8keepR 02-10-2005 06:39 PM

*follow up #2*

I Finally found at least a partial solution

by typing in: ifconfig eth0 mtu 9000

my transfer speeds went from 100-300KB/s to 3MB/s

One thing I also set was (in my smb.conf):

max xmit = 65535

You'll need both of these settings.

However, I noticed this works only when I go to my share via "smb://MACHINENAME/SHARENAME" and transfer my file. If I go to my share via a cifs filesystem mount, it goes back to 100-300KB/s. ARG!!!!

Darin 02-10-2005 09:12 PM


Originally posted by g8keepR
Not sure what distribution you are using, but you may want to find out if they have an update for Samba as some older versions did have some performance idiosyncrasies. If there is not an updated package for your Linux distribution then you can always get the newest version from the Samba team at and install it from source.

g8keepR 02-10-2005 09:17 PM

I'm using Fedora Core 3 and version 3.0.10-1-fc3. I just downloaded version 3.0.11 and hopefully this will work. By the way, in my previous post (above), that solution stopped working for me now. Everything's back to 100-300KB/s :(

g8keepR 02-10-2005 09:21 PM

whatever they did in v 3.0.11 WORKED !!! 6 - 11MB /s :)

but the minute i do more than 1 simultaneous transfer it slows down to 1.5-2MB/s each :(

oh well, I'll take 1 fast xfer over 2 slower ones any day

All times are GMT -5. The time now is 02:31 PM.