-   Linux - Networking (
-   -   wicd won't connect to a particular wireless net while Windows will (

Cultist 12-25-2010 07:39 PM

wicd won't connect to a particular wireless net while Windows will
odd thing I'm experiencing. I'm at a family member's house for the holiday and was trying to use their wifi. Its a WEP connection (I tried to tell them to change but they won't listen). In the wicd connection manager, I see their network, set the encryption to WEP (passphrase), enter the password, and hit connect. It says bringing up the card, checking authentication, then gets to Acquiring IP address, sits there for a minute, then times out saying unable to connect.

I know I used the right password because it passed the Authenticating part (tested with a wrong password that hangs at this point).

I know that my wifi card works because I used a store's unsecured wifi connection through wicd.

I know the wifi network works because my brother's windows netbook can get on just fine

I'm running through the same router right now with a wire instead.

Any ideas as to why I can't connect wirelessly?

Only thing I could think of was that I had to specifically enable wep or something. But I don't know if thats it or not.


Timothy Miller 12-25-2010 07:44 PM

I would try using WEP shared/restricted. I seem to recall that's what I have to use when I go over my one friends house (she refuses to buy a modern router that does WPA/WPA2).

Cultist 12-25-2010 07:49 PM

I just get a bad password error with anything other than WEP (passphrase)

Timothy Miller 12-26-2010 09:26 AM

I'm actually at my sisters this morning. She's actually the one I know that still uses WEP. I also am getting the same error now using ceni or wicd on aptosid. Able to connect to my home router via WPA2 with no issues using either one. However, the one difference is it authenticates regardless of which WEP authentication I choose, but fails to get IP exactly as you described.

Timothy Miller 12-26-2010 02:52 PM

Ok, I was able to connect now. I had to delete my key, set the connection type to WEP (HEX), then reset my password and try maybe NOT the same issue.

All times are GMT -5. The time now is 09:22 PM.