LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   why wont my internet work? (https://www.linuxquestions.org/questions/linux-networking-3/why-wont-my-internet-work-438379/)

jonny_fun 04-24-2006 11:21 AM

why wont my internet work?
 
Hi all,

Have just installed Suse 10.0 on my sony vaio pcg-grt716s laptop and have tried to connect to the internet using a network cable through a linksys 4-port router but it just wont work :mad:. What was supposed to automatically connect (as my friend told me) turned out not to do anything at all. I have been through all the settings of my network card (to coincide with my friends, using automatic config from DHCP etc) and it has seemed to make no difference whatsoever. I cannot even connect to the router directly (by typing 192.168.1.1 in firefox). I have also set the firewall to external zone if that makes much of a difference. It just doesn't seem to recognise the network cable is there... I would post details up from ifconfig etc but I am using the laptop on dual boot so currently on the internet in windows.

Any ideas would be grately appreciated, and if any details are required then I'll do my best to post them up.

Thanks

Jonny
:newbie:

jschiwal 04-24-2006 12:12 PM

Does the output of ifconfig show an IP address assigned to the NIC interface. If not, back up and use "lspci -n" to determine the controller chip used for the NIC.

The firewall setup assigns the NIC interface to a zone, such as internal or external. Normally "external" is more restrictive, but it depends on which services are allowed in the setup.

Try as root, or using sudo entering the command "/sbin/rcnetwork restart" and note if anything fails. If you have a fat32 device such as a keydrive, you can redirect the output, or cut and paste to save the output to a drive that windows can read.

Also, you might want to read through the networking section of the SuSE Administration Manual, to learn how to set up the NIC card and the firewall.

magnum81 04-24-2006 01:35 PM

If the nic gets an ip assigned to it "try ifconfig", then you need to make sure that a default route is assigned and make sure there is a nameserver in the resolv.conf file "cat /etc/resolv.conf"

jonny_fun 05-01-2006 12:59 PM

The latest
 
Thanks for the speedy responses last time, sorry I have been delayed in responding, have had an absolutely hectic week. Right, I have tried ifconfig and got this response:

---------------------------------------------------------
eth0 Link encap:Ethernet HWaddr 08:00:46:B4:47:51
inet6 addr: fe80::a00:46ff:feb4:4751/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:20 errors:0 dropped:60 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:796 (796.0 b) TX bytes:2239 (2.1 Kb)
Interrupt:11 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:222 errors:0 dropped:0 overruns:0 frame:0
TX packets:222 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:19317 (18.8 Kb) TX bytes:19317 (18.8 Kb)
---------------------------------------------------------

I couldn't see anything to do with NIC there so tried using the lspci -n command and got this:

---------------------------------------------------------
00:00.0 Class 0600: 1039:0648 (rev 03)
00:01.0 Class 0604: 1039:0002
00:02.0 Class 0601: 1039:0963 (rev 14)
00:02.1 Class 0c05: 1039:0016
00:02.5 Class 0101: 1039:5513
00:02.6 Class 0703: 1039:7013 (rev a0)
00:02.7 Class 0401: 1039:7012 (rev a0)
00:03.0 Class 0c03: 1039:7001 (rev 0f)
00:03.1 Class 0c03: 1039:7001 (rev 0f)
00:03.2 Class 0c03: 1039:7001 (rev 0f)
00:03.3 Class 0c03: 1039:7002
00:04.0 Class 0200: 1039:0900 (rev 90)
00:0a.0 Class 0607: 1180:0476 (rev aa)
00:0a.1 Class 0607: 1180:0476 (rev aa)
00:0a.2 Class 0c00: 1180:0552 (rev 02)
01:00.0 Class 0300: 10de:031a (rev a1)
---------------------------------------------------------

Again, I don't really understand what this is showing... I have also tried restarting the rcnetwork '/sbin/rcnetwork restart' and got the following response:

---------------------------------------------------------
Shutting down network interfaces:
eth0 device: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
eth0 configuration: eth-id-08:00:46:b4:47:51
[1A..doneShutting down service network . . . . . . . . . . . . . . ...done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8
[1A..done eth0 device: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
eth0 configuration: eth-id-08:00:46:b4:47:51
eth0 (DHCP) . . . . . no IP address yet... backgrounding.

Setting up service network . . . . . . . . . . . . . . . ...done
---------------------------------------------------------

Again, I can't see that anything has directly failed here either.

When I used cat on resolv.conf it only contained 'domain site', nothing else about the nameserver...

Finally, I thought I would check to see if the router could be picked up yet, but when I typed the router address into the browser, then nothing was available again!

So I hope these things help, I am still completely stuck with no internet... :mad:

Thanks again for your help guys

Jonny
:newbie:


All times are GMT -5. The time now is 09:44 PM.