LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-15-2017, 04:11 AM   #1
adrhc
Member
 
Registered: Dec 2006
Location: Bucharest
Distribution: Ubuntu 16.04 LTS
Posts: 103

Rep: Reputation: 13
why eth1 with auto dhcp disturbs pppoe over eth0


Hi, I use ubuntu 16.04 desktop with ufw (default setup + 22, 80, 443 ports open).

I connect directly to ISP using pppoe over eth0. I also have eth1 which when disabled the websites are accessible in browser. When starting eth1 with auto dhcp the websites are no longer accessible in browser (give a timeout while trying to load). eth1 is plugged in a LAN port of a router with its WAN port unplugged (yeah, don't ask why). When setting a manual ip on eth1 while gateway and dns are left blank the websites are accessible in browser again.

Why this happens?

Last edited by adrhc; 04-15-2017 at 03:06 PM.
 
Old 04-15-2017, 04:46 PM   #2
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,249
Blog Entries: 3

Rep: Reputation: 194Reputation: 194
I'm willing to bet when you turn on your eth1 it over writes the default GW thus making your system not able to connect to the internet.

Can you give us the output of
Code:
route -n
when eth1 is turned off and then again when eth1 is turned on?
 
Old 04-15-2017, 04:56 PM   #3
adrhc
Member
 
Registered: Dec 2006
Location: Bucharest
Distribution: Ubuntu 16.04 LTS
Posts: 103

Original Poster
Rep: Reputation: 13
Interesting idea; I'll give it a try when I'll be back home (after Easter).
 
  


Reply

Tags
dhcp, lan, pppoe, ubuntu 16.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 fixed IP. eth1 DHCP gateway. Need access to eth0 fopetesl Linux - Networking 69 02-01-2010 04:45 AM
Boot polls for dhcp on eth0 before connecting to eth1 drum Slackware - Installation 2 12-21-2008 08:44 AM
Eth0 using DHCP and eth1 using static ip: eth0 receive internal ip not the router ip geraldomanaus Linux - Networking 3 04-23-2008 04:00 PM
eth0, eth1, dhcp, slackware 11 problem q3noob Slackware 5 07-31-2007 10:26 AM
Dhcp eth0 and XP eth1 internet sharing props666999 Slackware 8 08-20-2005 10:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration