LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-09-2015, 08:45 AM   #1
luofeiyu
Member
 
Registered: Aug 2015
Posts: 237

Rep: Reputation: Disabled
Which computer will the bind9 be installed on ?


There is a mini home wifi network in my home.The wireless router is 192.168.1.1. Computer A is 192.168.1.2 ,the wordpress was build on it.ALL the urls of my wordpress are the form of mywp.com/wp/?m=201409 ,there is a line in /etc/hosts of Computer A .

192.168.1.2 mywp.com

Computer B is 192.168.1.3, there is a line in /etc/hosts of Computer B also .

192.168.1.2 mywp.com

Now the wordpress can be visited when to input mywp.com/wp/?m=201409 in firefox both on Computer A and B. My android phone ip is 192.168.1.4 ,the wordpress can not be visited when to input mywp.com/wp/?m=201409in android's firefox .

I want to solve the problem with bind9 as dns server.
Which computer will the bind9 be installed on ?
 
Old 11-09-2015, 11:57 AM   #2
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,249
Blog Entries: 3

Rep: Reputation: 194Reputation: 194
There is going to be more to this then simply setting up a DNS server and calling it done. Have you looked at your wireless router is there is a way to setup hosts on it for redirection? You could try the following on your phone:

Code:
192.168.1.2/wp/?m=201409
This should work without having to setup DNS server.
 
Old 11-09-2015, 12:08 PM   #3
berndbausch
LQ Addict
 
Registered: Nov 2013
Location: Tokyo
Distribution: Mostly Ubuntu and Centos
Posts: 6,316

Rep: Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002
Quote:
Originally Posted by lazydog View Post
There is going to be more to this then simply setting up a DNS server and calling it done. Have you looked at your wireless router is there is a way to setup hosts on it for redirection? You could try the following on your phone:

Code:
192.168.1.2/wp/?m=201409
You set up DNS on any computer, but preferably one that is running all the time. DNS is of no use if the DNS server is down.

Perhaps your router has a DNS server (mine doesn't). I would use this one. Otherwise, setting up BIND is not that trivial, but not that hard either, and a nice learning exercise. At home, I use a Raspberry Pi for DHCP and DNS, and since it only consumes 2W, it's OK to leave it on all the time.
 
1 members found this post helpful.
Old 11-11-2015, 10:40 PM   #4
luofeiyu
Member
 
Registered: Aug 2015
Posts: 237

Original Poster
Rep: Reputation: Disabled
ALL the urls is in the form of mywp.com/wp/?m=201409

You can't input `192.168.1.2/wp/?m=201409` in the android phone to visit my wordpress.
 
Old 11-12-2015, 06:20 AM   #5
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
If you let your android attach to your home wifi, this will work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect to website - Bind9 Installed - Configured, Still doesn't work jj20051 Linux - Server 1 12-20-2011 02:42 PM
Installed LAMP, bind9, Komposer - now how do I publish my website? navnathindia Linux - Server 5 12-09-2010 06:14 AM
[SOLVED] Bind9 stop working wheni installed Postfix on Ubuntu 9.10 Lucard Linux - Server 9 03-01-2010 12:17 PM
[SOLVED] BIND9 startup error, just installed on ubuntu 9.04 Predatorian Linux - Server 6 11-13-2009 01:43 AM
my computer does not detect sound drivers for redhat 4.0 installed on my computer. i kunalp Linux - General 1 06-17-2008 03:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration