LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-19-2004, 03:35 PM   #1
Jan Tanjo
Member
 
Registered: Dec 2004
Location: Toronto ON
Distribution: Mandrake 9.2 . Fedora 5
Posts: 65

Rep: Reputation: 15
where's my inetd.conf?


Hi

I'm trying to config Samba with SWAT and I'm supposed to edit the inetd.conf in /etc/ but there is none, as far as I can tell there isn't one on the whole system.

How do I get/make/put this file there
 
Old 12-19-2004, 04:05 PM   #2
pcunix
Member
 
Registered: Dec 2004
Location: MA
Distribution: Various
Posts: 149

Rep: Reputation: 23
You don't.

Your system almost certainly uses xinetd. That's a more modern, and much better replacement for inetd (and the "x" stands for "extended"; nothing to do with "X")

See http://aplawrence.com/Basics/xinetd.html

--
Tony Lawrence
http://aplawrence.com
 
Old 12-19-2004, 04:09 PM   #3
pcunix
Member
 
Registered: Dec 2004
Location: MA
Distribution: Various
Posts: 149

Rep: Reputation: 23
I forgot to add this to configure for xinetd

# SWAT is the Samba Web Admin Tool.
service swat
{
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/sbin/swat
only_from = 127.0.0.1
disable = yes
}


From http://us4.samba.org/samba/ftp/Binar...c/samba.xinetd

--
Tony Lawrence
http://aplawrence.com
 
Old 12-20-2004, 12:53 AM   #4
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
i think you want
disable = no
not
disable = yes

or you have swat disabled...

that's why i hate xinetd... inetd is just easier...
go slack.
 
Old 12-20-2004, 11:28 PM   #5
Jan Tanjo
Member
 
Registered: Dec 2004
Location: Toronto ON
Distribution: Mandrake 9.2 . Fedora 5
Posts: 65

Original Poster
Rep: Reputation: 15
Thanks pcunix

My wife found the xinetd for me, (I have no idea why she married me) your added lines is just what I needed. I also found that SWAT was not enabled in services
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rc.inetd.conf Alstare Slackware 5 12-08-2004 07:19 PM
convert from inetd.conf to xinetd.conf linuxturtle Linux - Networking 7 11-12-2003 05:23 AM
Please help!!! inetd.conf granny Linux - Newbie 4 12-10-2002 08:13 PM
/etc/inetd.conf RUN Linux - General 6 07-14-2002 07:57 PM
inetd.conf jondean Linux - Networking 2 12-05-2000 01:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration