-   Linux - Networking (
-   -   What VPN client under debian is stopping me from accessing the internet? (

shodekiagari 01-07-2005 12:07 PM

Title Change: ADSL Connection runs slower than a 16k modem!
Hello, I seem to have the same problem that many others have had. I can't access web pages even though I'm connected to the internet. I keep getting errors saying that "web pages have no data" under firefox. I can ping but the pings are very slow. Approximately once every five seconds a new line is written.

Accessing is possible; it takes approximately 3-5 minutes however. Occasionally something will sync and I'll get 15-20 minutes of dsl-like speeds. Then something will happen and it'll drop down to the glacially slow numbers.

I've checked with the people running the connection and they say everything comes through exceptionally clear when they check with my modem.
I've installed resolvconf (was told it might help keep the connection stable).
I've doublechecked all my dns errors
I've tried using the modem on knoppix (installed to hd), ubuntu (installed to hd) and mandrake (installed to hd)
I've tried the 2.4 and 2.6 kernels.
I've tried just about everything I could find to see if I could get it to work.

Information that may help you.
Currently running a 2.6 kernel with Ubuntu Linux
I have an ADSL account without a username/pass.
I have a speedstream 5360 modem. (no usb; has ethernet)
The resolv.conf, ifconfig, and route information are posted below.

If you have any further questions, please post. I'm at my wits end!

Thank you very much.

P.S. I changed the title to something more general as it turned out what I suspected it to be (an openswan/freeswan/ipsec conflict turned out not to be happening).

twsnnva 01-07-2005 01:23 PM

To stop IPsec.

/etc/init.d/ipsec stop

Edit: BTW to see if an application is installed in debian run.

dpkg -l programname
If dpkg reports a program and there is an ii to the left of the name, the program is installed.

shodekiagari 01-07-2005 04:24 PM

Thank you, however it turns out ipsec wasn't installed and I still can't access the internet. I think it might be line problems though.

twsnnva 01-07-2005 06:12 PM

Whats the output of "route", "ipconfig", and "cat /etc/resolv.conf"?

shodekiagari 01-07-2005 07:02 PM

Here ya go!
Alright, here are the results of those commands.

shodekiagari@shodekiagari:~ $ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * U 0 0 0 eth0
default 6x-136-x49-x.ds UG 0 0 0 eth0

shodekiagari@shodekiagari:~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 00:06:5B:90:9F:30
inet addr:64.1x6.1x9.5x Bcast:64.13x.x49.2x5 Mask:
inet6 addr: fe80::206:5bff:fe90:9f30/64 Scope:Link
RX packets:5024 errors:0 dropped:0 overruns:0 frame:0
TX packets:4799 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5082372 (4.8 MiB) TX bytes:544802 (532.0 KiB)
Interrupt:11 Base address:0xec00

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:49960 errors:0 dropped:0 overruns:0 frame:0
TX packets:49960 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3643132 (3.4 MiB) TX bytes:3643132 (3.4 MiB)

shodekiagari@shodekiagari:~ $ cat /etc/resolv.conf
nameserver 2x6.xx.64.86
nameserver 2x6.xx.64.87

I x'd out some of the numbers just in case. Not sure what anyone could use that info for, just not crazy for the idea of it being out there.

If this helps you any, I was able to connect for a short while and then the connection slowed down to a few b/ps. I think it may in fact be a more general thing than VPN. Do you think I should change the title?

Thank you for your time and patience.

twsnnva 01-07-2005 07:52 PM

Yes, changing the title is an excellent idea. I have no explanation for the connection slowing to a halt. Hopefully someone else has seen this before.


All times are GMT -5. The time now is 08:23 PM.