-   Linux - Networking (
-   -   What is required in order to see a windows share in Nautilus? (

thnker 04-22-2008 06:42 PM

What is required in order to see a windows share in Nautilus?
I'm using Fedora 9 beta on a ppc. I'm having trouble with samba, I think.

I can see the linux shares on windows machines - I assume this means that Samba is doing something for me.

I can mount a windows share using:

mount -t cifs -o username=u_name,password=pswd //laptop/c /mnt/laptop_c

However, I cannot view the same windows share from Nautilus. When I try - by entering smb://laptop/c in the location field, I get the following message:

"Error: Internal Error (failed to initialize smb context). Please select another viewer and try again."

What must I do in order to be able to mount / view windows shared folders from the nautilus file browser?

There is no "smbmount" command available. "mount -t smbfs..." complains that smbfs is an unknown file system type. modprobe smbfs fails because there is no smbfs.

jdavis2 04-22-2008 07:52 PM

If you have already mounted the share as /mnt/laptop_c why can't you just browse /mnt/laptop_c through nautilus?

thnker 04-22-2008 11:07 PM

What is required in order to see a windows share in Nautilus?
I can do that. However, using "mount... " in the first place was a troubleshooting measure. My understanding is that I should be able to mount / view windows shares from the GUI and not have to resort to the CLI. Thus... my question is essentially, why isn't Nautilus working the way it should? The fact that it isn't suggests that something somewhere is misconfigured and as the newbie that I am I would very much like to understand what is wrong.

jdavis2 04-23-2008 06:02 AM

You might want to check to see if you have installed the samba client files. I think that should help you with the unknown smbfs issue.

thnker 04-23-2008 10:51 AM

What is required in order to see a windows share in Nautilus?
That sounds like a good idea but I don't know where to begin. What Samba client files should there be and how can I determine which ones I have and don't have?

IsaacKuo 04-23-2008 11:14 AM

I don't really know how Nautilus's smb browsing works, but I'd say the most important thing required to see windows shares in Nautilus is extreme patience. Even when it works, it is stupidly sluggish. It's frustrating enough to go through the trouble of manually mounting.

XavierP 04-23-2008 02:41 PM

Go to /etc/samba and check that there is a file called smb.conf. If there is only smb.conf-sample, rename it to smb.conf and then try to browse again.

thnker 04-23-2008 03:56 PM

What is required in order to see a windows share in Nautilus?
Here is the smb.conf file I have:

#---------------------- smb.conf start -------------

workgroup = mshome
server string = mac450 Samba
netbios name = mac450
interfaces = lo eth0 wlan0
# logs split per machine
log file = /var/log/samba/log.%m
# max 50KB per log file, then rotate
max log size = 50
security = user
passdb backend = tdbsam
dns proxy = no
guest ok = yes
guest account = nobody
username map = /etc/samba/smbusers

comment = Home Directories
browseable = no
writable = yes

comment = All Printers
path = /var/spool/samba
browseable = no
printable = yes

comment = html pages
path = /var/www/html
public = yes
writeable = yes
browseable = yes

#---------------------- smb.conf stop -------------

I'm able to mount windows shares from the CLI and smbclient can connect to windows shares. One way to state the problem is that I can't use gnome's "Places|Connect to Server..." to connect to windows shares using something like smb://win_server/win_share. When I try that, I get "Can't display location smb://win_server/win_share. The specified location is not mounted".

My understanding is that is Samba is running - and it is - then I should be able to use "places|connect to server..." with a location like "smb://win_server/win_share" to mount the share rather than having to mount it from the CLI beforehand. Also, mounting it beforehand still does not solve the problem... same result.

jdavis2 04-23-2008 04:09 PM

You could type find / -name smb* and if you see any of the following files it has been installed. Look for smbclient, smbmnt, smbmount, smbprint, smbumount. If they haven't been installed you should be able to install them from your distribution disks.

I guess I was late on my answer. I see you have the samba client files.

jdavis2 04-23-2008 04:22 PM

I thought that when you used Connect to Server method that you were given the opportunity to type in the server, share, and user name. If so that will probably help you because windows is tricky you have to provide the proper credentials before it lets you access the shares. If you type the server name or server ip address without the smb:// prefix that might help.

thnker 04-23-2008 08:39 PM

What is required in order to see a windows share in Nautilus?
I tried find / -name smb* and got the following list of potentially relevant files. Some files, such as man pages etc have been omitted from the list for brevity.


Upon reviewing this list, I concluded that maybe the presence of smb4k is part of the problem because I don't have kde installed - or at least it wasn't functional. I uninstalled all the smb4k and kde related packages I could find among the list of installed packages then rebooted. I was surprised to find that the find command doesn't work as it did before. The same command (find / -name smb*) returns a result of:
"find: paths must precede expression
Usage: find [-H] [-L] [-P] [path...] [expression]"
I've not been able to make "find" work as before.

A couple of notable files that are missing from the above list are: smb_mount, smbfs and smb_umount. What if anything do I need to do to fix that? (Note that smbfs does appear in the ...fc8-ppc kernel area but I'm using ...fc9-ppc. Also, "mount -t smbfs..." fails due to unknown file system type).

My problem exhibits itself in several ways. I'm sure that at least some of the symptoms are telling me the answer but I'm too new to recognize them.

When I go to "smb:///" in nautilus, I'd expect to see all the samba mounts that can be found... instead, I get "Couldn't display "smb:///". Error: Failed to initialize smb context. Pelase select anotehr viewer and try again."

When I go to "network:///" in Nautilus, I get one icon named "Windows Network". When I double-click that icon to browse the windows network, I get "Unable to mount location. Failed to initialize smb context."

These two attempts to see samba shares seem to me to be the most fundamental things that nautilus should be able to do in connection with samba. If neither of these things can happen then no other method of accessing samba shares will either. Do these types of failures give you any additional ideas as to what is happening or not happening?

thnker 04-23-2008 08:41 PM

What is required in order to see a windows share in Nautilus?
Typing in the windows server name or its ip address without the smb:// didn't help either.

jdavis2 04-23-2008 09:50 PM

Okay it looks like you don't have smbmount which was called by nautilus but was not available. You mentioned that in the original post. Maybe you need to reinstall the samba client files. It will be on your installation disks. I don't know how comfortable you are with installing software but if you are new at it the easiest way is to look for a pakage maintenance program in your GUI menu.

As for the find command I think that you are using it from a subdirectory somewhere under the root directory. Type cd / and then try find / -name mount.smbfs that will tell you if it is present.

thnker 04-23-2008 10:58 PM

I removed all samba components using gnome's package manager and then reinstalled (rebooting after each step) and still no joy. I get the same response as before.

Also, there is still no smbmount or smbfs file (except the smbfs folder in the fc8 kernel folder).

I can still use smbclient to view win_shares from the CLI but gnome/nautilus still not working.

find / -name smb* still does not work even from the root directory but there is a gui based search tool that does work so I was able to search for anything with smb in the name.

The package manager reports that there are 4 samba related packages installed. These are:

1) samba-3.2.0-1.pre2.8.fc9.ppc - The samba suite of programs
2) samba-client-3.2.0-1.pre2.8.fc9.ppc - Samba client programs
3) samba-common-3.2.0-1.pre2.8.fc9.ppc - Files used by both samba servers and clients
4) samba-winbind-3.2.0-1.pre2.8.fc9.ppc - Samba winbind

thnker 04-24-2008 12:14 AM

I found this:

* Mon Feb 13 2006 Jay Fenlason <> 3.0.21b-2
- New upstream version.
- Since the rawhide kernel has dropped support for smbfs, remove smbmount
and smbumount. Users should use mount.cifs instead.


It seems to be saying that smbfs is no longer used and that there should be no smbmount program/script. I don't understand why the date is in 2006 given that last week, I was using fc8 and it had support for url's like smb://win_server/win_share.

btw... I am able to mount a winshare from the CLI using:

mount -t cifs //win_server/win_share /mnt/mnt_name

I was able to use url's like smb://win_server/win_share when using the fc8 kernel (I switched to fc9 for a completely different reason related to wireless networking).

Could it be that support for that was dropped - so that smb://win_server/win_share is no longer good - AND that Nautilus has not been updated? If that is the case, I would still like to know if there is a way to configure the ability to access windows shares using only the GUI... or does it have to be done in the CLI?

All times are GMT -5. The time now is 12:10 AM.