-   Linux - Networking (
-   -   Weird results with netstat (

nekromancer 02-16-2004 10:58 AM

Weird results with netstat
Hi, I am getting something weird while running netstat. I am unsure of what it means and it is the first time I see this...

I run Gentoo Linux with a Cable modem.

I see this along with other stuff...

tcp 0 0 TIME_WAIT
tcp 0 0 TIME_WAIT
tcp 0 0 TIME_WAIT

the address resolves to but when I check my /etc/hosts /etc/hostname and /etc/dnsdomainname files I don't see anything that resembles that name. I also don't remember anything using that...

Does anyone know off hand what is going on? Or maybe a config file I didn't look at that a program changed?

Larsin 02-16-2004 04:03 PM

Local host is simply your machine's internal network name, which resolves to For example, if you ping, you are pinging yourself to verify that your network card works. What you are seeing in netstat is normal.

Go to or google in your browser, and then run another netstat and you will see your machine non-local(meaning you will see the static address of your machine or another dynamically assigned address)IP address is now connected to the IP address of whatever website you just opened.

Hope that helps.

peter_robb 02-16-2004 04:33 PM

Also try using netstat -tanp & netstat -uanp to get a programme name and ip numbers...

nekromancer 02-17-2004 02:36 AM


I get more useful help off non-linux related areas.

Larsin,.. seriously... did I ask what localhost was? NO. I said I am getting an extra address identifying it self as and I run 1 single computer with no 196.x.x.x addresses. Imagine you netstat and you see 10 different addresses, each one resolving to ... thats a bit weird isn't it? espeically if you never assigned them.... Don't you think???


last time I'll ever post here.

All times are GMT -5. The time now is 04:09 PM.