-   Linux - Networking (
-   -   Weird DNS (?) behaviour (

jalonsom 10-31-2004 05:02 AM

Weird DNS (?) behaviour
Hello everybody.

I'm totally new to Linux and I've tried this week to install a system without success.
The main problem is with network. I have tried to do a net install with many flavours of Debian and a regular (CD) install with Ubuntu, and then tried GENTOO as it seemed to give me a lot of control over the installation process, but the network behaved in a strange way In all cases except with Knoppix Live CD, where there was no problem at all.

What I first noticed is that during Debian netinstall, I couldn't configure apt properly, since the installer couldn't connect to any server, giving a "network unreachable (" message.
Then I realized that with some CD images (test, I believe) I had an option to run a command line during install, so I did a ping to a few of those servers... Surprise! ping was successful! But there's more: after doing a ping to a certain server, apt could connect to it by its name!!!!, but only for a little time, after reboot it couldn't.
Even with some netinstall images (tiny test ones, I think) the installer could be downloaded from the net without doing the ping trick, but after the first reboot thing went as I explained before when getting to apt config.

The thing is that before giving up completely the whole Linux thing, I decided to try Knoppix and Ubuntu.
Ubuntu install CD failed exactly as Debian, so I decided to test the Ubuntu Live CD.
To my surprise, even if the two of them are Debian-based, there were no network problems with Knoppix, but there were strange ones with Ubuntu Live CD:
I could ping on terminal any address (IP or name), and could access internet from applications (Firefox browser, Gaim...), but only with IP, there seemed to be no name resolving.

With GENTOO (both LiveCD and Installed): Same as Debian and Ubuntu:
I can ping everywhere,
I can surf with links everywhere,
BUT: emerge gets no proper DNS, it gets ( for every server name, UNLESS I ping it just before, or UNLESS I add the entry to /etc/hosts.
I have the 8139too module loaded properly, as reported by lsmod, and lspci reports a RLT-8139 net card.

Do you see any explanation? (resolv.conf is OK, and with correct permissions).

It's a shame, I can imagine lots of people giving up and going back to windows because of so many installation/configuration problems..


# ip route dev eth0 proto kernel scope link src
default via dev eth0

eth0 Link encap:Ethernet HWaddr 00:50:FC:C0:89:3D
inet addr: Bcast: Mask:
inet6 addr: fe80::250:fcff:fec0:893d/64 Scope:Link
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2275 (2.2 KiB) TX bytes:2141 (2.0 KiB)
Interrupt:11 Base address:0xa000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:2677 errors:0 dropped:0 overruns:0 frame:0
TX packets:2677 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:197324 (192.6 KiB) TX bytes:197324 (192.6 KiB)

# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 eth0
default mygateway UG 0 0 0 eth0

jalonsom 10-31-2004 06:55 AM

I only have a good DNS behaviour on knoppix, but only when I boot the 2.4.27 kernel.
If I boot the 2.6 kernel, same behaviour as Debian, Ubuntu & Gentoo.....
Maybe this can be a clue?

All times are GMT -5. The time now is 06:13 AM.