LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-28-2016, 08:33 AM   #1
zkab
Member
 
Registered: Dec 2007
Posts: 142

Rep: Reputation: 16
Webmin & apcupsd for remote server


I have installed apcupsd on a Ubuntu server - the server has static IP 192.168.0.32
Also Webmin was installed on the server and interfaced with apcupsd according to https://help.ubuntu.com/community/apcupsd
When I enter in my workstation's browser https://192.168.0.32:10000 and goto 'Webmin/Others/APC UPS Daemon' I get:

Local Host Not available: upsfetch: tcp_open failed for 127.0.0.1 port 3551

where it should be something like this:

Local Host Smart-UPS 1500 ONLINE
100.0 % 231.7 VAC 17.5 % 32.9 C 62.0 min. All data

When I access the server's apcupsd from my workstation via command line I get following:

sudo apcaccess status 192.168.0.32:3551

APC : 001,043,1063
DATE : 2016-09-27 19:16:58 +0200
HOSTNAME : farbaute
VERSION : 3.14.10 (13 September 2011) debian
UPSNAME : FARBAUTE
CABLE : USB Cable
DRIVER : USB UPS Driver
UPSMODE : Stand Alone
STARTTIME: 2016-09-27 19:15:56 +0200
MODEL : Smart-UPS 1500
STATUS : ONLINE
LINEV : 240.3 Volts
LOADPCT : 16.1 Percent Load Capacity
BCHARGE : 100.0 Percent
TIMELEFT : 79.0 Minutes
MBATTCHG : 5 Percentsudo apcaccess status 192.168.0.32:3551
APC : 001,043,1063
DATE : 2016-09-27 19:16:58 +0200
HOSTNAME : farbaute
VERSION : 3.14.10 (13 September 2011) debian
UPSNAME : FARBAUTE
CABLE : USB Cable
DRIVER : USB UPS Driver
UPSMODE : Stand Alone
STARTTIME: 2016-09-27 19:15:56 +0200
MODEL : Smart-UPS 1500
STATUS : ONLINE
LINEV : 240.3 Volts
LOADPCT : 16.1 Percent Load Capacity
BCHARGE : 100.0 Percent
TIMELEFT : 79.0 Minutes
MBATTCHG : 5 Percent
MINTIMEL : 3 Minutes
MAXTIME : 0 Seconds
OUTPUTV : 240.3 Volts
SENSE : High
DWAKE : -01 Seconds
DSHUTD : 090 Seconds
LOTRANS : 208.0 Volts
HITRANS : 253.0 Volts
RETPCT : 000.0 Percent
ITEMP : 24.9 C Internal
ALARMDEL : 30 seconds
BATTV : 27.4 Volts
LINEFREQ : 50.0 Hz
LASTXFER : Automatic or explicit self test
NUMXFERS : 0
TONBATT : 0 seconds
CUMONBATT: 0 seconds
XOFFBATT : N/A
SELFTEST : NO
STESTI : 14 days
STATFLAG : 0x07000008 Status Flag
MANDATE : 2013-01-28
SERIALNO : AS1305221101
BATTDATE : 2013-01-28
NOMOUTV : 230 Volts
NOMBATTV : 24.0 Volts
FIRMWARE : UPS 08.3 USB_FW:LCC
END APC : 2016-09-27 19:17:53 +0200

MINTIMEL : 3 Minutes
MAXTIME : 0 Seconds
OUTPUTV : 240.3 Volts
SENSE : High
DWAKE : -01 Seconds
DSHUTD : 090 Seconds
LOTRANS : 208.0 Volts
HITRANS : 253.0 Volts
RETPCT : 000.0 Percent
ITEMP : 24.9 C Internal
ALARMDEL : 30 seconds
BATTV : 27.4 Volts
LINEFREQ : 50.0 Hz
LASTXFER : Automatic or explicit self test
NUMXFERS : 0
TONBATT : 0 seconds
CUMONBATT: 0 seconds
XOFFBATT : N/A
SELFTEST : NO
STESTI : 14 days
STATFLAG : 0x07000008 Status Flag
MANDATE : 2013-01-28
SERIALNO : AS1305221101
BATTDATE : 2013-01-28
NOMOUTV : 230 Volts
NOMBATTV : 24.0 Volts
FIRMWARE : UPS 08.3 USB_FW:LCC
END APC : 2016-09-27 19:17:53 +0200

So apparently my workstation can talk to the server 192.168.0.32 apcupsd ... but Webmin fails when it comes to apcupsd - all other information from Webmin for 192.168.0.32 is OK.
Where have I gone wrong ?
 
Old 09-29-2016, 11:05 PM   #2
gentisle
Member
 
Registered: May 2005
Location: Wisconsin, USA
Distribution: LinuxMint, NomadBSD
Posts: 259

Rep: Reputation: 9
I don't know if this will help, but I have a CyberPower UPS, and they have different software for Virtual guests. Does APC do the same? Maybe that's the case? Hope it at least helps.
 
Old 10-03-2016, 06:49 AM   #3
zkab
Member
 
Registered: Dec 2007
Posts: 142

Original Poster
Rep: Reputation: 16
I haven't found any APC software for Virtual guests ...
 
Old 10-03-2016, 08:59 AM   #4
gentisle
Member
 
Registered: May 2005
Location: Wisconsin, USA
Distribution: LinuxMint, NomadBSD
Posts: 259

Rep: Reputation: 9
Maybe APC needs to light a fire under their gluts.
 
Old 10-04-2016, 11:09 AM   #5
zkab
Member
 
Registered: Dec 2007
Posts: 142

Original Poster
Rep: Reputation: 16
I don't think it has to do with APC ... the problem lies probably in the third party module diego.caravana.to/wp-content/apcupsd0.812.wbm.gz
since everything in Webmin works OK for the remote server except the APC UPS Daemon module.
Also 'apcaccess' gives correct values for the server ... so apcupsd should also be OK.
I have googled for a solution for a long time but it seems that I have to file the problem to the Not-Solved-Problem-Archive ... which is getting bigger and bigger.
I can't be the first person on this planet who has encountered this ...
 
Old 10-04-2016, 11:17 AM   #6
gentisle
Member
 
Registered: May 2005
Location: Wisconsin, USA
Distribution: LinuxMint, NomadBSD
Posts: 259

Rep: Reputation: 9
Sorry to hear, that's not good, but have you tried "Googling" on //duckduckgo.com and startpage.com? I usually search on all three because they usually come up w/some different sites. They're not always helpful, but at least it gives me more peace of mind that I did a good search. I used to have APC, but the battery died, and I haven't bothered to check if a replacement is available and cost effective. Sorry I couldn't help.
 
Old 10-04-2016, 12:00 PM   #7
zkab
Member
 
Registered: Dec 2007
Posts: 142

Original Poster
Rep: Reputation: 16
Thanks - I'll have a look at duckduckgo.com and startpage.com
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
APCUPSD - No permissions to shutdown server cultavix Linux - Hardware 1 12-03-2012 06:32 AM
Install & Configure Squid Proxy Server, Dansguirdian, with webmin in centos pragneshsachania Linux - Networking 0 11-15-2011 05:06 AM
Monitoring Hardware Health: lm_sensors, smartd & apcupsd njdube Linux - General 2 06-07-2007 08:03 PM
Python: raw_input & puTTy on remote server Hairein Programming 1 01-01-2007 09:25 AM
Remote Webmin Saber99 Linux - Networking 3 08-07-2001 05:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration