LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 10-24-2008, 09:40 PM   #1
timnp
Member
 
Registered: Feb 2008
Location: London
Distribution: FC8, FC9, Centos 4, Centos 5, Knoppix
Posts: 52

Rep: Reputation: 16
wake on lan issue


Hi,

I have a Dell Poweredge 2550 that I'm trying to get to respond to wake on lan packets.

Is wake on lan complicated? I didn't used to think so. When I first got the machine in question (second hand), I thought "Hey, wouldnt it be great if it supports wake on lan", I sent the magic packet to it an lo and behold it booted. Great.

Now it doesnt respond to it though

Most things I read recommended running something like

ethtool -s eth0 wol g

Which when I power off the machine (using `shutdown -Ph now` (does that matter?)), it goes through all the usual motions but won't respond to the the magic packet to bring it back up.

I looked on the dell site and followed their instructions for creating a boot disk that can alter the wol settings, essentialy it was an MS-DOS boot disk and a utility for the intel boot agent called "ibautil", if I run this from the boot disk...

ibautil -nic=1 -wole

Then power the machine off it will respond to magic packets and power up. If I power it off while its still in the BIOS then sometimes it will respond to another magic packet and othertimes it wont.

If however, I let it go all the way through its boot cycle (it doesnt have an HD, it netboots using PXE), then it will boot the OS and upon shutting the box down it will not respond anymore to magic packets. This is even if I run the `ethtool -s eth0 wol g` command from within the operating system.

As this machine is one of a small group (all identical hardware and problem), it would be nice to have this feature so I could rely on it to remotely turn machines on and off.

My guess is that something in the boot sequence, possibly even the design of WOL, clears the WOL setting and I need to apply this again at OS shutdown time. Bits i've pieced together suggest it might be a wake on pci issue.

Any thoughts?
 
Old 10-26-2008, 10:22 AM   #2
timnp
Member
 
Registered: Feb 2008
Location: London
Distribution: FC8, FC9, Centos 4, Centos 5, Knoppix
Posts: 52

Original Poster
Rep: Reputation: 16
A follow up to this, I still don't know exactly what the issue is but I've read on news groups of people in the same situation, basically me (and them), dont have disks in the machines and they do a netboot with PXE. That means that there is an nfsroot and so when it comes to halting the system things aren't done as they normally would be because the connection needs to be kept open. I can't be more specific than that though and i'm not even sure if its right but it seems to fit.

http://groups.google.com/group/linux...e8fb9?lnk=raot
 
Old 10-26-2008, 11:53 AM   #3
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Thanks for the follow-up.

I subscribed to this thread when you first posted, hoping you, or someone, would post a solution.

The problem seems to be that the interface is "fully shut down" at halt so it no longer listens for the "magic packet". This possibly saves a tiny bit of power.

I tried looking at how shutdown and halt work but I am none the wiser.

I think we'll have to wait until the developers wake up to the problem.

If you search for wake on lan broken you'll see lots of discussion (but I found no solution, perhaps you'll be luckier).

This is also quite a good link for wol, if it was functioning:
http://www.archlinux.it/wiki/index.p...le=Wake-on-LAN
 
Old 10-27-2008, 11:42 AM   #4
timnp
Member
 
Registered: Feb 2008
Location: London
Distribution: FC8, FC9, Centos 4, Centos 5, Knoppix
Posts: 52

Original Poster
Rep: Reputation: 16
Sadly I am none the wiser. I have done a lot of reading on it now and have found others in the same situation, a few possible solutions but none of them seem to work.

The issue is definitely in how the interface is shut down (otherwise I wouldn't be able to make the wakeonlan bootdisk). My suspicions about it being related to PXE and nfsroot turned out to be false as I made a liveCD of exactly the same thing that would otherwise get netbooted and when I shutdown from there it still failed.

If your interested, the card I'm using is an intel e100, if you search for IBAUTIL.EXE and write it to an MS-DOS 6 or greater boot disk (which you can get from www.bootdisk.com ), you can then boot into that and use the IBAUTIL.EXE to enable WoL. Shut the machine down and WoL works, let it boot into Linux and it'll fail IBAUTIL.EXE is specific to the Intel Boot Agent so if your card isn't intel based it won't work.
 
Old 10-27-2008, 05:26 PM   #5
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Quote:
The issue is definitely in how the interface is shut down
I agree.
I have not found a work-around for this, and will await the next kernel release, I think the developers are aware of the problem(s).
I cannot see the point of re-booting from an "MS-DOS 6 or greater boot disk", and then shutting down the server. Besides, my interface is different from yours.
The Newsgroups are full of this problem, it'll sort out.
Wait, and be patient - cleverer people will (eventually) sort this out.
You / I'll re-post here if and when a solution is found.
 
Old 10-28-2008, 06:14 AM   #6
timnp
Member
 
Registered: Feb 2008
Location: London
Distribution: FC8, FC9, Centos 4, Centos 5, Knoppix
Posts: 52

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by tredegar View Post
I cannot see the point of re-booting from an "MS-DOS 6 or greater boot disk", and then shutting down the server.
Oh no, it isn't a practical solution, it was useful in my case so I could be sure that the network card, motherboard, power supply etc supported WoL and that I was sending the magic packet correctly. It's pretty useless for day to day unattended booting.
 
Old 03-17-2009, 11:48 AM   #7
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
I finally got WOL to work by re-enabling WOL after linux had shut it down
The details are here: http://www.linuxquestions.org/questi...l-work-712283/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wake on Lan & Sleep on lan? ufmale Linux - Networking 1 06-25-2008 05:34 PM
wake on lan magic packet does not wake. albean Linux - Networking 1 06-30-2007 03:57 PM
wake on lan upload-3 Linux - Networking 2 06-12-2006 01:00 PM
wake on lan?? alaios Linux - Hardware 2 08-10-2004 01:04 PM
Wake-on-LAN dARkHunTEr Linux - Hardware 0 11-04-2003 04:17 PM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration