LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-26-2004, 04:45 AM   #1
checta
LQ Newbie
 
Registered: Apr 2004
Posts: 21

Rep: Reputation: 15
vsftpd problems with anonymous login


Hello!
I have RedHat 9.0 and vsftpd-1.1.3-8

I wish to setup vsftpd WITHOUT anonymous login, however despite following numerous threads / tutorials ... whatever i could find i get
530 This FTP server is anonymous only.
Login failed.

The red hat manual says vsftpd is anonymous by default but the only thing i can find that should disable it is by commenting out the conf command anonymous_enable.

Here is my current vsftpd.conf
Code:
# /etc/vsftpd/vsftpd.conf
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
#anon_upload_enable=YES
#anon_mkdir_write_enable=YES
#dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
#xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
#idle_session_timeout=600
#data_connection_timeout=120
#nopriv_user=ftpsecure
#async_abor_enable=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES
ftpd_banner=Welcome to the jcyoung FTP service.
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
#ls_recurse_enable=YES
pam_service_name=vsftpd
userlist_deny=NO
userlist_enable=YES
userlist_file=/etc/vsftpd.user_list
tcp_wrappers=YES
local_root=/home/ftproot
I have uncommented and then recommneted the anonymous_enable but it seems to have no effect ... is there something that vsftpd looks at other than this config to determine the server is anonymous only??

Help would be much appreciated!!

Cheers,
Claire
 
Old 06-26-2004, 02:39 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
Where have you saved vsftpd.conf? /etc/ or /etc/vsftpd/?
 
Old 06-26-2004, 07:32 PM   #3
checta
LQ Newbie
 
Registered: Apr 2004
Posts: 21

Original Poster
Rep: Reputation: 15
vsftpd.conf is in /etc/vsftpd/ some of the docs said this is where it is suppossed to be for redhat 8 +

i also copied the file and put it under /etc/ to see it that would do anything but nothing changed.

 
Old 06-27-2004, 07:24 AM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
Did you restart vsftpd?
 
Old 06-27-2004, 08:07 AM   #5
checta
LQ Newbie
 
Registered: Apr 2004
Posts: 21

Original Poster
Rep: Reputation: 15
yep, several times but i will do it one more time and let you know what happens!
 
Old 06-27-2004, 09:38 AM   #6
checta
LQ Newbie
 
Registered: Apr 2004
Posts: 21

Original Poster
Rep: Reputation: 15
i rebooted and still no luck
 
Old 06-27-2004, 02:49 PM   #7
twsnnva
Member
 
Registered: Oct 2003
Location: Newport News, Va
Distribution: Debian
Posts: 246

Rep: Reputation: 30
I can't understand why that dosen't work for you but here is a copy of my vsftpd.conf, which works fine.

listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=YES
chown_username=thomas
chroot_local_user=YES
 
Old 06-30-2004, 09:25 AM   #8
checta
LQ Newbie
 
Registered: Apr 2004
Posts: 21

Original Poster
Rep: Reputation: 15
OK! I got it working - thanks to both twsnnva & david_ross!

Here is the final conf file ...

Code:
ftpd_banner=WOOHOO!! IT'S WORKING
#listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=YES
chown_username=ftpuser
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
userlist_deny=NO
userlist_enable=YES
userlist_file=/etc/vsftpd.user_list
pam_service_name=vsftpd
I also figures that may version of vsftpd uses the conf at /etc/vsftpd.conf despite many sites saying that from redhat9.0 on wards it should be /etc/vsftpd/vsftpd.conf or have i got that upside down?

By not setting local root in the config but having ftp users that own the selected folder the desired setup was achieved whereby i can log in as a normal user but am not chrooted so can access anything whereas users who are not local but dedicated ftp users can only access the one folder for ftpusers and other local users can access their home directories with no annoynomus login.


checta ... on to battle the next one
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd anonymous login r.stiltskin Linux - Networking 4 03-16-2007 11:19 PM
vsftpd anonymous overwrite lapthorn Linux - Security 3 10-11-2006 11:20 AM
SUS9.3: can't do vsftpd anonymous login fisayo SUSE / openSUSE 1 11-16-2005 11:39 PM
vsftpd won't follow links for anonymous login sebaldus Linux - Software 7 08-22-2004 02:14 AM
Anonymous AND Normal Login with VsFTPd Fussi Linux - Networking 1 06-18-2004 10:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration