LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-10-2003, 11:04 AM   #1
RSKeisuke
LQ Newbie
 
Registered: Mar 2003
Location: Austin, TX
Distribution: Red Hate 8
Posts: 4

Rep: Reputation: 0
VSFTPD problems


I seem to have everything setup correctly, but vsftpd still won't work. I'm sure it's something stupid but I'm quite new to this mess so I don't know what the computer wants me to do. Every time I try to start the ftp server, I get this message: "500 OOPS: could not bind listening socket". Does anyone know what I should do about this?
 
Old 03-10-2003, 09:21 PM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
how do u start vsftpd? all u need to do is:

/sbin/chkconfig vsftpd on

and tail -f /var/log/messages for hints.

to check if ftp is listening, run this:

netstat -ln | less

and look for something like '0.0.0.0:21'. port 21 is the ftp port by default. Also, be sure that you fwall ruleset allow incoming ftp connections.
 
Old 03-10-2003, 11:45 PM   #3
RSKeisuke
LQ Newbie
 
Registered: Mar 2003
Location: Austin, TX
Distribution: Red Hate 8
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by born4linux
how do u start vsftpd? all u need to do is:

/sbin/chkconfig vsftpd on

and tail -f /var/log/messages for hints.

to check if ftp is listening, run this:

netstat -ln | less

and look for something like '0.0.0.0:21'. port 21 is the ftp port by default. Also, be sure that you fwall ruleset allow incoming ftp connections.
I have done of all that, and yet still I get
500 OOPS: Could not bind listening socket.
 
Old 04-21-2003, 10:25 AM   #4
thomaswoof
LQ Newbie
 
Registered: Apr 2003
Posts: 2

Rep: Reputation: 0
same here

I am also having this problem... someone please help =) ...
 
Old 04-21-2003, 11:42 AM   #5
thomaswoof
LQ Newbie
 
Registered: Apr 2003
Posts: 2

Rep: Reputation: 0
see http://www.linuxquestions.org/questions/history/49958

change this line in your vsftpd.conf file from:

listen=YES

to:

listen=NO

the problem is that xinetd is listening on port 21 and with listen=YES in the vsftpd.conf, vsftp is also trying to listen to port 21 in standalone mode (the thread in the url above explains this better, I'm just a newbie). When I changed that line, the "500 OOPS: Could not bind listening socket" error disappeared and I could then log onto ftp.

Hope this helps anyone having this problem =)
 
Old 07-27-2004, 08:28 PM   #6
zoonalex
LQ Newbie
 
Registered: Aug 2003
Location: Mexico
Distribution: Fedora 7
Posts: 5

Rep: Reputation: 0
Question VSFTPD problem

How can I log as a local user?, if I already changed the annonymus_enable option to NO, and local_enable option to YES, and I still have the listen option with YES. Also, I haven't used xinetd neither inetd.

Does it affect to the server when I try to log as a local user?

Last edited by zoonalex; 07-27-2004 at 08:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd problems Timme Linux - Newbie 4 11-18-2005 09:57 PM
vsftpd Problems jazee Linux - Software 6 10-14-2005 12:41 AM
vsftpd problems vswr31 Linux - Software 6 07-18-2005 01:25 PM
VSFTPD problems cwolf78 Linux - Software 10 05-12-2005 10:28 PM
VSFTPD problems cwolf78 Linux - Software 4 04-24-2005 05:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration