-   Linux - Networking (
-   -   vsftpd + pam + virtual users - Pam cannot load database file. (

mdkelly069 11-30-2003 04:49 PM

vsftpd + pam + virtual users - Pam cannot load database file.
Hi all,

I know this is something that has probably been beaten to death, but I just cannot get it working.

I have followed this tutorial to the letter: (great site by the way) but I am still faced with a serious issue. When I try to log in with the account I have created using the steps at the above site it just says
"Invalid username and password" and will not let me log in.

When I check the log in /var/log/messages it states that pam cannot open the database.

The vsftpd.log states the I tried to log in but login has failed.

I am using RedHat 9 (updated) which has version 4 of the db_load app, and I am using vsftpd-1.2.1 that I compiled from source. I was thinking that using version four could be the problem, but I am concerned about installing version 3 as I do not know what it or installing any of its dependant files will do to my system. Yes I am pretty much of a n00b at this level of Linux.

The service is running and I am connecting to the correct IP address. I did find this exact problem in another thread, but the poster was directed back to the above web page and no solution was posted to the forum.

I thank you for any and all suggestions

mdkelly069 11-30-2003 08:01 PM

working sort of
Hi all,

okay it is working, except connections from the localhost are refused

Here is what I did:

1) wiped out vsftpd and started from scratch
2) re-installed vsftpd
3) made vsftpd.conf according to the webpage listed earlier
4) grabbed version 3 of db_load (tar.gz)
5) created my pam database using version 3 0f db_load
6) created all necessary folders and files according to above web site
7) removed the xinetd files pertaining to vsftpd
8) started vsftpd
9) logged in from another machine as localhost connections are still refused
10) was happy because it worked

I am not sure what changed other than using version 3 of db_load, but it is working now.

Now onto the rest of the set up


mdkelly069 12-03-2003 10:15 AM

latest update
hi again all,

Just wanting to update this incase anyone else has the same problems with a similar setup.

The problem with the database file was not the use of db4, it was the use of kwrite to create the text file that I was converting to the database file.

I ran into another issue, not with the ftp, but another project I was working on and for some reason the text file created by kwrite was being rejected. I pull out my eye-teeth and moved to vim, created the same file it was accepted without question.

This got me curious so I redid my text file for the pam database used by vsftpd. It worked no problem.

I am happy to say that my ftp sevrver is running smoothly behind my firewall/router using port forwarding with dynamic dns service from no-ip/com. Next step is to get the no-ip update tool running on my linux machine.


mossy 09-22-2004 11:07 PM

What command did you use to db it in order for vsftpd to accept it?

All times are GMT -5. The time now is 03:29 AM.