LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-13-2006, 12:02 PM   #1
ziox
Member
 
Registered: Apr 2004
Distribution: RedHat, Fedora, Suse, Debian, Gentoo, Mandrake
Posts: 132

Rep: Reputation: 15
vsftpd dead but subsys locked


Hi there
I got a problem after adding few lines in vsftpd.conf
about enabling ssl
my conf file look like this
#==========================
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_file=/var/log/vsftpd.log ''i never found that log file"
xferlog_std_format=YES
idle_session_timeout=600
chroot_local_user=YES
"still able to brows the entire system when I use something like WinScp sftp://mysite but from a regular browser it is fine just
pub and my home_dir!!!"
syslog_enable=YES
pam_service_name=vsftpd
userlist_enable=YES
listen=YES
ssl_enable=YES
ssl_tlsv1=YES
ssl_sslv2=YES
ssl_ss1v3=YES
rsa_cert_file=/etc/secrets/vsftpd.pem
#==========================
vsftpd is running but when I run "service vsftpd status"
i always getting this message "vsftpd dead but subsys locked"
I found the same problem on a lot of forums some said it is related to the .pid file
but still getting this message
when I removed the ssl lines it works fine
 
Old 06-13-2006, 01:25 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
i always getting this message "vsftpd dead but subsys locked"
This message is not from Vsftpd but the SysV init script.
Usually happens when the app bails out due to a config problem.


when I removed the ssl lines it works fine
Then by all means read the log ("touch" it if it doesn't exist) and reread the docs about using SSL. I think it would be best to start with getting a "basic" config to work and test between adding functionality. That way you get a better grip on what goes wrong.


xferlog_file=/var/log/vsftpd.log ''i never found that log file"
Lines like these are not valid AFAIK. Most apps require using the crunch, splat, pound sign, number sign, hash mark or whatever you call the "#" glyph to comment.
 
Old 06-14-2006, 12:28 PM   #3
ziox
Member
 
Registered: Apr 2004
Distribution: RedHat, Fedora, Suse, Debian, Gentoo, Mandrake
Posts: 132

Original Poster
Rep: Reputation: 15
thanks for your reply
I got that log file after I added this line
dual_log_enable=YES
and this message "SysV init msg" stopped after I commented out these lines
#ssl_sslv2=YES
#ssl_ss1v3=YES
and I added these 2 lines also
force_local_data_ssl=YES
force_local_logins_ssl=YES
but now I'm in different issue
when I connect ftp://mysite it works fine
but ftp://someone@mysite it give me 530 Non-anonymous sessions must use encryption
what I'm suppose to write in the url sftp yelled another program as ssh and scp
 
Old 06-14-2006, 04:08 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
ftps://uri ?
 
Old 06-15-2006, 08:15 AM   #5
ziox
Member
 
Registered: Apr 2004
Distribution: RedHat, Fedora, Suse, Debian, Gentoo, Mandrake
Posts: 132

Original Poster
Rep: Reputation: 15
I did that already --firefox doesn't know how to open this uri
IE something like rewrite it as ftp://mysite then ask me the user/pass
then gives me the same "530 NON blablabla msg"
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd settingd and VSFTPD DEAD BUT SUBSYS LOCKED pc_copat Linux - Newbie 15 11-05-2009 10:31 PM
radiusd dead but subsys locked velocitygirl Linux - General 5 10-27-2005 09:40 AM
vsftpd dead but subsys locked? ciberrust Linux - Software 6 11-29-2004 07:11 AM
vsftpd dead but subsys locked ??? markstevens Linux - Software 43 03-18-2004 10:14 AM
vsftpd dead but subsys locked jon_k Linux - Software 2 07-16-2003 04:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration