LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-03-2005, 10:06 PM   #1
Malkaven
LQ Newbie
 
Registered: Jan 2005
Posts: 8

Rep: Reputation: 0
VSFTPD.conf


Im new to linux. Im using fedora core 3.
Im trying to get a ftp server up. Ive installed
vsftpd and the service is running, i can even log on my
server annon.

I want to edit the vsftpd.conf file so i can
setup my server but the vsftpd.conf file wont let me edit
or modify, or even view. say i dont have the permissions for this.
does this make sense for anyone? trying to edit the one in
/ect/vsftpd/vsftpd.conf.
 
Old 01-03-2005, 10:09 PM   #2
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Rep: Reputation: 30
You probably don't have the permissions. I'm assuming your doing this on a non root account. You can either edit it as root or chmod it as root.
 
Old 01-03-2005, 10:25 PM   #3
Malkaven
LQ Newbie
 
Registered: Jan 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Talking

yup that was it thanks. logged in under the root account. thought i could
just use the root password authorization under a non root account. guess not hehe.
 
Old 01-04-2005, 05:45 AM   #4
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Rep: Reputation: 30
You can always use sudo or change the permissions of the file.
 
Old 03-08-2006, 04:34 AM   #5
carilmu
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Rep: Reputation: 0
hi..
i'm a newbie.i also have the same problem as malkaven...but i still couldn't edit the vsftpd.conf file when i type

#whoami
root

it says that i am the root.How can i use the chmod statement? thanks.
 
Old 03-08-2006, 06:48 AM   #6
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
@carilmu, first off, it's unpolite to take over someone else's thread. Consult the forum rules for that one.
Nevertheless, if you are root, then you have access to all files on the filesystem, regardless of the permissions.

For clues on how to use chmod, consult it's man page.
You can alter permissions either numerically or via characters.
ie
chmod 644 some_file (makes file read-write for owner, read-only for anyone else)
chmod u+rw some_file (gives the owner read-write permission)
Be careful using chmod however. File permissions are a very important part of your system's security.
Post back if you have any trouble.
You need to be either root or the file's owner to be able to change the file permissions for a certain file.

@Malkaven: you can impersonate the root user while you're logged in as some non-root user.
The commands "su" (switch user) and "sudo" (impersonate root for execution of certain commands) can help you with that. After an "su", type "exit" to revert back to previous user. Of course, you'll need the passwords for all users you want to impersonate.
 
Old 03-08-2006, 10:48 AM   #7
carilmu
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Rep: Reputation: 0
hi all.
sorry for taking over the thread. i apologize and thanks to timmeke for pointing it.i didn't meant to be like that.

btw, i used the
#vi /etc/vsftpd.conf

and proceed to edit the file after i make a backup.

really guys, sorry for my mistake...
 
Old 03-09-2006, 02:01 AM   #8
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
No problem, carilmu. Just remember to create your own thread if you need help.
In short:
-make a copy of /etc/vsftpd.conf as backup
-then edit the settings
-finally, restart vsftpd so it reads the configuration changes.
Something like
Code:
service vsftpd restart
should accomplish that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd.conf/chroot/vsftpd.chroot_list issue Jerman Linux - Security 2 06-01-2007 07:24 PM
Restricting FTP access in vsftpd.conf jomy Linux - Networking 0 11-05-2005 02:09 AM
vsftpd.conf - 550 error need help zaoka Linux - Software 3 08-02-2005 11:10 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 01:05 AM
vsftpd problems with .conf and uploading. pulling my hair out! mindfestival Linux - Newbie 6 06-27-2004 11:58 AM


All times are GMT -5. The time now is 10:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration