LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-03-2005, 08:46 AM   #1
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Rep: Reputation: 15
Unhappy vsftpd bad-ip connecting


Aight, I'm having this annoying issue with vsftpd. Whenever I attempt to direct my browser (IE 6) to ftp://joer.homelinux.com/ I get prompted for my username and password. Once, I do that I receive this error:

"An error occured while opening that directory on the FTP Server. Make sure you have permission to access this folder."

Details:
200 Switching to ASCII mode
227 Entering Passive Mode 192, 168, 1, 5, 95, 91
425 Security: Bad IP connecting

Though, through my terminal on linux or command prompt. I can do the following:

joer@venus:/etc $ ftp
ftp> open joer.homelinux.com
Connected to joer.homelinux.com.
220 Welcome to Joe's FTP service (updated for faster service).
Name (joer.homelinux.com:joer): webuser
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

This gives me perfect access... now when I'm on my browser and direct to my 'local' IP, 192.168.1.5 it will prompt for the username/password. I push those through and it logs in perfectly.

I have no firewall as you can see below. I port forwarded 20-21 for FTP, but that shouldn't have much to do with it... since it's working through the terminal or windows command prompt.

joer@venus:/etc $ sudo iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
joer@venus:/etc $


If you need to see my /etc/vsftpd.conf file, let me know

Open to suggestions.
 
Old 08-04-2005, 07:56 PM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,521

Rep: Reputation: 99
Perhaps your browser is configured to use a proxy?
 
Old 08-04-2005, 08:11 PM   #3
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Original Poster
Rep: Reputation: 15
I don't believe so. In my Internet Explorer, Connections Tab (Advanced) there is no proxy setup. If you meant something else, could you elaborate more on how I can tell?

Thanks
 
Old 08-04-2005, 11:17 PM   #4
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Quote:
Originally posted by javamdk
227 Entering Passive Mode 192, 168, 1, 5, 95, 91
425 Security: Bad IP connecting
perhaps you need this option set to YES in your conf file:
Quote:
pasv_promiscuous
Set to YES if you want to disable the PASV security check that ensures the data connection originates from the same IP address as the control connection. Only enable if you know what you are doing! The only legitimate use for this is in some form of secure tunnelling scheme, or perhaps to facilitate FXP support.

Default: NO
http://vsftpd.beasts.org/vsftpd_conf.html
 
Old 08-04-2005, 11:34 PM   #5
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Original Poster
Rep: Reputation: 15
Genious! It works great, much appreciated...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd Problem with 425 Security: Bad IP connecting elchui Linux - Newbie 8 07-29-2011 10:21 AM
Problem connecting to vsftpd Khang Linux - Software 5 04-11-2006 12:35 PM
Problem connecting to vsftpd from Internet kejohnson75 Linux - Networking 0 02-29-2004 09:11 PM
vsftpd connecting problem tr0gd0O0r Linux - Networking 19 12-11-2003 02:59 PM
vsftpd 425 bad ip error raven282 Linux - Software 2 05-01-2003 04:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration