LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-03-2004, 12:44 AM   #1
mieslep
LQ Newbie
 
Registered: May 2004
Location: Minneapolis, USA
Distribution: Mandrake 10CE
Posts: 19

Rep: Reputation: 0
vsftpd and local users not working...but configured right (methinks!)


I had this working on one machine, not sure why my current one is giving me so much grief. I'm on Debian. I get a 530 error when trying to connect with any user (anonymous worked okay when I had that enabled). I have the user_list and chroot_list files set up with a test username, the user has /bin/bash shell (though changing that doesn't seem to have mattered). Any ideas would be most welcome!

Here's by vsftpd.conf file:

# Access rights
anonymous_enable=YES
local_enable=YES
local_umask=022
write_enable=YES
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO

# Users must be in the userlist_file
userlist_enable=YES
userlist_deny=NO
userlist_file=/etc/vsftpd.user_list
chroot_list_enable=YES
chroot_local_user=YES
chroot_list_file=/etc/vsftpd.chroot_list
guest_enable=NO

# Security
anon_world_readable_only=YES
connect_from_port_20=YES
pasv_min_port=50000
pasv_max_port=60000
pasv_promiscuous=YES

# Features
xferlog_enable=YES
ls_recurse_enable=NO
ascii_download_enable=NO
async_abor_enable=NO
ftpd_banner=Welcome to my FTP server!

# Performance
idle_session_timeout=120
data_connection_timeout=300
accept_timeout=60
connect_timeout=60
anon_max_rate=50000

Last edited by mieslep; 11-03-2004 at 11:31 PM.
 
Old 11-03-2004, 11:32 PM   #2
mieslep
LQ Newbie
 
Registered: May 2004
Location: Minneapolis, USA
Distribution: Mandrake 10CE
Posts: 19

Original Poster
Rep: Reputation: 0
Any help please?
 
Old 11-04-2004, 06:54 PM   #3
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
What do you have in your /etc/vsftpd.user_list ?
 
Old 11-04-2004, 11:32 PM   #4
mieslep
LQ Newbie
 
Registered: May 2004
Location: Minneapolis, USA
Distribution: Mandrake 10CE
Posts: 19

Original Poster
Rep: Reputation: 0
# cat /etc/vsftpd.user_list
testuser
#

# cat /etc/vsftpd.chroot_list
testuser
#

# grep testuser /etc/passwd
testuser:x:1001:1001:Test FTP User,,,:/home/testuser:/bin/bash
#

Thanks,
:-Phil
 
Old 11-05-2004, 12:49 AM   #5
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
from: man vsftpd.conf


chroot_list_enable
If activated, you may provide a list of local users who are placed in a chroot() jail in their home directory upon login. The meaning is slightly different if chroot_local_user is set to YES. In this case, the list becomes a list of users which are NOT to be placed in a chroot() jail.


In other words, if you want to chroot all users, use:
chroot_local_user YES
chroot_list_enable NO

Or if you do enable the list, put a list on non-chrooted users in it. In the current configuration I would expect it to give you the same tree as anonymous.

Have you checked the log yet? It's either in the system log or /var/log/vsftpd.log
 
Old 11-05-2004, 09:31 AM   #6
mieslep
LQ Newbie
 
Registered: May 2004
Location: Minneapolis, USA
Distribution: Mandrake 10CE
Posts: 19

Original Poster
Rep: Reputation: 0
Problem is that I get a 530 (access denied) error...I can't get as far as logged in...
 
Old 11-05-2004, 01:21 PM   #7
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Yes, but what does the logfile say?...

Other things I can see to check (that you probably already have):

Does your test user's home directory exist?

Is your userlist readable by the ftp daemon? What permissions does the Daemon run with (root, ftp, etc.)? what are the ownership and read permissions on the file. You might try:
chmod a+r /etc/vsftpd.user_list
if you think your daemon might not be reading the file

You could also turn the user list off to see if it may be the problem.

You could turn off the chroot list also to see if it is the problem. etc.


As always, good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd, web uploads, vsftpd virtual users, apache virtual hosts, home directories jerryasher Linux - Software 7 02-18-2007 07:29 AM
VSFTPD Local Test Palula Linux - Software 19 10-26-2005 09:58 PM
how to authenticate external users but bypass prompt on local LAN users? taiwf Linux - Security 5 07-13-2005 10:01 AM
vsftpd no connection other than local killahsmurf Linux - Networking 3 04-13-2005 03:42 AM
vsftpd and (some) local users totothehero Linux - Networking 0 09-29-2004 05:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration