-   Linux - Networking (
-   -   VPN connection issue (

Joe_Zhu 12-10-2009 12:31 AM

VPN connection issue
Hi i am using ubuntu 9.10 32bit.

recently i setup a PPTP VPN server in my linksys router running DD WRT at home.
and in the ubuntu laptop in my office, i configure manually a vpn connection by following the instruction in following webpage

at first i thought it is successful, i can ping, SSH, FTP to my NAS from my laptop, however, when i try to open the web interface, it never come up in my browser.
here is my routing table in the ubuntu laptop after the pptp connected.
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * UH 0 0 0 ppp0
119246039114.ct UGH 0 0 0 eth0 * U 0 0 0 ppp0 * U 0 0 0 eth0
link-local * U 1000 0 0 eth0
default UG 100 0 0 eth0 is the remote network.

it is so strange!

then i try to connect by another windows laptop from office, it just works seamlessly.

anyone can help?


Joe_Zhu 12-10-2009 01:36 AM

when i compare the windows pptp and linux pptp connection i found the different in the gateway.
in linux:
ppp0 Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:

in windows

IP address........:
Default Gateway...:

but i don't know why in linux the p-t-p will become ? where to set it??

pls. help!

Web31337 12-10-2009 04:00 AM

what about gateway in linux?
P-t-P is set by VPN serv.
can you ping are you sure you enabled web interface for LAN? do you access it as ? i presume it's an IP of router.
btw have no idea why windows tells a gateway is your own ip, it can't be.
what's wrong with subnet mask? i think it shouldn't be, usually it's
i think you should look into your router's settings.

scheidel21 12-10-2009 08:28 AM

No point to point has a subnet mask of becuase it is a point to point that's normal. I don't know why the browser isn't working but it seems to me that his PPTP connection is working if he can ping ssh, etc... it seems more browser specific. We need to know the full story IP network range key IPs like the router, and the server setup on the DD-WRT linksys in order to help better.

Joe_Zhu 12-11-2009 01:03 AM

my DD-WRT router ip address is, it is the default gateway for all equipment in this network. it connect to ISP by ethernet and DHCP. (no modem, pppoe)

and the pptp server setting are;

Server IP:
Client IP(s):
broadcast support: enable
Force MPPE enceryption: enable

what will be the problem?


p.s. i tried to change the server ip to, as told in DD-WRT wiki.
but still not work for my linux pptp client ...
again the windows client has no problem.

scheidel21 12-11-2009 09:01 AM

Might this have anything to do with Proxyarp settings maybe data is not getting back to it properly, additionally your server address if I recall correctly should be the same as the server itself. However, it looks like everything is setup properly, and that you have networking, as you can use other services, I am baffled.

Joe_Zhu 12-11-2009 10:54 AM

Hi What is proxyarp? where i can set it in the ubuntu system?
pls. advice, thanks!!


Joe_Zhu 12-13-2009 09:21 PM


I am studying the proxy arp issue, it seems that it should be in the router (DD WRT).

the router seems somehow not passing the traffic. i found my ssh session freeze after the connection established for awhile.

another point is the linux VPN client get the gateway ip address as specified by the router, but for windows machine, it just use the client ip address as the gateway and seem it make a different. so i guess it could be a work around that let my linux vpn client to set the gateway same as the it's ip in this ppp connection, but i don't know how to do it.....


Joe_Zhu 12-17-2009 09:20 PM

Hi All,

the pptp in my ubuntu still not work, however, i have a ip route add in the ip-up.d

which is
if [ "${PPP_IPPARAM}" = "HOME_VPN" ]; then
/sbin/route add -net dev ${IFNAME}

after the ppp connection up,
in the route table, there are 2 entries regarding to the remote network ''

Destination Gateway Genmask Flags Metric Ref Use Iface * UH 0 0 0 ppp0
xxxxxxxxxxxx.xx UGH 0 0 0 eth0 * U 0 0 0 ppp0 * U 0 0 0 eth0
link-local * U 1000 0 0 eth0
default UG 100 0 0 eth0

i would like to add the gateway in and hope it will be help.
but i tried to add gw option in the above route add statement but seems didn't work ....

any suggestion?


All times are GMT -5. The time now is 04:35 PM.