-   Linux - Networking (
-   -   Voyager 105 USB modem not found (

fannymites 06-15-2005 09:21 PM

Voyager 105 USB modem not found
I have just switched over to broadband from dial-up and am having problems getting the BT Voyager 105 USB modem to work.
I installed the driver from here

And followed various instructions I've found after searching the net but when I try to start the connection I just get modem not found.
Can anyone point me to a definitive tutorial for getting broadband and my modem to work in Linux (Debian).

zidane_tribal 06-16-2005 09:41 AM

im unsure if anyone actually has ever got this modem working. i have one of these (and the voyager 205 router), and neither would work on linux using the usb. i tried the caretakers drivers, but just couldnt make it go. BT have three or four usb modems badged as the voyager 1XX series and you need to know *exactly* which one you have.

if you want to keep trying with the eciadsl drivers, the best advice i can give is make sure your using the right synch files, and if in doubt, dont be afraid to experiment with the drivers, the voyagers are very resilient.

personally, i gave up after banging my head against the wall repeatedly. BT ship these modems for free and they are really not very good at all. if you look around, you can find a PCI dsl modem. i got a "dynamode pci dsl modem" thats a connextant accessrunner in a dynamode box, i got mine for £15, so they are really very good value. in my ipcop box the modem was picked up, drivers set up automagically, and has worked flawlessly, the only thing i had to set was the VPI/VCI (0,38 iirc) and my username and password, but if you only have a single machine i guess you would have to set up a connection, which im sure someone can help you with. if you see a cheap pci dsl modem in a store, ask to see the actual card, if its two largest chips are both "connexant" chips, odds are its a connexant accessrunner in a cheap box. (in my local pc store, he had 7 or 8 different boxed cards, all of which were the same connexant accessrunner cards in different companys boxes, i think they must just buy connexant cards, rebadge them and resell them)

this is probably not the answer you are looking for, but to be honest, it seems like i see this question at least twice a week on various forums, and ive never seen anyone give a working answer for the 105. apparently people are working on drivers, but its taking time.

fannymites 06-16-2005 10:20 AM

Well I tried the driver site again and downloaded the alpha driver and the modem is now working and I'm connecting to the internet at full speed.
One major problem is that the modem works fine in KDE but won't start in xfce4.2 or Gnome, it starts synching but just carries on like that without going any further. I don't really see why it shouldn't work with them though but I'll look into it.
At least I have broadband running on Linux and all I can say is WOW!

zidane_tribal 06-16-2005 03:12 PM

wow, im amzed, it works with the alpha's? i havent used the 105 in maybe 3 months so i didnt know there was an alpha for it.

as for it not starting in gnome (i use kde personally), i assume your trying to start the modem once gnome has loaded? just a thought, but why not write a lil shell script for it, and start the connection at boot-time or similar (i.e. before any gui is loaded), then have it running prior to gnome starting. iirc the eciadsl drivers and the ppp connection can be started that way. as you say, it seems odd that it doesnt run in gnome.

as this question comes up quite a lot (seriously, google for "105 usb not working linux" and you get a bazillion hits), would you mind posting your setup, and if you had to do anything funky to get it running? im sure there are lots of people who would appreciate it, including me, i never got it to work!

great news its working, this has been a bone of contention for many people for an awfull long time.

fannymites 06-16-2005 04:43 PM

Unfortunately I still have a bit of trouble with Linux and I'm certainly not up on technical stuff, I tend to use Linux in fits and starts.

After searching I found instructions on this site -
And this is the actual driver I downloaded -
This includes the synch file needed also.

Basically, I just followed the instructions in the first link to the letter and everything just worked.
I can't really say much about my setup other than I'm on Debian Unstable and I have from Ubuntu repositories and I'm using KDE 3.4, xfce 4.2 and Gnome 2.10 - not sure if any of those make a difference or not but I have noticed that a lot of people having voyager problems are on SUSE.

Incidentally, after my last post, I rebooted and the modem was working fine in all 3, KDE, xfce4.2 and Gnome

There are still some issues - I can only run "eciadsl-start" as root to start the connection and despite editing sudoers
I can't seem to get it to run as regular user. I've also been trying to create a startup script but I'm not having much luck getting anything to work so if anyone can help with that it would be much appreciated.

I would be interested to hear if anyone else having problems with this modem manages to get it working after following the instructions on the first site.

sammykrupa 06-16-2005 05:55 PM

Never had a high-speed modem that needed drivers!

zidane_tribal 06-17-2005 05:03 AM

apologies for the late reply, i think i broke something last night. my mouse died and my ps2 mouse port is no longer working! :(

fannymites, i think we are in the same boat, i tend to use linux when i need it (or when i simply get too frustrated with windows)

about the sudo'ing the eciadsl to run as root. i know its a silly question, but ive done this myself in the past, are you using the sudo command to run the eciadsl, many many times before today ive caught myself editing the sudoers file then just trying to run the command, and forgetting to use sudo! although, i suspect this is an indication i need more fresh air, rather than sitting here beating away on this devil-machine all day ;)

as for the startup script, if you need a hand with it i'll be happy to give it.

i dont recall whether debian sets up an rc.local for you by default or not, if it does, then getting something to start up at system start is *easy*. just look for this file: /etc/rc.d/rc.local
if the file is there, usually it is the last thing to run on startup before the login prompt is run. the file is just a simple script file, and you can edit it using your favourite editor. just put the "eciadsl-start" command on the last line of the file. if you want to get fancy, you could try something like


eciadsl-start >/dev/null 2>&1 &
which will start the eciadsl start command, >/dev/null 2>&1 throw all the output of the program into /dev/null (so it executes silently), and & on the end backgrounds the program, so it gets busy logging onto the internet, whilst you are logging into your machine. (tell me if you know all this stuff, im explaining everything i do cause i dont know your level of knowledge. if this is old hat to you, say so and i'll stop ;) )

however, the first few times you do it i'd reccomend just putting in the eciadsl start command, so you can watch it doing its thing and make sure its connecting properly.

if you dont have an rc.local, well, no matter no mind, it is pretty easy to make one, but always easier if your distro has made one for you, lol.

fannymites 06-17-2005 08:12 PM

The problem with sudoers turned out to be that I had added /usr/bin/eciadsl-start, when it should have been /usr/local/bin/eciadsl-start. So I can run the command from a shortcut now but I'm not getting anywhere trying to run it at startup. I can add the shortcut to the autostart folder but since synching takes a while I would rather get it to run as the computer as it's booting so that it is already connected by the time the desktop is loaded.
I have no rc.local file and I tried creating one but nothing happened. Any other ideas?

zidane_tribal 06-17-2005 09:25 PM

excuse me if im rambling and confsuing, its 3am and ive just got back in :D

if you have allready made your rc.local file, then it should be pretty easy to set it to start up on system start.

the rc.local is not a special file in itself, its just a handy file to put stuff in without digging around in your bootscripts, the magic comes from adding symlinks to it from your bootscripts. you have a series of bootscripts that are executed when your system switches runlevel (i.e. when the system undergoes a major change in state, starting up, shutting down, switching from GUI to text-console mode, those sorts of things.) in all, there are 7 run levels, but some of them are reserved for the system (namely, halt and reboot). theres a good breif description of what runlevels are here

what we need to do is make your rc.local script the last thing to run when your system is booting into runlevels 3 and 5 (this sounds a lot more complex than it actually is)

you should find you have the following directorys


what we need to do is make a symlink in those directorys pointing to your rc.local file.

you should be able to do this with these two commands (run as root, and change any paths you need to [im assuming you put the rc.local in /etc/rc.d, if you put it somewhere else, change the target path])


ln -s /etc/rc.d/rc.local /etc/rc3.d/S99startmyadsl
ln -s /etc/rc.d/rc.local /etc/rc5.d/S99startmyadsl

you can call the links anything you want, as long as they start with the S99 (the S means Start, and the 99 is the order in which to start, numbered 0 to 99, so the adsl start script will start after everything else). its important to add things like this as late as you can in the bootscript order because you depend on other things being active first (i.e. you need the usb gubbins loaded before you try to use a usb modem).

once those two symlinks are present, then init will automagically run the rc.local script when it is loading runlevel 3 (text only multiuser mode) and runlevel 5 (the fancy gui login, the one you want ;) )

as an afterthought..... its very tempting to bung all sorts of funky stuff into your rc.local script. when i made my first one the thing was like three pages long, lol. the commands run in there are usually run as a root priviledged user, so be cautious about what you have running in there. the adsl start commands should be fine

if your not sure if your rc.local is a shell script, it should look like....




have fun, with a little luck once oyu make the symlinks everything should suddenly work automagically. good to know the voyager is finally running under linux, even if it is a bit of a pain to start it all up.

fannymites 06-18-2005 11:09 AM

I just got round to trying it out and it works fine now. I have to wait for a while til I can login to KDM but I usually go to make a cuppa tea or something while it's booting so that's not really a problem. Thanks a lot.
Now if I can just get it to auto-connect on windows startup...

ps Just out of interest, is there any way to speed up the synching process?

zidane_tribal 06-18-2005 07:40 PM

awesome, now your all set for the internet under linux.... as for getting it to autostart under windows, not a clue (unless you want to put a shortcut to a url in your startup items folder and set the connection to dial-on-damand, but that wull open a url every startup :( )

just a thought, but you can background the eciadsl-start command, so it dissapears into the background and gets busy with the synching, whilst letting the system carry on booting.

you probably want something like

eciadsl-start >/dev/null 2>&1 &
that should background it and pipe all the output to /dev/null (including errors!).

as far as im aware, there isnt any user-level things you can do to speed up the synch. the pc has to wake up and boot the modem, then start talking, then the modem has to listen to the line for a while to synchronise with the network. when my ipcop box starts, the biggest delay is waiting for the modem to synch properly with bt's dsl. i dont know of any way to speed it up im afraid :(

still, if you background it, it will work happily away whilst your busy logging in and drinking your tea ;)

great to hear someones finally got one of these things to run, they seem to have been a black-hole of linux compatibility for so long :)

fannymites 06-18-2005 08:01 PM

Oh yes, you had already mentioned that command in the earlier post but I somehow missed it. All is well now.
I'm actually suprised I got this working the same day as my broadband was activated. With my old dial-up winmodem it took me a month to get online with Linux and that's only after I manually edited the driver install file (I didn't really know what I was doing, it was just trial and error).
I have generally had a nightmare time with all my harware. But I'm happy now.
A big thankyou again for all the help with this.

zidane_tribal 06-18-2005 08:08 PM

good to see another happy linux user :D

Damnation 07-08-2005 06:28 AM

i just got this modem, i downloaded those drivers installed etc. it all works sync files work, but my dsl light doesn't come on, now when that happened it was when there was no drivers installed on windows, so i am confused. any ideas?
it also doesn't connect to the internet heres the output.


[EciAdsl 2/5] Uploading firmware...

config: unrecognized entry 'MODEM_CHIPSET' at line 20
config: unrecognized entry 'SYNCH_ALTIFACE' at line 21
config: unrecognized entry 'PPPOECI_ALTIFACE' at line 22
ERROR eciadsl-firmware: failed
eciadsl-firmware: success
firmware loaded successfully

[EciAdsl 3/5] Synchronization...

config: unrecognized entry 'MODEM_CHIPSET' at line 20
config: unrecognized entry 'SYNCH_ALTIFACE' at line 21
config: unrecognized entry 'PPPOECI_ALTIFACE' at line 22
Progress indicator is 00 Training...
eciadsl-synch: success
Synchronization successful
Mounting devpts filsystem...
mount: devpts already mounted or /dev/pts busy
failed to mount

Script /usr/local/bin/eciadsl-pppoeci -vpi 8 -vci 35 -vendor 0x1690 -product 0x0215 finished (pid 14977), status = 0x0
Modem hangup
Connection terminated.
using channel 20
Using interface ppp0
Connect: ppp0 <--> /dev/pts/2
sent [LCP ConfReq id=0xa <magic 0xc66da78>]
sent [LCP ConfReq id=0xa <magic 0xc66da78>]
sent [LCP ConfReq id=0xa <magic 0xc66da78>]
sent [LCP ConfReq id=0xa <magic 0xc66da78>]
Script /usr/local/bin/eciadsl-pppoeci -vpi 8 -vci 35 -vendor 0x1690 -product 0x0215 finished (pid 15029), status = 0x0
Modem hangup
Connection terminated.
ERROR: failed to connect
[root@localhost damnation]#

fannymites 07-08-2005 06:05 PM

@ Damnation:
After having 2 hard drives die in a week I lost all trace of my Linux installation and since I had to start from scratch, I decided to give Ubuntu a try.
After installing the modem driver as I had for Debian I got the same errors as you.
I tried running the configuration (eciadsl-config-text) and went through everything again and it worked fine. You could try that.

@ zidane_tribal
Just in case you read this topic again, you were a huge help in getting the modem to run on startup in Debian. Now I'm on Ubuntu, the steps you gave me to get it to run on startup won't work, even though Ubuntu is pretty much the same as Debian. Do you have any ideas?

All times are GMT -5. The time now is 04:56 PM.