-   Linux - Networking (
-   -   vnc into session 0 (

fraz 11-19-2005 04:51 PM

vnc into session 0
Ok here's the deal.
I want to use vnc to share my X desktop. Now I have already achieved vnc into session 1 and 2 no problem.
The problem came when I started trying to get into session 0 meaning I could share the session0 desktop on my remote client.
I have been fiddling around and got to the point where I try to supply my password and the vnc viewer on the remote pc informs me in the kindest possible terms that the vncAuth password is not setand therefore the connection is dropped. Now the password has been setup as confirmed by my successful use of sessions 1 or 2.
I believe that the problem lies in my xorg.conf.
I have added the Load "vnc" line to the modules section but am a little unsure as to where the option lines as described on the realvnc website need to be. It says they go in the Screen section, but I have read elsewhere that they go in the device section.
Ok so a brief summary:
1. vnc installed and working
2. load vnc has succeeded (session 1 or 2 no longer available, is this supposed to happen?)
3. Have put option lines:
Section "Screen"
Option "SecurityTypes" "VncAuth"
Option "UserPasswdVerifier" "VncAuth"
Option "PasswordFile" "/root/.vnc/passwd"
into the screen section of xorg.conf (which I found a little odd) but it didn't work.
Please help.


P.S. I don't want to use the x0vncserver solution. Ta

poochdog 11-19-2005 07:51 PM

I think that in Fedora there is a setting you can enable which will allow you to connect to the linux console. This is normall found under the system menu, preferences and then remote desktop. You can enable display 0 from here and set a password.

fraz 11-20-2005 06:27 PM

This doesn't seem to be the case on my system. Do you know where I can get this from and/or how to start it from the command line?

fraz 11-20-2005 06:31 PM

strike that. just found it. now all i need is to bring my winxp box back from the dead

poochdog 11-21-2005 02:43 AM

Excellent :)

fraz 11-21-2005 08:36 AM

Oh I should say thanks, so Thanks.

All times are GMT -5. The time now is 11:58 PM.