-   Linux - Networking (
-   -   vnc doesn't work over the internet. (

justanto 01-20-2007 01:55 AM

vnc doesn't work over the internet.
I'm running ubuntu 6.10. I can vnc into my computer from within my own network but when I try to vnc to a computer out side of my network it doesn't work. I have tried everything I can think of. I have tried to vnc to a computer outside of my network with my mac and it just times out. I have set up a vpn between these computers and this still doesn't solve the problem. I have had equally little success trying to do the same processes from my ubuntu pc to the other ubuntu pc outside of my network. several times when I tried I was given the error "no route to host" this confuses me because I had a vpn set up between them. I have vnced over a vpn within my network with no problem but as soon as an external machine gets involved everything seems to fall apart.

all help is very appreciated.

chort 01-20-2007 02:49 AM

I cannot imagine what your problem might be. I've used VNC over SSH tunnels and over Cisco VPNs without any issues. It seems like it's probably an underlying network problem, not a VNC problem. It just uses TCP ports after all...

xjlittle 01-20-2007 11:27 AM

That sounds like your vnc client is trying to use your normal default gateway rather than the vpn gateway. See the following:

[root@john-fc6 jslittl]# /sbin/route
Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface        *     UH    0      0        0 tun0 UGH  0      0        0 tun0    UG    0      0        0 tun0    UG    0      0        0 tun0    UG    0      0        0 tun0    UG    0      0        0 tun0      *        U    0      0        0 eth1
default        UG    0      0        0 eth1
[root@john-fc6 jslittl]#

Here my normal defaut gw is eth1 (see the last column Use Iface) because that is my internal network and routes all calls to the internet except for the IP's in the 10.x.x.x and 128.x.x.x range. However all calls to the Ip's in the 10.x.x.x and 128.x.x.x go through the tun0 interface. That is where yours should be going to connect to the vnc machine on the other end of your vpn.

All times are GMT -5. The time now is 05:29 PM.