-   Linux - Networking (
-   -   vcnviewer not connecting (

Johng 12-12-2012 02:05 PM

vcnviewer not connecting
I am using Hamachi to link my desktop top a remote laptop. If I use the command: 'vncviewer' on a Mandriva 2007 desktop I am asked for a password, and then greeted with the remote desktop. Attempting the same with Mageia 2 on the same computer as root with firewall off, I get "server not found". Using 'vncviewer port 5900' has the same response.

'' is the reote address obtained with the command 'hamachi list', and as displayed on the remote desktop.

How do I make the required connection?

kenneth_phough 12-12-2012 03:10 PM

Does the Mageia 2 "know" where your remote device is? i.e. are they on the same network?

EDIT: looking at the way you censored your IP it seems like a class A address, i.e. an IP assigned to you from your ISP. Could you describe your set up a bit more?

Johng 12-12-2012 03:54 PM

Thanks for the reply. The remote laptop has Windows XP with Logmein-Hamachi and Tightvnc running. Hamachi is logged into a network with a name aaaaaa and an address

The Desktop is logged into the same network aaaaaa, address 25.yyy.yyy.yyy. If I command 'hamachi list' it identifies the remote laptop confirming the connection. Up to this point, I can do the same using Windows XP, Mandriva 2007, and Mageia 2 (same computer - multi boot).

On the Desktop, using Tightvnc on XP or vncviewer on Mandriva 2007, I can see the desktop on the remote laptop. On Mandriva, I enter vncviewer, password when asked, and the remote desktop appears.

Using Mageia on the Desktop, if I enter vncviewer, after a delay I get the response "Server not found". I have tried krdc with similar results. I'm doing this a root, with the firewall disabled.

kenneth_phough 12-12-2012 05:07 PM

I wish I could pin point the problem but I'll have to keep asking questions - sorry!

1) What is your IP address on the Mageia system? Is it 25.yyy.yyy.yyy? (It sounds like you have to "login" to the virtual network and maybe the Mageia isn't???)

2) If the IP address is correct, then is your destination (laptop pingable from your Mageia system?


Johng 12-12-2012 06:09 PM

Logmein-Hamachi is a free VPN; when you connect, it assigns an unique address to each system eg: 25.yyy.yyy.yyy. Once logged in, you can create a new network or join a previously created named network, eg aaaaaa. After joining a network, on Mandriva 2007, the command vncviewer connects to the remote device (the laptop) through the hamachi VPN network. This is not happening on Mageia. It would not on Mandriva 2010 also. It would seem something changed between Mandriva 2007 and 2010(?).

The Mageia Dsktop IP is I cannot ping the on any system, even those that work as desired.

kenneth_phough 12-12-2012 07:32 PM

As you may have guessed I'm not familiar with hamachi but can you access it like any other VPN? Do you use a hamachi service to access it? If so is that service running on your linux box? I'm a centos user but can you do something like

service hamachi status
If a VPN is established is there a proper interface with that IP when you do ifconfig?

For example when I VPN from my box I get an interface

jnc0: flags=841<UP,RUNNING,SIMPLEX> mtu 1400
        inet SOMEVPNIP netmask 0xffffffff

sorry for not being too much help... :(

Johng 12-12-2012 08:05 PM

Re: "sorry for not being too much help..." I appreciate your help. I realise I'm not helping cos I'm flying blind.

'service hamachi status' produced no results. However the hamachi status is:
# hamachi
version :
pid : 18870
status : logged in
client id : 119-422-405
address : 2620:9b::19c7:d303
nickname : localhost.localdomain
lmi account: -

ifconfig lists eth0, ham0 and lo which don't appear relevant.

Re: "can you access it like any other VPN?" - I don't know, I've not had any other experience.

kenneth_phough 12-12-2012 11:34 PM

ham0 sounds relevant but is that not a virtual interface? Idk what your device setup is like but if its a hamachi interface ifconfig ham0 may give us a clue...?

Will keep thinking and get back to you if I find/think of anything.

Johng 12-12-2012 11:57 PM

The ham0 portion of ifconfig looks like this:

ham0 Link encap:Ethernet HWaddr 7A:79:19:C7:D3:03
inet6 addr: fe80::7879:19ff:fec7:d303/64 Scope:Link
inet6 addr: 2620:9b::19c7:d303/96 Scope:Global
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:500
RX bytes:0 (0.0 b) TX bytes:2004 (1.9 KiB)

kenneth_phough 12-13-2012 11:30 AM

normally in VPN when you are logged in to another network you cannot access (i.e. ping) machines on your local network.

Once you've booted Mageia or Mandriva 2010, started hamachi, and logged into your VPN try pinging something that is on your lan (, i.e. your printer or router. If this works it seems like you're not on the VPN at all.

Is there a log for hamachi? I couldn't find anything useful on google becuase "Log" file and "Log" me in coincided.
My guess would be that the file is in /var/log/

I did also find this (not sure if it's helpful and maybe you've already seen it):

Johng 12-13-2012 07:57 PM


With Mdk 2007, when logged into hamachi and with vncviewer connected, I cannot ping, as you suggest.

I've done some more comparisons between Mdk 2007 and Mageia which suggest it may be an ipv4/ipv6 problem(?).

On Mdk 2007, ifconfig lists inet addr: (which is the address of the local hamachi).

On Mageia, ifconfig does not have "inet addr:" - instead it lists inet6 addr:xxxx:xx::xxxx:xxxx (which appears to be the local hamachi ipv6 address).

The remote laptop shows hamachi ipv4 and ipv6 addresses. vncviewer on Mdk 2007 and the XP on the laptop connect (using the ipv4 addresses), Mageia does not.

The Xp has Microsoft TCP/IP version 6 ticked. So on Mageia I tried vncviewer zzzz:zz::zzzz:zzzz (the remote hamachi address), I get:
main: unable connect to socket: Invalid argument (22)

kenneth_phough 12-13-2012 08:08 PM

Good catch! It seems like vncviewer doesn't support ipv6 and Mageia is on ipv6. From my understanding you have to tunnel to be able to cross from v6 to v4.

let's make sure that's the case...can you see what's in /etc/sysconfig/network-scripts/ifcfg-ethX

you should see your device definition. Modify it so that





reload the network

/etc/init.d/network restart
and check with ifconfig to see if IPV4 address was given

Johng 12-13-2012 09:45 PM

Thanks again, I checked/modified the /etc/sysconfig/network-scripts/ifcfg-ethX settings. They made no difference to ifconfig output, even rebooted in case.

kenneth_phough 12-14-2012 09:18 AM

Right of course it's a virtual ethX won't help in this case.

I looked around and couldn't find a configuration file with the linux hamachi files. It seems like you can do some kind of configuration online. Is there a way to disable ipv6 from hamachi "control panel"?

Also maybe it's just better to get a vncviewer that supports ipv6???
It seems like they do, what version is yours?

You can check if ipv6 modules have been loaded or not by

lsmod | grep ipv6

Johng 12-14-2012 04:06 PM

# lsmod | grep ipv6
ipv6 331954 22

hamachi can be set = set-ip-mode ipv4 | ipv6 | both

I have set it to ipv4

I also ran: # nmap -Pn

Starting Nmap 5.51 ( ) at 2012-12-15 10:07 NZDT
Nmap scan report for
Host is up (0.000027s latency).
Not shown: 999 closed ports
631/tcp open ipp
Nmap done: 1 IP address (1 host up) scanned in 0.55 seconds

(IP address censored), firewall off.

The remote Win XP indicates when there is/not a hamachi link, therefore I'm sure the two computers are linked via the hamachi VPN. vcnviewer is Tigervnc; I have also tried gtkviewer (gvncviewer) with same result. It seems there is a barrier between the hamachi VPN and vcnviewer on Mageia and Mdk2010 thats not present on Mdk 2007.

All times are GMT -5. The time now is 07:49 PM.