LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-31-2012, 02:31 PM   #1
RootMason
Member
 
Registered: Oct 2012
Location: Tucson, AZ
Distribution: Debian/CentOS
Posts: 124

Rep: Reputation: 5
Using Squid on Debian Wheezy as a Proxy to a Client in VMWare Workstation


Hello all!

I am setting up a Server/Client test environment for class using VMware Workstation. I am using Debian Wheezy as my Server and DSLinux as my Client. What I am hoping to do is to use the Server to serve DHCP/DNS requests from the Client, and then to use the Server as a Proxy to "funnel" internet traffic from the Client to the Internet.

In VMware (v9), on the Server, I am using VMNet8 (NAT; 192.168.133.0/24) to connect to the Internet and VMNet1 (Host-Only; 192.168.33.0/24) to connect to the Client. On the Client side I am using VMNet1 to connect to the Server.

I have set up DHCP (isc-dhcp-server) on the Server side and the Client is picking up IP addresses, so DHCP is working. I have not set up DNS yet, though I have added my ISP Nameservers to the dhcpd.conf list. I set up Squid today, but I am not getting any network connectivity from the Client.

So my question is this: is my problem the fact that I have not set up a DNS Server(bind9) yet? Or is it that I am using NAT (in VMWare) to connect to my PC's Internet connection? Or is it perhaps a configuration problem? I felt that adding the changes I made to squid.conf would make this post so long noone would read it, but if you are interested in helping, I would be more than happy to provide it.

Thanks to anyone who makes it this far in my thread... your help will be much appreciated and thanks for taking the time to help.

Steve
__________________________

#!/bin/bash
horse=1
dead=1
while [ $horse -eq $dead]
do
echo "beat"
done

Last edited by RootMason; 10-31-2012 at 02:42 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up a Test Lab between DSL Client & Debian Server in VMWare Workstation RootMason Linux - Virtualization and Cloud 5 11-01-2012 04:27 PM
VMware workstation not working in debian baronobeefdip Linux - Software 9 09-26-2011 01:07 AM
using debian as a client workstation in a company cccc Debian 9 07-15-2011 01:18 AM
Can I convert my VMware Workstation into a server client mode coolsreejith Linux - Virtualization and Cloud 4 03-22-2011 03:46 AM
win2000 server with VMware workstation and Debian woody as guest OS xstation Debian 1 07-14-2005 06:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration