-   Linux - Networking (
-   -   Unable to print to a Windows SMB printer from Linux (

jomy 02-22-2005 01:45 AM

Unable to print to a Windows SMB printer from Linux

I was trying to add a Networked Windows SMB printer in my RHEL AS 3 server.I’ll explain what I did.

The printer HP officejet 4110 is installed on Win 2000 professional.It is shared and the share name is “hpoffice”.A user is added on the win machine named “printuser”.He is given permission to manage the printer and print documents.Printing is fine locally from Windows.

Now at the Linux box,

I'm using CUPS as the printing system which is the default.

I used redhat-config-printer to add the printer.I gave the queue name as “ hp” and I selected Windows Print Queue.In the next page I gave the following details.

Share : hpoffice

Host IP :

Workgroup : mygroup

User : printuser

Passwd : <password>

In the next screen, since the driver for my printer was not listed , I selected raw “Print Queue”.I finished the setup and made it the default printer. I tried to print a test page and selected ASCII Text Testpage. It showed the print is sent to the printer, but nothing printed out.I’ll list the contents of /var/log/cups/error_log

Job 1 queued on ‘hp’ by ‘root’

Started backend /usr/lib/cups/backend/smb (PID 4703 ) for job 1

Anyway I couldn’t see any printout coming out of the printer.Please help me to find out where I’ve gone wrong.



broch 02-22-2005 06:00 AM

this is the problem with password handling incompatibility between CUPS and samba. It can be resolved, however for me worked by using lpd (tcp515)
install on the windows machine TCP printing services (Rdd/Remove windows components UNIX services). Once this is running
Open CUPS and configure URI device as
or (in case yuo have problems with name resolution)

jomy 02-22-2005 06:25 AM

Hi Mr. Broch,

Let me hope it to be added in /etc/cups/cupsd.conf and under the queue that is added onto the machine.And let me hope it is URL and not URI.

Thanks. Please Reply

broch 02-22-2005 07:47 AM

no, that is URI. The abbreviation stands for "Uniform Resource Identifiers"

You can use your browser too (http://localhost:631)

All times are GMT -5. The time now is 01:24 PM.