LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 10-29-2005, 03:02 PM   #1
ivor.miller
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Rep: Reputation: 0
unable to logon to SAMBA from Windows


I am very new to Linux.
I installed Linux after I had a hard disk crash on my windows machine which resulted in significant changes to the machine and I decided to try SUSE 9.3 Linux.

The major justification for the machine is to serve as a backup disk for all of the Windows machines and I have put a 250 Gig drive into it.

I have installed SAMBA on my Linux machine and that seems to have gone in well.

Unfortunately I have not been able to access any of the shares I have set up from windows. When I try to access a share I see the machine and I see the shares. When I actually try to set one up as a drive on windows I am asked to sign on and no matter what username and password I enter it simply comes back and asks again for a sign on. I have been round and round the barn on this one and have tried multiple setups including setting up the shares as user and not as user I have tried encrypted passwords of DES and other options. I have even re-installed Linux multiple times and have tried Red hat and SUSE both - All to no avail! I currently have SUSE 9.3 installed.

When I try to access it I get the following in the Linux system log.

linux smbd[7994]: [2005/10/29 09:21:35, 0] passdb/pdb_smbpasswd.c:getsmbfilepwent(389)
linux smbd[7994]: getsmbfilepwent: malformed password entry (no
linux syslog-ng[3470]: STATS: dropped 0
linux smbd[7995]: [2005/10/29 09:21:48, 0] lib/util_sock.c:get_peer_addr(1150)
linux smbd[7995]: getpeername failed. Error was Transport endpoint is not connected
linux smbd[7995]: [2005/10/29 09:21:48, 0] lib/util_sock.c:write_socket_data(430)
linux smbd[7995]: write_socket_data: write failure. Error = Connection reset by peer
linux smbd[7995]: [2005/10/29 09:21:48, 0] lib/util_sock.c:write_socket(455)
linux smbd[7995]: write_socket: Error writing 4 bytes to socket 25: ERRNO = Connection reset by peer
linux smbd[7995]: [2005/10/29 09:21:48, 0] lib/util_sock.c:send_smb(647)
linux smbd[7995]: Error writing 4 bytes to client. -1. (Connection reset by peer)
linux smbd[7996]: [2005/10/29 09:21:48, 0] passdb/pdb_smbpasswd.c:getsmbfilepwent(389)
linux smbd[7996]: getsmbfilepwent: malformed password entry (no

Can anyone help me to figure out what I have to do to get access to the machine from Windows?
 
Old 10-29-2005, 03:24 PM   #2
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 739

Rep: Reputation: 31
Your problem may lie in one of these options. Try setting them like this:

security = share
passdb backend = tdbsam guest
obey pam restrictions = no

Good luck
 
Old 10-29-2005, 04:05 PM   #3
ivor.miller
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Tried suggestions and now get further

Thank you - I tried your suggestions and found that I now can get further.

You suggested that I set the following up
-----------------------------------------------
security = share
passdb backend = tdbsam guest
obey pam restrictions = no
-----------------------------------------------

The system refused to allow me to change security from "user" to "share"

but I was able to set the other two suggestions.

I am now able to set up users "ivor" as a drive. It now says that my Windows T: drive is "kdecache-ivor on 'Linux\users'". Unfortunately while it allowed me to set it up it and shows the Gigs on the device and how much is available; it also says "T:\isnot accessible. Access is denied."

Any thoughts on this problem?

Ivor
 
Old 10-29-2005, 04:17 PM   #4
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 739

Rep: Reputation: 31
Quote:
The system refused to allow me to change security from "user" to "share"
I don't quite understand this. Are you using a utility to configure Samba?

Become root.

Edit the file /etc/samba/smb.conf directly

Run testparm to check that all is OK. then restart samba using

smbcontrol smbd reload-config

That should do it.

security = share is essential for what you're trying to do. (Been there, done that.)
 
Old 10-29-2005, 05:38 PM   #5
ivor.miller
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
I was using YAST

I was using YAST and it disabled share.

I have now done it manually and I can now get to a directory which is called "vi.recover on 'Linux\users'"

I can create a file and I think I can play a bit with this.

I still get sign on screen in windows for the other directories I set for shares and am seeing "Linux\guest" showing and again whatever password I type in (including blank) it simply comes back and refuses to go further.

I will set the rest up the same way I have "Linux\users" set.

I will start doing things manually now that I have seen the problems using YAST.


Thanks again.

Ivor
 
Old 10-30-2005, 12:00 AM   #6
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 739

Rep: Reputation: 31
Try checking if the shares have been set up in /etc/samba/smb.conf.

You have to specifically define each share. Look towards the end of the file for this.
 
Old 10-30-2005, 07:13 AM   #7
ivor.miller
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks Dave

I have started looking and playing. I have gotten access to another area and I think I am on my way.

Unfortunately Work cuts into the play time and I have to catch a plane today.

I think the problem is essentially solved and I will play next weekend when I get back.

Thanks again - Ivor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows XP unable to connect to linux with Samba luthree Linux - Networking 13 03-10-2007 06:54 AM
Can't Logon to a samba PDC with Windows XP aussieskier Linux - Networking 5 06-15-2005 04:57 PM
unable to logon to samba(linux) from network places 0984@webmail.co.za Ubuntu 2 06-14-2005 06:51 PM
Unable to logon on as non-root user after update as unable to set executable context pls198 Fedora 2 04-09-2004 11:41 AM
unable to browse samba share from windows 2003 kfloda Linux - Software 1 08-16-2003 07:14 AM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration