-   Linux - Networking (
-   -   unable to load Ubuntu ndiswrapper driver (

talint 10-05-2009 02:54 PM

unable to load Ubuntu ndiswrapper driver
This is on a 64bit dual boot Windows/Ubuntu 8.04 desktop. I was able to successfully install the arusb_lhx ndiswrapper driver. But, "sudo modprobe ndiswrapper" is giving me couldn't load driver message. I searched the web a bit. Typed "lshw -C Network" to see if anything else was taking over; blacklisted the Ethernet interface by modifying /etc/modbroke.d/blacklist and adding "blacklist r8169"; typed

sudo update_initramfs -k all -u
and then rebooted. I respecified

sudo modprobe ndiswrapper
tail /var/log/messages

The messages I'm seeing are:
ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
usb 4-4: reset high speed USB device using ehci_hcd and address 2
loadndisdriver: load_driver(358): couldn't load driver arusb_lhx
usbcore: register new interface driver ndiswrapper

I don't know what I should be doing next. I want to be able to load the driver. This forum was helpful in suggesting Ubuntu for dual boot. So, I thought I should ask. I would appreciate any input.

w_r_cromwell 10-08-2009 09:02 AM

a missed step?

First of all... I don't do anything 64 bit. I looked at your message and I wonder if you need to run the "nidiswrapper -m" command to prepare and link your ndiswrapper for loading as a kernel module. If the "ndiswrapper -l" command shows your driver then give the -m command a try. Your ndiswrapper setup should then be ready to load as a module. Follow that with your modprobe command.

I hope this helps.


talint 10-09-2009 08:04 AM

some progress with ndiswrapper -m
Thanks for the reply. With "sudo ndiswrapper -m", it added an
"alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapped which wasn't there before. However, "sudo modprobe ndiswrapper" still couldn't load the driver. I then typed "locate ndiswrapper", a list comes up. Under arusb_lhx, I see
My NetGear wireless USB is of type wnda.... Probably I should have the inf file for that. Let me give that a try and I'll let you know what happens.
When you search through forums, you see threads about known bugs and they suggest recompiling from source etc. But locating the proper source code for the proper chipset from sourceforge is also not that obvious. Let me try a few things. I'll let you know.
Thanks a lot,

talint 10-20-2009 07:25 PM

Acer-5720-64bit drivers load but still no wlan
I keep coming back at this. I guess I will until it works. To recap, I'm still trying to set up wireless with a USB stick from NetGear (WNDA3100) on a dual boot 64-bit Vista/Ubuntu Hardy 8.04 system. The wireless problem is with Ubuntu only. Finally, I did find 64 bit net5211drivers that do load from
but, the network is still not detected; no wireless from iwconfig; unknown command 'wlan0' from iwlist scan wlan0. I see several possibilities. Any input from you will be appreciated.

(i) When installing this driver, multiple .conf files are being generated in /etc/ndiswrapper/net5122. I then specify
sudo ndiswrapper -a 0846:9010 net5122
This links 0846:9010.5.conf to the first .conf file it finds. Without that link the USB is not detected. But, regardless of which .conf file you link it to, the USB stick is always detected. The conf file you link it to may be crucial in setting up the network? I didn't try out all of them and I don't know how to determine which one is appropriate??

(ii) The other one is related to the ndiswrapper -m option. When installing this particular driver, you get multiple aliases in /etc/modprobe.d/ndiswrapper that look like
alias pci:v0000168Cd0000001Csv00007096sd0000144Fbc*s*c*i ndiswrapper
and then ndiswrapper -m tells you that module configuration already contains alias directive. I added another line "alias wlan0 one_of_the_pci_files" to indirectly link it to ndiswrapper which didn't help much. I then found a post saying that the crucial step is to specify
sudo ndiswrapper -ma && sudo ndiswrapper -mi
That also didn't help much, but what that does is change the contents of /etc/modprobe.d/ndiswrapper such that the above line becomes
install pci:v0000168Cd0000001Csv00007096sd00001Fbc*s*c*i /sudo/modprobe ndiswrapper
I then added another line "alias wlan0 ndiswrapper" to no avail.
Any input at this point is welcome. I may be very close to getting it to work. Tried out other things like madwifi, but I don't think madwifi was meant for USB's. In any case, this is my experience.
Thanks to all - Talin

All times are GMT -5. The time now is 11:37 PM.