LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-02-2007, 12:31 PM   #1
Funky D
LQ Newbie
 
Registered: Oct 2004
Posts: 7

Rep: Reputation: 0
Unable to join samba to W2K3 domain controller


Hi all,

After google searching for hours, I'm begining to think I'm the only one who's ever encountered this problem!

I've set up a Fedora 7 file server, updated, and configured Samba according to this handy blog (http://www.planetmy.com/blog/?p=248), which seems to echo other configurations I've found on the net since. I kinit adminstrator@TEST.LOCAL and successfully receive a Kerberos ticket. Unfortunately, when I try to join the domain, I get the following:

Code:
[root@localhost "]# net ads join -U administrator
administrator's password:
[2007/08/02 12:17:42, 0]  libsmb/smb_signing.c:signing_good(253)
  signing_good: BAD SIG: seq 1
Failed to join domain: Logon failure
The W2K3 domain controller shows Event ID 529 (Unknown user name or bad password), although before this error I get several events reporting successfull logons and logoffs.

I'm stumped! I'm not sure if this is a problem on the linux box or the W2K3 box, or how to tell where the problem lies. Any help would be greatly appreciated.

Thanks!

Paul
 
Old 08-03-2007, 03:04 AM   #2
vjn
LQ Newbie
 
Registered: Jul 2007
Posts: 12

Rep: Reputation: 0
Hi,

You have given command kinit administrator@DOMAIN.COM you have recive ticket from ADS server for list that ticket command -

klist

output will be

Code:
Default principal: administrator@DOMAIN.COM

Valid starting     Expires            Service principal
07/26/07 19:50:02  07/27/07 05:50:04  krbtgt/DOMAIAN.COM@DOMAIAN.COM
        renew until 07/27/07 19:50:02
 
Old 08-03-2007, 10:12 PM   #3
Funky D
LQ Newbie
 
Registered: Oct 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Solved!

Well, I found the problem and got everything pretty much working. It turned out to be the line "client use spnego = no" in the smb.conf file... the howto I was following said this line was necessary for Windows 2003 AD's, but it actually broke things instead!

Paul
 
Old 08-04-2007, 01:44 AM   #4
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Can you try seeing if your samba shares work the next day? I was able to set up something similar on my CentOS5, however, I noticed that the next day, my Kerberos ticket would expire and I would have to request a new ticket every time I wanted to access something on the Linux box. This made it impractical, but maybe I did something wrong. Can you verify?
 
Old 08-06-2007, 10:50 PM   #5
Funky D
LQ Newbie
 
Registered: Oct 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Micro420
Can you try seeing if your samba shares work the next day?
The samba share was still working fine this morning... the timeout in my krb5.conf is set to 24000. Although I'm confused as to the purpose of getting a ticket through kinit... I only ran net ads join and was able to connect to the shares via 2003 machine no problem.

The howto I ended up following was located on these boards, (http://www.linuxquestions.org/questi....php?t=569620), however I didn't edit any of the PAM files.

Paul
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to join domain using Net Join command in FC3 client jeb083079 Linux - Networking 9 07-30-2007 02:41 AM
How to join Linux Exterprise 3 WS to Windows 2003 Domain Controller babu550 Linux - Server 0 07-30-2007 12:56 AM
only 1 W2K SP4 workstation unable to join samba domain Winanjaya Linux - Server 1 06-19-2007 04:26 AM
WinXP/Win2K unable to join Samba Domain jgnasser Linux - Networking 6 09-01-2006 10:10 AM
Using Linux as a domain controller for a W2K3 domain. Passive Linux - Networking 3 01-28-2005 06:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration