-   Linux - Networking (
-   -   unable to connect to network printer can't even telnet it (

fahadmanzoor 07-08-2011 02:50 AM

unable to connect to network printer can't even telnet it
I have a network printer which is on a windows domain/workgroup. Earlier I use to connect to the printer with URI socket://10.x.x.x:9100 and it worked fine. Then I after some time the going got tough and at the moment I am not able to print.

Initially I thought that I need to upgrade CUPS and even downloaded its latest version (did not installed it though).

My trouble shooting started with the ping then telnet followed it. Following is the output of telnet


****@linux-rafr:~> telnet 10.x.x.x 9100
Trying 10.x.x.x...
Connected to 10.x.x.x.
Escape character is '^]'.
Connection closed by foreign host.

I tried to telnet by turning off the firewall but no good. Hope someone has a solution to this issue.

BTW when test page print job is viewed in CUPS the following is the message.

Unable to write print data: Broken pipe

markush 07-08-2011 03:13 PM

Hello fahadmanzoor,

could you please provide more information?

Did ping work?

Does cups "see" the printer? what I mean is, if you open the cups-interfache in a browser (adress http://localhost:631), can you add the printer with it's IP-adress?

Did you try to connect to the webinterface of the printer (http://???.???.???.??? where the questionmarks are the IP-adress of the printer).

Have you once been able to connect to the printer via telnet? as you know, many computers/devices block telnet by default.


jefro 07-08-2011 09:53 PM

Try browser set to the ip address.

Ping and telnet may be blocked or not enabled.

fahadmanzoor 07-11-2011 12:19 AM

Dear All

Thank you for your response and do overlook the weekend delay from my end.

I can access the webpage of the printer on port 80, 280 and 631 using the Firefox.

Ping works perfectly fine.

I added the printer from http://localhost:631 page via socket uri socket://10.x.x.x:9100

I can telnet to port 80, 280 and 631 of the printer perfectly.

I can print the .ps files from the webpage of the printer easily as well.

The thing which pinches me is that the error message of "broken pipe unable to write print data". The same setup used to work quite fine earlier and smoothly.

I hope that I succeeded in satisfying you with my answers/feedback.

Edit => Is it possible that permission of some file hinders CUPS from using them? Maybe this only reason of broken pipe and data could be written because some socket libraries are not being shared properly perhaps.

All times are GMT -5. The time now is 08:09 AM.