LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Unable to connect (https://www.linuxquestions.org/questions/linux-networking-3/unable-to-connect-257779/)

eggoz 11-21-2004 09:34 PM

Unable to connect
 
I have a linux Fedora box with a printer setup on it. I can print if I am on this computer. I also am sharing a hard drive with my other windows computer using samba. But I can not print from the windows computer to the linux box. It gives me this error....
Printer on Samba Access denied, unable to connect.
I tried going back into the printconf-gui and telling it to share the printer with all hosts. I also tried a single IP and nothing works. Where could I be going wrong? Thanks.

maxut 11-22-2004 11:18 AM

there is an option in smb.conf to allow users to use own printer drivers. try it.
here is an example:
Code:

[lp0]
        path = /var/spool/samba
        read only = No
        printable = Yes
        printer name = lp0
        use client driver = Yes
        oplocks = No

good luck

eggoz 11-22-2004 06:32 PM

That didn't really help. I am now able to connect to the printer, but I can still not print. On the linux box, I am using the HP 3650 cups (hpijs driver). From the windows machine, I first tried using the HP 3650 driver from HP. I get this error:

Microsoft Visual C++ Runtime Library
Runtime error!
Program: C:\WINNT\system32\NOTEPAD.EXE
abnormal program termination

I also tried with a standard Deskjet Driver and I get this error:

A StartDocPrinter call was not issued.

I looked up that error and said to try using the command line in windows to use the printer and supply is a password. This also didn't work. Any other ideas?


All times are GMT -5. The time now is 12:40 AM.