LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-18-2008, 07:16 AM   #16
aadilbcas
LQ Newbie
 
Registered: Feb 2008
Posts: 11

Original Poster
Rep: Reputation: 0

yeh ok im done thanks...every thing needs patience..

Quote:
Originally Posted by Brian1 View Post

Also where did you get your current source file you used to build? I would like to give it a try and check the differences.

Brian

this one ftp://ftp.hogchain.net/pub/linux/att....0.40.4.tar.gz
 
Old 02-19-2008, 07:15 PM   #17
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Thanks for the info. Gave it a try and builds fine. They changed the at.main.c file in the place I mentioned in post.

Brian
 
Old 04-09-2008, 03:49 PM   #18
fullgore
Member
 
Registered: Aug 2006
Location: Brasilia, Brazil
Distribution: Slackware / Suse / FreeBSD
Posts: 55

Rep: Reputation: 15
Question

I'm at a OpenSuse 10.3 and I'm an Asus motherboard with the Attansic ethernet chip, I'm having the same problem in order to activate the nic. I downloaded the file l2-linux-v1.0.40.4.tar.gz from a link at one of the replies in this post, I followed the instructions in the readme file; I had to create de version.h file to compile the driver but even had created the file everytime I try to compile I receive the answer "Linux kernel source not configured - missing version.h. Stop.". Any clue?
 
Old 04-09-2008, 10:59 PM   #19
jiucenglou
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
The url is great!!

Quote:
Originally Posted by aadilbcas View Post
yeh ok im done thanks...every thing needs patience..




ftp://ftp.hogchain.net/pub/linux/att....0.40.4.tar.gz
The url is great!!
Thank you for sharing!!
 
Old 09-07-2008, 03:11 AM   #20
carda
LQ Newbie
 
Registered: Nov 2004
Posts: 5

Rep: Reputation: 0
Hello,

I am running a fresh install of Centos 5.2 with kernel 2.6.18-92.el5 and thanks to this thread and another one at Ubuntu forums I got as far as:

./lsmod|grep atl2

returns:

atl2 31512 0

So it seems that the module is loaded correctly. And what should I do next? How can I activate the network card? It is still not recognized by the system at startup. There is just no ethx device.

Thanks in advance!

Benedikt.
 
Old 09-07-2008, 05:18 AM   #21
carda
LQ Newbie
 
Registered: Nov 2004
Posts: 5

Rep: Reputation: 0
O.k. after five hours of work (Argh!!) I got the Attensic L2 network chip on my ASUS board to work on my new out of the box CENTOS 5.2 installation with kernel 2.6.18-92.el5.

Here is a summary of what I found out, perhaps it helps people to save some time:

1) When you search google you get two helping threads about this hardware issue, namely this one at linuxquestions.org and the one at the Ubuntu forums: http://ubuntuforums.org/showthread.php?t=429845
There is also a blog entry at:
http://ihatecubicle.blogspot.com/200...2-network.html

2) There are two driver versions available. As far as I found out, there is one that works for kernels prior to 2.6.23 and one for newer kernels. I used the "old" one which I got at http://ubuntuforums.org/attachment.p...0&d=1179781554

The new one can be downloaded at several sources, e.g.:
http://launchpadlibrarian.net/738241...driver_new.rar
or
ftp://ftp.hogchain.net/pub/linux/att....0.40.4.tar.gz

I never managed to compile the new driver without errors. There was always this "error: redefinition of typedef 'irq_handler_t'" issue mentioned above in this thread.

3) For use with CENTOS 5.2 you can stay with the "old" driver for the moment, which compiles without problems. There is also a compiled version of this driver to download in the above mentioned thread at Ubuntu forums but it does not work for CENTOS 5.2.
When you get the error:
insmod: error inserting 'lib..../atl2.ko': -1 Invalid module format
you likely wanted to use the already compiled version and it fails


3) Compiling itself is easy:
Anyway, for Linux beginners it is sometimes tricky because they do not have the packages installed to do compiling (namely the compiler gcc and of course, in this case kernel-devel as we want to compile a kernel module). Typical errors you get if you do not have the right packages installed are:

Makefile:62: *** Linux kernel source not found. Stop.

(This happens when you are missing kernel-devel)
or

make: command not found
(This happens when you are missing gcc compiler)

So be sure to have all these packages installed:
kernel-headers, kernel-devel, gcc, glibc, glibc-headers, libgomp, glibc-devel, cpp;

These packages you find on your distros CDs or you can download them from a CENTOS mirror (pick the right version!) and transfer them to the box with an usb stick (as you probably have no network access on the machine). Then install them by typing
rpm -ivh filename_of_package.rpm

4) Ok, back to compiling:
Unzip the drivers zip-file and enter the directory. Enter the sub directory src and type

make install

When successfully performed, the compiler should have placed the module in the directory /lib/modules/<KERNEL VERSION>/kernel/drivers/net

The file is named atl2.ko or atl.ko. If it is only named atl.ko rename it to atl2.ko (I did this and it worked - I do not know if it is necessary.) I also did a chmod 744 to give the file the same permissions as the other files in the directory but I am also not sure if it is necessary.

5) Add the module to the loaded kernel

Remap all modules by typing
modprobe -a

If you get a command not found error then type:
/sbin/modprobe -a

To load the module type:
/sbin/modprobe atl2

If you do not get an error message, this was successful.


6) Now you have to make sure that it is loaded each time you boot.

Change directory:
cd /etc/sysconfig/modules

Add a file named atl2.modules with the following content:
/sbin/modprobe atl2

Change Permissions:
chmod 0755 atl2.modules


7) You have to manually configure the network card. Do not expect that kudzu / anaconda will help you.

Change directory:
cd /etc/sysconfig/network-scripts

Add the configuration file of the network interface. Filename: ifcfg-eth0 (if you want it to be eth0, otherwise use eth1, eth2 etc).

The file should look like this:
DEVICE=eth0
BOOTPROTO=static
HWADDR=xx:xx:xx:xx:xx:xx
IPADDR=xx.xx.xx.xx
NETMASK=xxx.xxx.xxx.xxx
GATEWAY=xxx.xxx.xxx.xxx
ONBOOT=YES
TYPE=Ethernet

Change the settings as you want, e.g. DHCP instead of static ip address, etc. Important is the hardware address of the L2 adapter. I found it after reboot of my computer in the GNOME hardware browser.

After saving the file, type:
/etc/rc.d/init.d/network restart

Now the ethx interface should come up.
Finally, if you did not have a network installation until then (because Anaconda skipped it due to non-availability of network interface) you should also enter some nameservers:

Change file:
/etc/resolv.conf

Add entries like:
nameserver xx.xx.xx.xx

Finally your internet connection should work. As you can see, I have only described the compile part in detail. Of course there are many settings you can change with the network preferences but this depends on your network topology (most important DHCP <-> static IP address).

Hope this helps.

Benedikt.
 
Old 11-22-2008, 09:20 AM   #22
skunkcabbage
Member
 
Registered: Aug 2003
Location: Oxfordshire, UK
Distribution: SuSE 9.3 Pro/SuSE 10 Eval
Posts: 64

Rep: Reputation: 15
Thumbs down

Quote:
Originally Posted by carda View Post
O.k. after five hours of work (Argh!!) I got the Attensic L2 network chip on my ASUS board to work on my new out of the box CENTOS 5.2 installation with kernel 2.6.18-92.el5.

Here is a summary of what I found out, perhaps it helps people to save some time:

........

Hope this helps.

Benedikt.
Not so good for me I'm afraid. I downloaded the earlier version of the atheros driver, and it appears to compile perfectly. I can install the module with modprobe, but I don't see how your instructions will ever work after that?

I.e. there is no "link" established between the atl2 module and eth0. Normally you would put an alias into /etc/modprobe.conf
i.e. alias eth0 atl2, however, whilst this does at least make networking attempt to start the network (at boot time), eth0 is never
brought up successfully.

One thing I need to check is whether it is essential to have the MAC address in /etc/sysconfig/network-scripts/ifcfg-eth0 ? If so,
how can I find out this information? Please don't suggest I install windows :-)

So in short, I can only say that for me these instructions didn't work when installing Centos 5.2 x86_64 on an Asus P5K SE/EPU motherboard, which has the Atheros gigabit NIC.

Will report back if I have any success.

Cheers, Jon
 
Old 11-23-2008, 01:21 PM   #23
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
I just backported the current version of the atl2 driver in the mainline kernel to CentOS 5.2. Anyone willing to test it?

The instructions are simple. Copy this tarball to your home directory, then:
Code:
$ tar xzvf atlx-centos-5.2.tar.gz
$ cd atlx-centos-5.2
$ make
$ sudo make install
It compiles, but my CentOS box doesn't have an L1 or L2 NIC, so I can't test it.
 
Old 11-23-2008, 01:37 PM   #24
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Quote:
Originally Posted by skunkcabbage View Post
So in short, I can only say that for me these instructions didn't work when installing Centos 5.2 x86_64 on an Asus P5K SE/EPU motherboard, which has the Atheros gigabit NIC.
Jon,

Are you sure your motherboard contains an L2 NIC? I think it's fitted with the L1e NIC, which doesn't use the atl2 driver.

Please post the output of lspci -n.
 
Old 12-01-2008, 03:49 PM   #25
abelardy
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
Thumbs down

Quote:
Originally Posted by jcliburn View Post
I just backported the current version of the atl2 driver in the mainline kernel to CentOS 5.2. Anyone willing to test it?

The instructions are simple. Copy .... to your home directory, then:
Code:
$ tar xzvf atlx-centos-5.2.tar.gz
$ cd atlx-centos-5.2
$ make
$ sudo make install
It compiles, but my CentOS box doesn't have an L1 or L2 NIC, so I can't test it.
I can compile it under 2.6.18-92.cc4, but I don't think it works. Could be I screwed up somewhere, and I'm only 90% sure I know what I'm doing, but...

L2 NIC on an ASUS board, running ClarkConnect 4.3 community, based (I think) on CENTOS. Kernel 2.6.18-92.cc4. Was using the l2-linux-v1.0.40 driver which works, but only sort of - it suffers very frequent 'txs packet size do not coinsist with txd' errors, and intermittent transmit time outs, forcing a reconnect, and so transfer of large (>1Gb) files over e.g. SAMBA fails most of the time because the network drive link suddenly disappears.

So, I was keen to try a driver update...

Your backport compiles and installs, but on ifup (using the network script previously set up for the old driver) I get a message that the device doesn't seem to be present. Modinfo atl2 reports the module is present and installed. A reboot doesn't fix.

Last edited by abelardy; 12-01-2008 at 03:50 PM.
 
Old 12-01-2008, 06:51 PM   #26
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Thanks for trying it abelardy. It's not terribly surprising to learn it doesn't work. I'll poke at it when I get some free time.

What version of the vendor atl2 driver are you using when you get the "consist" error? Seems that a digit may be missing from the version number you provided. Was it supposed to be 1.0.40.4?

Last edited by jcliburn; 12-01-2008 at 06:52 PM.
 
Old 12-01-2008, 07:14 PM   #27
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Quote:
Originally Posted by abelardy View Post
I can compile it under 2.6.18-92.cc4, but I don't think it works.
Could you do me a huge favor and email the tarball to me at jcliburn at gmail dot com? I stupidly deleted it.
 
Old 12-01-2008, 07:49 PM   #28
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Quote:
Originally Posted by jcliburn View Post
Could you do me a huge favor and email the tarball to me at jcliburn at gmail dot com? I stupidly deleted it.
Never mind. I found another copy. Whew!
 
Old 12-01-2008, 09:06 PM   #29
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Quote:
Originally Posted by abelardy View Post
I can compile it under 2.6.18-92.cc4, but I don't think it works.
Okay, I found and fixed a major problem that prevented the device from properly registering with the kernel. Can you please try again? Download from the same link as before.

And thanks for testing.
 
Old 12-03-2008, 03:32 PM   #30
abelardy
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
atl2 on 2.6.18-92

Quote:
Originally Posted by jcliburn View Post
Okay, I found and fixed a major problem that prevented the device from properly registering with the kernel. Can you please try again? Download from the same link as before.
Thanks Jay,

That definitely works. Compiled, installed, worked first time and still working after 2 reboots.

Previous version was indeed l2-linux-v1.0.40.4 running (badly) on kernel 2.6.18-92.cc4.

In the last 5 months the Attansic Atheros atl2 driver version v1.0.40.4 caused 1788 unique instances of a 'NETDEV WATCH transmit timed out' error logged to /var/log/messages, with at least one such error occuring within any 24 hours of up time (range 1-214 in any one day), as well as a zillion 'packet size do not coinsist' errors and other signs of general ill-health. Most of the time this was barely noticeable at the user end, except for occasional slightly long pauses, and the more irritating Samba transfer failures with large files over a gigabyte.

Since switching to your 2.1.3 backported atlx driver still on 2.6.18-92.cc4, I've had zero such NIC-related errors in the last 36 hours.

______________________________________________
ASUS P5GX-MX/1333
Attansic Technology Corp. L2 100 Mbit Ethernet Adapter (rev a0)
ClarkConnect 4.3 Community Kernel 2.6.18-92.cc4
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2 Unable to activate Network device eth0 Wolfy Linux - Networking 21 10-29-2008 11:44 AM
Unable to activate eth0 - permissions gchandler Linux - Networking 4 07-16-2006 10:55 PM
Can't activate eth0 arme Linux - Networking 6 06-21-2004 08:57 PM
Unable to activate eth0 sined Fedora 1 06-13-2004 12:00 AM
eth0 will not activate reichhorn Linux - Networking 16 05-14-2004 01:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration