Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 06-10-2005, 09:26 PM   #1
Registered: Mar 2005
Location: Lancaster, PA
Distribution: Gentoo, Fedora Core
Posts: 39

Rep: Reputation: 15
Ultra slow gnome login on ubuntu linux. Suspected network issues

Hi everyone,

I recently installed Ubuntu linux, and it worked wonderfully until I started monkeying around with the network settings. My internet connection is through Verizon, ADSL, with the router using DHCP.

GNOME now takes about 10-15 minutes to login from the graphic login. It used to work in a few seconds.

I had tried to set a static network address from the network GUI, but I found that it didn't work (couldn't get on the internet) I tried to switch it back. I'd set it back to dhcp in the network GUI, but when I closed out the GUI, it would crash.

So, I edited the /etc/network/interfaces file by hand. Now, it takes this ridiculous amount of time to login to GNOME. I had also installed Firestarter at about the same time as monkeying with the settings, so I tried uninstalling it. Same problem.

Here's what I did in the /etc/network/interfaces file:

Had (after monkeying around):

iface lo inet loopback

iface eth0 inet static

auto eth0

Changed it to:

iface lo inet loopback

iface eth0 inet dhcp

auto eth0

One other interesting thing that I tried is to boot the computer, and before logging in at the GUI login interface, switch to tty1, login as root, and do:

ifdown -a
then, I'll switch back to tty7, and login. Everything logs in as it should. I also have internet access, even after doing the ifdown!

Old 06-11-2005, 06:20 AM   #2
Registered: Mar 2005
Location: Hilversum/Holland
Distribution: Debian GNU/Linux 5.0 (“Lenny”)
Posts: 290

Rep: Reputation: 31
I would change your ether card address to

As your netmask is and the router's IP is it will only allow connections from the range 192.168.1.[1-255] (0 excluded).

If your network doesn't has many machines you should use a static configurations as it goes up during the boot process
Old 06-11-2005, 08:45 AM   #3
Registered: Sep 2003
Distribution: ubuntu 5.04 knoppix Slack91/10 freebsd51 vector4 redhat9
Posts: 304

Rep: Reputation: 30
a bad network setting would slow down the bootup, I had the same problems when I try to share my 56k to other pc at home.

- for home network, use 192.168.x.x. subnet
- if your gateway/router is, then use 192.168.1.x for the clients ip.
- static ip is recommended. You can disable the dhcp server
- make sure both internet connection and lo is enabled in ifconfig

check this out. It saved my life:

Last edited by codec; 06-11-2005 at 08:47 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ultra slow browsing xila Slackware 8 06-18-2005 06:14 PM
Network Slow, giving random 404s, etc in AOL:Ubuntu-Hoary bengoodger Linux - Networking 0 05-31-2005 06:26 PM
[SOLVED] Ultra slow network eRJe Linux - Networking 7 05-04-2005 09:35 PM
Accounts with KDE/GNOME login issues (unable to read configs) hexbox Linux - Networking 1 01-31-2005 04:19 PM
Redhat GNOME runs slow when network is enabled gregpend Red Hat 2 10-08-2003 11:34 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration