-   Linux - Networking (
-   -   Ubuntu laptop recognizes but does not connect to HTC wifi hotspot on my android phone (

izquierdista 06-03-2012 12:21 PM

Ubuntu laptop recognizes but does not connect to HTC wifi hotspot on my android phone
Hello I have a laptop that has Ubuntu 12.04 LTS installed. For some odd reason I am unable to connect to my wireless HTC wifi hotspot eventhough my computer sees the network and has full bars but when I click on it to connect it doesnt establish a connection.

Here are the steps that I follow in order to try and connect:

1) I turn on my laptop
2) I turn on the HTC wifi hotspot on my Android cellphone (without any security settings)
3) I click on the wireless icon on my laptop and click on the HTC hotspot network
4) The icon shows the laptop trying to connect but after a few minutes no connection is established.

I would really appreciate any help thanks.

Didier Spaier 06-03-2012 12:54 PM

Try a manual connection so that you can see any error message:

Open a terminal and become root (sudo su)
Do steps 1) and 2) as prevously then:

3) type "ifconfig".
Among others you should see your wireless interface.
If not that means it is down. Then type e.g. "ifconfig <wireless interface name> up" to bring it up.
In my case wlan0 is the name of the wireless interface. If you you don't know its name and it doesn't show in the results of "ifconfig" (because it is down), the command "ifconfig -a" will tell you that name.

4) When the wireless interface is up type "iwlist <wireless interface name> scan".
Among others you should see your HTC wifi hotspot's network including its ESSID and it should show "Encryption key: off" as it has no security settings.

5) Then type "iwconfig <wireless interface name> essid <value read at step 5>
This shouls associate your wireless interface to your HTC wifi hotspot's network.

6) Type "dhcpcd wlan0" and hopefully the connection will be established.
In case Ubuntu doen't ship the "dhcpcd" app, use another DHCP client instead.

Let us know the outcome.

izquierdista 06-05-2012 10:56 AM

I Found the solution it was quite simple when I followed didiers advice I noticed that with iwlist the HTC Portable Hotspot would not show up eventhough the desktop wireless icon detected the network. I went ahead and shortened the name from HTC Portable Hotspot on my phone to HTC as the Network name and I was able to connect to "HTC" without a problem and now I can use my t-mobile phone as a hotspot :)

bbhopesh 06-08-2012 03:48 PM

I had a similar problem. I followed the steps given, my phone's hotspot name is sony. When I ran the ifconfig command, it didn't show any device named sony, When I ran ifconfig sony up, it gave error that no such device exists, while network manager was showing a network named sony. and ifconfig- a command also listed the names listed by ifconfig, no new name was there.
Can you please help me with this problem ?

All times are GMT -5. The time now is 04:14 AM.