LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-31-2009, 07:52 PM   #1
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Rep: Reputation: 0
ubuntu 9.04 desktop does not auto-reconnect into network after router reboot


When I power cycle the router (which is also the modem), the desktop initially shows that it lost the connection, and then attempts to connect to the router, and finally fails to connect (i.e., gives up). To make it connect again, I need to go into the network manager and manually request a connection.

I need the machine to autodetect that the router is back up again because I am going to be out of the home for an extended period, and need to connect into the home lan over the internet during this time. I was testing potential power-loss situations and how the lan will recover from these events. Would appreciate any suggestions on how I can get the desktop to autoconnect into the network once the network is up and running.

Thanks
neela
 
Old 06-01-2009, 05:00 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
I was going to reply to this yesterday but I had hoped that someone else with a better idea than I had would reply. I can see that this hasn't happened. This may be for the same reason that I hesitated to write, which is the following.

A Linux desktop machine should not notice if the router reboots. The Linux machine already has an IP address. Naturally it will not be able to use the network while the router is rebooting. Once the router is running the Linux machine should be able to carry on using the network without any interruption in service.

This leads me to ask what are you talking about when you say that the computer doesn't automatically reconnect to the network? Are you talking about network share connections as in SMB or NFS connected drives?
 
Old 06-01-2009, 08:12 PM   #3
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
I meant exactly what I said

The desktop notices when the router reboots.
I retested it just now.
I see the message

"Wired connection
Disconnected - you are now offline"

flash where the network manager icon is on the top left of the desktop.
This happens as soon as I unplug the router.

Then, when I replug the power for the router, I see the desktop attempting to reconnect. After probably a minute or so of trying, it fails, and shows the same message as above if I place the cursor on top of the icon again. Also, by this time, the Auto eth0 check box, which was previously checked, becomes unchecked -- it was checked when the desktop was trying to renegotiate the connection.

When I re-check the Auto eth0 box (left click of the network manager icon), the desktop reconnects again.

Thank you very much for your attention -- I have been anxiously logging in and checking every hour or so..
 
Old 06-01-2009, 08:57 PM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
I'm very glad to help if I can.

I believe that I understand the problem now. You have some kind of network monitoring application in your desktop. It is possible that if we can turn this off your computer will work as I described.

Do you know which distribution of Linux you are running and what desktop environment or window manager you are using?
 
Old 06-01-2009, 09:03 PM   #5
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
Standard install of Ubuntu 9.04 from ISO image

Installed openssh etc, but no specific networking tweaks -- I don't know how to make any tweaks :-). Just a stock install from a few days ago.

Just to be clear, I am not complaining about the auto detection. I would also like to have auto-connect. Then the system needs no attention while I am trying to connect in across the internet.

Last edited by neela77777; 06-01-2009 at 09:13 PM.
 
Old 06-01-2009, 09:04 PM   #6
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Which distribution are you using? For example you could be using Ubuntu or Fedora Core or OpenSuse or Debian or Slackware etc.

Last edited by stress_junkie; 06-01-2009 at 09:09 PM.
 
Old 06-01-2009, 09:15 PM   #7
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
I had this in the subject line of my previous reply:

Standard install of Ubuntu 9.04 from ISO image
 
Old 06-01-2009, 09:40 PM   #8
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Okay. I see now that the information was in the subject line of reply #5 and in the subject line of the original post. I guess you put me in my place rather than simply answering the question. Good luck.

Last edited by stress_junkie; 06-01-2009 at 09:42 PM.
 
Old 06-01-2009, 09:48 PM   #9
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
My intent was not to put you in place -- quite obviously, I am asking for help. I just mentioned this to tell you that I didn't ignore your question. Would still appreciate your help.
 
Old 06-01-2009, 10:22 PM   #10
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,247
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
I would remove network-manager and install wicd in it's place.
http://wicd.sourceforge.net/screenshot.php

see the last screenshot that has the check box for auto reconnect on connection loss.. not sure how many times it will try to reconnect before it gives up, so if the router takes too long to come up it still may not work.. but it's worth a shot. personally I can't stand network-manager anyway. wicd is more my style.

sudo apt-get remove network-manager network-manager-gnome
sudo apt-get install wicd


You must remove network-manager or wicd will not work.

wicd is in the Ubuntu universe repository



and neela you should update your profile to include your distro.. it will make it easier for people to assist you. even though you may mention it in the subject, we are used to seeing it in the profile or plainly stated in the body of the original post. will avoid future misunderstanding, as only Internet forums and chat can provide...

Cheers !!
 
Old 06-01-2009, 10:55 PM   #11
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
Thank you very much. I will try that. And will change my profile.
 
Old 06-02-2009, 02:20 PM   #12
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
I have a follow up question:
I installed WICD and removed Network Manager as per your suggestion on two desktops -- both with Ubuntu 9.04 (one is a dual boot).

Both of them auto reconnect when router reboots. Thank you very much for this.

Interestingly, one of the desktops (the one that is not a dual boot -- this is a Dell Vostro -- does not autoconnect at system startup (i.e., boot). The other machine which is a HP, auto connects into the network at boot time. They both have identical setup in the WICD client, but seem to have slight differences in their boot setup. This is in fact surprising as both the Ubuntu 9.04s were installed at the same time from ISO with no networking modifications done on either one. Part of the log file from the session that "did not" autoconnect at boot is pasted below..

2009/06/02 14:39:25 :: ---------------------------
2009/06/02 14:39:25 :: wicd initializing...
2009/06/02 14:39:25 :: ---------------------------
2009/06/02 14:39:25 :: Couldn't detect a wireless interface.
2009/06/02 14:39:25 :: found wireless_interface in configuration
2009/06/02 14:39:25 :: setting wireless interface
2009/06/02 14:39:25 :: automatically detected wired interface eth0
2009/06/02 14:39:25 :: found wired_interface in configuration eth0
2009/06/02 14:39:25 :: setting wired interface eth0
2009/06/02 14:39:25 :: found wpa_driver in configuration wext
2009/06/02 14:39:25 :: setting wpa driver wext
2009/06/02 14:39:25 :: found always_show_wired_interface in configuration True
2009/06/02 14:39:25 :: found use_global_dns in configuration False
2009/06/02 14:39:25 :: setting use global dns to False
2009/06/02 14:39:25 :: setting use global dns to boolean False
2009/06/02 14:39:25 :: found global_dns_1 in configuration None
2009/06/02 14:39:25 :: found global_dns_2 in configuration None
2009/06/02 14:39:25 :: found global_dns_3 in configuration None
2009/06/02 14:39:25 :: setting global dns
2009/06/02 14:39:25 :: global dns servers are None None None
2009/06/02 14:39:25 :: found auto_reconnect in configuration True
2009/06/02 14:39:25 :: setting automatically reconnect when connection drops
2009/06/02 14:39:25 :: found debug_mode in configuration 0
2009/06/02 14:39:25 :: found wired_connect_mode in configuration 1
2009/06/02 14:39:25 :: found signal_display_type in configuration 0
2009/06/02 14:39:25 :: found dhcp_client in configuration 0
2009/06/02 14:39:25 :: Setting dhcp client to 0
2009/06/02 14:39:25 :: found link_detect_tool in configuration 0
2009/06/02 14:39:25 :: found flush_tool in configuration 0
2009/06/02 14:39:25 :: Wireless configuration file found...
2009/06/02 14:39:25 :: Wired configuration file found...
2009/06/02 14:39:25 :: chmoding configuration files 0600...
2009/06/02 14:39:25 :: chowning configuration files root:root...
2009/06/02 14:39:25 :: Using wired interface...eth0
2009/06/02 14:39:25 :: Using wireless interface...
2009/06/02 14:39:25 :: autoconnecting...
2009/06/02 14:39:28 :: No wired connection present, attempting to autoconnect to wireless network
2009/06/02 14:39:28 :: Unable to autoconnect, you'll have to manually connect
2009/06/02 14:39:58 :: GetWiredProperty: WiredNetwork does not exist
2009/06/02 14:40:03 :: Putting interface down
2009/06/02 14:40:03 :: Releasing DHCP leases...
2009/06/02 14:40:03 :: Setting false IP...
2009/06/02 14:40:03 :: Stopping wpa_supplicant and any DHCP clients
2009/06/02 14:40:03 :: Flushing the routing table...
2009/06/02 14:40:03 :: Putting interface up...
2009/06/02 14:40:03 :: Running DHCP
2009/06/02 14:40:03 :: Internet Systems Consortium DHCP Client V3.1.1
2009/06/02 14:40:03 :: Copyright 2004-2008 Internet Systems Consortium.
2009/06/02 14:40:03 :: All rights reserved.
2009/06/02 14:40:03 :: For info, please visit http://www.isc.org/sw/dhcp/
2009/06/02 14:40:03 ::


Looks like the network card is not up at the time the WICD daemon is starting up.

I am able to manually connect from the client tho ..

Any suggestions?

Thanks again.
 
Old 06-02-2009, 03:49 PM   #13
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,247
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
Glad that worked out for you with the reconnect.

So what wireless is in the Vostro ? lspci and are you using a native Linux driver (preferred) or ndiswrapper (yuck) ?

I would look in /etc/rc2,d for the wicd startup script, then rename it to a higher number so it starts later ..
something like:
mv /etc/rc2.d/S20wicd /etc/rc2.d/S40wicd

that will cause the wicd daemon to start later during the boot sequence and hopefully your network module is loaded by then. you can experiment with the number.

Looking at the numbers of the other scripts in that folder may also show you where your wireless module is being loaded. maybe S24hal is loading the wireless module so wicd at 30 would be sufficient..
 
Old 06-02-2009, 04:19 PM   #14
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
The Vostro is used with a wired connection -- it is a desktop. I am not exactly sure if it has any wireless.

How do I figure out which of the scripts is loading the wired network connection please?lrwxrwxrwx 1 root root 19 2009-05-30 15:36 S01policykit -> ../init.d/policykit
lrwxrwxrwx 1 root root 15 2009-05-30 15:36 S10acpid -> ../init.d/acpid
lrwxrwxrwx 1 root root 18 2009-05-30 15:36 S10sysklogd -> ../init.d/sysklogd
lrwxrwxrwx 1 root root 15 2009-05-30 15:36 S11klogd -> ../init.d/klogd
lrwxrwxrwx 1 root root 14 2009-05-30 15:36 S12dbus -> ../init.d/dbus
lrwxrwxrwx 1 root root 13 2009-05-30 17:03 S16ssh -> ../init.d/ssh
lrwxrwxrwx 1 root root 16 2009-05-30 15:36 S20apport -> ../init.d/apport
lrwxrwxrwx 1 root root 18 2009-05-30 17:14 S20ddclient -> ../init.d/ddclient
lrwxrwxrwx 1 root root 22 2009-05-30 15:36 S20hotkey-setup -> ../init.d/hotkey-setup
lrwxrwxrwx 1 root root 15 2009-05-30 16:21 S20jetty -> ../init.d/jetty
lrwxrwxrwx 1 root root 14 2009-06-02 00:37 S20wicd -> ../init.d/wicd
lrwxrwxrwx 1 root root 13 2009-05-30 15:36 S24hal -> ../init.d/hal
lrwxrwxrwx 1 root root 19 2009-05-30 15:36 S25bluetooth -> ../init.d/bluetooth
lrwxrwxrwx 1 root root 13 2009-05-30 15:36 S30gdm -> ../init.d/gdm
lrwxrwxrwx 1 root root 22 2009-05-30 15:36 S50avahi-daemon -> ../init.d/avahi-daemon
lrwxrwxrwx 1 root root 14 2009-05-30 15:36 S50cups -> ../init.d/cups
lrwxrwxrwx 1 root root 20 2009-05-30 15:36 S50pulseaudio -> ../init.d/pulseaudio
lrwxrwxrwx 1 root root 15 2009-05-30 15:36 S50rsync -> ../init.d/rsync
lrwxrwxrwx 1 root root 15 2009-05-30 15:36 S50saned -> ../init.d/saned
lrwxrwxrwx 1 root root 31 2009-05-30 15:36 S50system-tools-backends -> ../init.d/system-tools-backends
lrwxrwxrwx 1 root root 21 2009-05-30 15:36 S70bootlogs.sh -> ../init.d/bootlogs.sh
lrwxrwxrwx 1 root root 19 2009-05-30 15:36 S70dns-clean -> ../init.d/dns-clean
lrwxrwxrwx 1 root root 18 2009-05-30 15:36 S70pppd-dns -> ../init.d/pppd-dns
lrwxrwxrwx 1 root root 17 2009-05-30 15:36 S89anacron -> ../init.d/anacron
lrwxrwxrwx 1 root root 13 2009-05-30 15:36 S89atd -> ../init.d/atd
lrwxrwxrwx 1 root root 14 2009-05-30 15:36 S89cron -> ../init.d/cron
lrwxrwxrwx 1 root root 24 2009-05-30 15:36 S90binfmt-support -> ../init.d/binfmt-support
lrwxrwxrwx 1 root root 17 2009-05-30 15:36 S98usplash -> ../init.d/usplash
lrwxrwxrwx 1 root root 22 2009-05-30 15:36 S99acpi-support -> ../init.d/acpi-support
lrwxrwxrwx 1 root root 21 2009-05-30 15:36 S99laptop-mode -> ../init.d/laptop-mode
lrwxrwxrwx 1 root root 18 2009-05-30 15:36 S99ondemand -> ../init.d/ondemand
lrwxrwxrwx 1 root root 18 2009-05-30 15:36 S99rc.local -> ../init.d/rc.local
lrwxrwxrwx 1 root root 19 2009-05-30 15:36 S99rmnologin -> ../init.d/rmnologin
lrwxrwxrwx 1 root root 24 2009-05-30 15:36 S99stop-readahead -> ../init.d/stop-readahead


Thanks
 
Old 06-02-2009, 05:09 PM   #15
neela77777
LQ Newbie
 
Registered: May 2009
Distribution: Ubuntu 9.04
Posts: 11

Original Poster
Rep: Reputation: 0
I tried /etc/rc2.d/S40wicd and /etc/rc2.d/S99wicd.
Both didn't help.

Thought I could try the 1.6.0b3 version -- they claim to have solved some autoconnect issues -- but I am not sure how to install it from the download..

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Network auto reconnect brim4brim Linux - Newbie 0 06-22-2005 11:06 PM
pftpfxp auto reconnect behade Linux - Software 4 01-12-2005 10:25 AM
ISP auto reconnect problem lumpfish Linux - Networking 0 07-29-2003 10:43 AM
Auto-Reconnect JC404 Linux - Newbie 3 07-01-2003 04:04 PM
want auto-reconnect off in wvdial marlaina1 Linux - General 2 03-18-2002 04:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration