-   Linux - Networking (
-   -   Ubuntu 10.04 won't actually connect to wireless network (

RealGomer 07-26-2010 08:30 PM

Ubuntu 10.04 won't actually connect to wireless network
I've just finished doing the basic install of Ubuntu 10.04. I have the SSID, password, etc. set up for my wireless network. The network icon will show the PC is connected to the network but I can't connect to the internet. I'm using a Zoom 4411 Wireless-N USB adapter which works fine under Windows. I DL'd the driver files (rt2780) from Ralink using the Windows partition but they need to be compiled(the topic for another query.)Since I can't connect, I can't get Buildessential or Checkinstall. Any suggestions?

Peacedog 07-26-2010 09:16 PM

Hi RealGomer, Welcome to LQ. Did you do a "full" install? If not, are the tools you need on your installation media? Alternatively, you could download the needed tools via the Windows partition and save them to a usb stick. Just some ideas.

Good luck. ;-)

jschiwal 07-26-2010 09:32 PM

Look at the output of "lsmod". Is "rt2x00usb" listed?
Post the output of the "ifconfig" command.
Also the output of "route" and "cat /etc/resolv.conf"

There could be other problems besides your device not working that can prevent you from accessing the internet.
1) Do you have a working device?
2) Are you Authenticated to the wireless network?
3) Do you have an IP address via DHCP
4) Is the route configured correctly.
5) Are the name servers listed in /etc/resolv.conf

GallopingGhost 07-27-2010 03:56 PM

I am also unable to find any wireless networks although I know they are there as the Windows partition is able to connect to the Internet. However, is the fact I booted from a Live CD the reason why I cannot connect?

EDIT: Fully installed it and still no connection. No worries I'm sure I'll figure it out

RealGomer 07-27-2010 06:16 PM

Ubuntu 10.04 won't connect
I just put the iso cd in the drive and let it have at it.
I'll try the steps mentioned by jschiwal. The connection works just fine under Windows. Would the IP being outside the range of the home network be part of the problem? The dongle is 127. etc, but the home network is 198. etc.

Peacedog 07-27-2010 08:39 PM

Please post the output from the commands jschiwal asked for.

Good luck. ;-)

GallopingGhost 07-27-2010 11:38 PM

I am proud to say I am typing this via a wireless connection. I hadn't installed the driver located at System -> Administration-> Hardware Drivers. Once I did that I was able to connect

Peacedog 07-28-2010 11:35 AM

GallopingGhost, Glad you got that sorted.

RealGomer, If you could, please post the output asked for previously so we have more insight to the problem.

Good luck. ;-)

RealGomer 07-28-2010 03:58 PM

Ubuntu 10.04 won't connect to wireles
Here's the output. I had lost the connection in Windows and discovered it was because of the updated drivers being flaky.
I'm going to see what's in the directory that show-off (:D) Galloping Ghost used.

Module Size Used by
nls_utf8 1069 1
isofs 29250 1
binfmt_misc 6587 1
fbcon 35102 71
tileblit 2031 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
vga16fb 11385 0
vgastate 8961 1 vga16fb
snd_intel8x0 25588 2
snd_ac97_codec 100646 1 snd_intel8x0
ac97_bus 1002 1 snd_ac97_codec
snd_pcm_oss 35308 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_pcm 70662 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 1338 0
snd_seq_oss 26726 0
snd_seq_midi 4557 0
snd_rawmidi 19056 1 snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
rt2870sta 461811 0
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
arc4 1153 2
radeon 674135 3
rt2800usb 31531 0
snd_timer 19098 2 snd_pcm,snd_seq
rt2x00usb 9703 1 rt2800usb
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
joydev 8708 0
ttm 49943 1 radeon
rt2x00lib 27509 2 rt2800usb,rt2x00usb
led_class 2864 1 rt2x00lib
drm_kms_helper 29297 1 radeon
mac80211 204922 2 rt2x00usb,rt2x00lib
ppdev 5259 0
ns558 3056 0
snd 54148 14 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_ti mer,snd_seq_device
usbhid 36110 0
hid 67032 1 usbhid
drm 162471 5 radeon,ttm,drm_kms_helper
i2c_algo_bit 5028 1 radeon
cfg80211 126485 2 rt2x00lib,mac80211
crc_ccitt 1339 1 rt2800usb
amd64_agp 7025 1
gameport 9089 2 ns558
soundcore 6620 1 snd
k8temp 3024 0
parport_pc 25962 1
agpgart 31724 3 ttm,drm,amd64_agp
i2c_nforce2 5199 0
snd_page_alloc 7076 2 snd_intel8x0,snd_pcm
shpchp 28820 0
lp 7028 0
parport 32635 3 ppdev,parport_pc,lp
skge 35683 0
floppy 53016 0
pata_amd 8766 3

~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:0d:61:68:d7:81
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:104 errors:0 dropped:0 overruns:0 frame:0
TX packets:104 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8192 (8.1 KB) TX bytes:8192 (8.1 KB)

wlan0 Link encap:Ethernet HWaddr 00:40:36:3c:0a:d9
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Peacedog 07-28-2010 04:43 PM

It appears there are 2 modules are loaded.


rt2870sta 461811 0
rt2800usb 31531 0
rt2x00usb 9703 1 rt2800usb
rt2x00lib 27509 2 rt2800usb,rt2x00usb

I'd try blacklisting one of them. Typically if there is more than one module loaded, none of them will function. I believe this chip requires firmware also.

Good luck. ;-)

RealGomer 07-29-2010 01:28 PM

Right. I blacklisted rt2800usb. I'm getting a message that asks for the password to unlock the login keyring. That's nice. I don't remember setting a password for the login keyring, whatever that is. Interestingly enough, Windows shows the drivers as being rt2870 but Zoom tech support says, "According to engineering ....the wireless n uses the following
4411 use Ralink RT-3070L 1x1." I'm so confu-u-u-used.
Now what?

Peacedog 07-29-2010 09:20 PM

That may actually be a good sign. It's likely the networkmanager attempting to use the stored Wifi key, which, you haven't stored yet. Try deleting the keyring file and rebooting.


rm .gnome2/keyrings/login.keyring
Upon reboot you should asked for your network password, WEP key, etc.

Good luck. ;-)

RealGomer 07-30-2010 12:48 PM

4411 won't connect to net in U10.04
I tried to make the changes suggested by deleting the keyring info:

rm .gnome2/keyrings/login.keyring

I used Terminal. I get a popup asking for my keyring password. MY wireless is now named as Auto Trail (my network name). Still, no internet access. If I click on the network icon, I get a message the network is disconnected.

Now what?

Peacedog 07-30-2010 12:59 PM

There may be two files in there, sorry, I don't run Ubunutu. Try this file.


rm .gnome2/keyrings/default.keyring
It appears as if the wireless is now working and finding your AP, you just need to connect to it and pull an IP.

Good luck. ;-)

Peacedog 07-30-2010 01:03 PM

Found these tutorials of interest.

Good luck. ;-)

All times are GMT -5. The time now is 06:46 PM.