-   Linux - Networking (
-   -   Two network interfaces on Slackware (

djake 06-28-2008 01:54 PM

Two network interfaces on Slackware

I've got a frustrating network problem since I upgraded my desktop computer. I now have an Asus M2A-MX motherboard with an integrated network controller, but I also have a PCI network card. I've used two network cards on Slackware for a time without problem, they have appeared as eth0 and eth1, respectively, but after the upgrade I now have eth1 and eth0_rename, the integrated one as eth1.

Any idea about the eth0_rename interface? Why does it not appear as eth0?

MS3FGX 06-28-2008 03:26 PM

That is pretty odd. Is the second Ethernet interface configured in rc.inet1.conf? Was this a clean install of Slackware 12.1 or an upgrade?

djake 06-29-2008 05:04 AM

Odd, yes indeed. They are both configured in rc.inet1.conf but that doesn't have any effect on the names of the interfaces. I've used Slackware since 11.0 and always upgraded, maybe I should try a clean install?

MS3FGX 06-29-2008 02:54 PM

Perhaps. You are sure there aren't any *.new files laying around under /etc, right?

djake 06-29-2008 04:04 PM

I tried to change the network PCI-card to another, and that actually solved the problem. However, thank you for your answers!

All times are GMT -5. The time now is 05:04 AM.