LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-14-2007, 01:49 PM   #1
glza
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Rep: Reputation: 0
two interfaces on feisty


i've got a dual-lan mobo on feisty, and it seems i can't get them to both be on at the same time...

how can i get both my interfaces working at the same time?

$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:70:2A:32:CD
inet addr:192.168.0.235 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:224469 errors:0 dropped:0 overruns:0 frame:0
TX packets:233075 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:30080796 (28.6 MiB) TX bytes:141876417 (135.3 MiB)
Base address:0x9000 Memory:e5000000-e5020000

eth1 Link encap:Ethernet HWaddr 00:50:70:23:32:E8
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1396709 errors:0 dropped:0 overruns:0 frame:0
TX packets:1469122 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:136741391 (130.4 MiB) TX bytes:975540577 (930.3 MiB)
Interrupt:17 Base address:0x8000

eth1:avah Link encap:Ethernet HWaddr 00:50:70:23:32:E8
inet addr:169.254.6.234 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:17 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5614 errors:0 dropped:0 overruns:0 frame:0
TX packets:5614 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:638307 (623.3 KiB) TX bytes:638307 (623.3 KiB)


then if i enable eth1 using the network manager applet:

$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:70:2A:32:CD
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:225417 errors:0 dropped:0 overruns:0 frame:0
TX packets:234187 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:30430685 (29.0 MiB) TX bytes:142016377 (135.4 MiB)
Base address:0x9000 Memory:e5000000-e5020000

eth1 Link encap:Ethernet HWaddr 00:50:70:23:32:E8
inet addr:192.168.0.242 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1396899 errors:0 dropped:0 overruns:0 frame:0
TX packets:1469125 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:136765250 (130.4 MiB) TX bytes:975541321 (930.3 MiB)
Interrupt:17 Base address:0x8000

eth0:avah Link encap:Ethernet HWaddr 00:50:70:2A:32:CD
inet addr:169.254.6.120 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Base address:0x9000 Memory:e5000000-e5020000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5622 errors:0 dropped:0 overruns:0 frame:0
TX packets:5622 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:639411 (624.4 KiB) TX bytes:639411 (624.4 KiB)

i want them to both run at the same time -- but the network manager only allows me to choose one... this seems ridiculous to me -- why isn't it a checkbox instead of a radio button and why can't i get this to work?
 
Old 06-15-2007, 10:02 AM   #2
crazyivan
Member
 
Registered: Mar 2007
Distribution: Debian, Ubuntu server
Posts: 40

Rep: Reputation: 15
Can you post the result of:
Code:
cat /etc/network/interfaces
 
Old 06-15-2007, 10:54 AM   #3
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,155

Rep: Reputation: Disabled
Quote:
i want them to both run at the same time -- but the network manager only allows me to choose one... this seems ridiculous to me -- why isn't it a checkbox instead of a radio button and why can't i get this to work?
This "Network Manager" knows something you don't - you can't have two NIC's on same subnet (search Google for bond+NIC if you really need this).
 
Old 06-15-2007, 11:53 AM   #4
glza
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Original Poster
Rep: Reputation: 0
$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp


i'd hate to bring up the 'w' word, but i can do it on that operating system... do they do something i'm not aware of?
 
Old 06-15-2007, 12:01 PM   #5
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,155

Rep: Reputation: Disabled
I'm not sure how you do it in Windows, somehow I do not believe it works properly. Unless they do bonding in Windows without telling you what's going on. Sure, you can assign addresses to your NIC's manually in Linux and have them on same subnet but it's not going to work as desired, it won't double your bandwith.
 
Old 06-15-2007, 12:55 PM   #6
glza
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Original Poster
Rep: Reputation: 0
oh -- i'm not trying to double bandwidth or anything like that. here's what i'm trying to do:

i have one nic as my normal, firewalled connection -- on all the time

have the other nic on the router's dmz (already set up) and turn it on whenever i need it (troubleshooting, or if i need unrestricted access to the internet NOW)

i'd like to be able to enable the second nic at will, and still have the other nic up at the same time...
 
Old 06-15-2007, 12:57 PM   #7
glza
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Original Poster
Rep: Reputation: 0
or even to be able to forward certain ports, like all bittorrenting done through one nic and everything else through the other...
 
Old 06-16-2007, 06:25 AM   #8
crazyivan
Member
 
Registered: Mar 2007
Distribution: Debian, Ubuntu server
Posts: 40

Rep: Reputation: 15
It seems that ETH1 (your second NIC) is getting a self-assigned IP address 169.254.6.234. If you look in /etc/network/interfaces you can see it is sitting there and waiting for an IP address from a DHCP server. Are you running one on the LAN NIC ETH1 is located in?
 
Old 06-16-2007, 09:16 PM   #9
glza
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Original Poster
Rep: Reputation: 0
yup -- i have the router (which runs the dhcp)passing out addresses to my network based on MAC address, it gives 192.168.0.235 to one nic, and 192.168.0.242 to the other nic (the one that's on the dmz)the set up works wonderfully... i just want eth1 to get an ip address when i $ifconfig eth1 up
 
Old 06-16-2007, 09:37 PM   #10
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,155

Rep: Reputation: Disabled
If you want just to have two IP addresses for one box I'd use aliasing on eth0, it works on same subnet.
 
Old 06-19-2007, 03:23 AM   #11
glza
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Original Poster
Rep: Reputation: 0
emerson, it works swimmingly in windows -- no doubt about it. i can enable/disable network interfaces at will, each with different settings if i want to...

i don't want to alias eth0 when i have a perfectly good network interface in eth1.

so no one knows how to do this, is what i'm reading...

Last edited by glza; 06-19-2007 at 03:25 AM.
 
Old 06-19-2007, 08:09 AM   #12
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,155

Rep: Reputation: Disabled
1. Aliasing is the way to do it, it saves you one NIC, one cable and one port in network switch.
2. Despite it makes no sense and it is not a valid IP configuration you still can do it. Please note: DHCP is only configuration helper, in most cases static configuration works better (I see you use static via DHCP - why not simply static?). Obviously the GUI tools are useless in this case. You have to run your DHCP client manually on eth1 or - much better and simpler - assign static IP addresses to both NIC's (or at least to eth1). Then activating and deactivating it is simply the matter of running "sudo ifconfig eth1 up/down". You can create icons on your desktop to issue these commands.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What do you think of Feisty Fawn? mikieboy Ubuntu 24 06-23-2007 02:54 PM
feisty and wireless connection unisol Linux - Wireless Networking 1 06-01-2007 03:58 PM
Upgrade to feisty problems bdiddy84 Linux - Newbie 5 04-29-2007 09:12 PM
Feisty iPod Help progrock Ubuntu 0 04-25-2007 06:45 PM
Feisty Fawn- Ready or not? darklight55 Ubuntu 2 01-12-2007 01:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration